Extension specific outbound caller ID not working

I’m running FreePBX Ver 13.0.95 and finding that setting the “Outbound CID” in the extensions general tab doesnt seem to be doing anything. I have tried various settings in the field and then grep’d all files in the /etc/asterisk dir and do not find anything (this is after saving and applying the change). Setting it in the trunk or the outbound route works as expected, but I want to set individual CIDs. Can someone point me to where/how it should be getting set. If it’s in an agi script, then which one (if its there then grepping probably wont find it as it would be likely using the database).

I cant see any other way this can be disabled apart from overriding it in either the outbound route or the trunk (both are empty).

Any suggestions ?

These are set in the asterisk db. Which is not the freepbx db.

Hi Andrew,

Thanks for the reply. It wasn’t quite what I was expecting but I have managed to locate where my caller ID’s are being set (sort of). Your hint was a big help.

If I create the following in extensions_custom.conf

exten => s,1,Set(CALLERID(name)=12345678)
exten => s,n,MacroExit

then I can set the callerid name to what I want. The problem is that it doesn’t seem to matter what I set the freepbx Outbound CID to, it gets overwritten by the freepbx display name. I have tried the following in the outbound cid


All with the same result (ie no change to outbound CID).

If you know if another way to set this then great. If not, then I’ll do it in AGI (dirty but at least it works).


When you say “Outbound Caller ID”, are you referring to Caller ID Name or Caller ID Number? You PBX will set both on an outbound call, but phone providers notoriously throw out the CID Name and only deliver the CID Number when terminating calls.

@lgaetz is right, plus the destination’s CNAM process may disregard your set caller ID name and supply their own, even if yours is perfectly reasonable. Caller ID on the receiving end is completely out of your (or any of our) control.

If you check your logs, are the values getting set the way you want them? If that isn’t happening (the wrong Caller ID info is getting sent) you might need to dive into a custom context to get this working the way you want.

Yes, you’re both correct.

I ended up having to script what I needed. I use 2 providers and they both want caller id in different formats. One wants country prefix-area code-number and the other wants area code-number. Any deviation causes no CID to be sent.

All working now anyway.

Thanks again.