Error installing FreePBX on Late 2014 Mac Mini

Tried installing both 32bit and 64bit versions of Stable-6.12.65 and Stable-5.211.65 32bit
on two new late 2014 mac mini’s i5, 4GB RAM.

I used the ISO’s burned to a DVD and a LG external DVD-ROM.
I get an error message at the beginning stating that the hardware is incompatible and a link to THe installation proceeds and ultimately completes without any other errors.
When the system reboots itself i get a GRU Grub screen and a command prompt. The error states :

Error 28 : Selected item cannot fit into memory

Typing anything at the “grub>” prompt returns symbols instead of letters.
I’ve installed this on previous model Mac Mini’s without issues.
Has anyone experienced this before?

Is it x86 or ppc…

PowerPC processors went away almost 10 years ago if I’m not mistaken.

The good old days… Looks like the minis (except the G4) have all been x86. I think the g4 may have been the last mini I touched…

Quick google…

This error arises when grub asks for the amount of memory from the motherboard and gets back an undesirable number (such as 0).

Check for BIOS updates and see if there are any memory related settings you can play with in the BIOS.

This is the 4th Gen intel i5 processor. I wonder what the system differences is between this model and the previous model. Is there anyway to modify the EFI (This system doesnt have a BIOS)

TBH, I am not sure how to answer this question. The processor is a 4th Gen Intel i5.

Any tips on why an install of the latest Sangoma OS SNG7-FPBX-64bit-1904-2 is failing on a Mac Mini?

The error is that "requested boot drive “/dev/disk/by-id/usb-sandisk-extreme_aa…” doesn’t exist or cannot be used.

The Mac Mini’s hard disk, a 150gb disk is shown with an [x] in the box next to it but is for whatever reason not cutting the mustard either?!


The error about disk seems to be the issue. It references a USB disk. Have you tried writing the image to a USB pen drive instead of a usb cdrom?

Boot with a live linux rescue cd/iso/usb that supports efi
explore the drive itself with

ls -lR /dev/disk/

identify the disk and clear out the first 1M bytes of the device to get rid of any strange partitioning.

As mac’s use efi not bios, there might be something not easy to fix, so something like

might help, but replace the ubuntu image iso with the one you want, that also supports efi booting.

Good Luck

I would avoid the issues with bare metal and run ESXi on the Mac Mini. Then run FreePBX as a VM.

Is that free software? I notice there’s something called “free vSphere Hypervisor edition”?

I’m slowly making progress with this ridiculous task I’ve set myself. I’ve found THIS document which details how to run Ubuntu on my Mac Mini so I’m currently downloading that. This is my plan:-

– Run Ubuntu from a live USB stick made possible thanks to the above 32bit EFI workaruond
– Wipe the hard disk completely
– Then investigate whether I can re-run the Sangoma Live USB stick and install the Sangoma OS successfully.

I’m a bit worried that once the OS is installed the Mac Mini won’t boot it, is there any way I could know in advance? It’s a 64 bit version of the software I’ve downloaded because while my Mac Mini IS a Core 2 Duo, it has 32bit EFI.


There is a free license available. I ditched actual Apple hardware years ago for reasons related to yours and now use all “hackintoshes”. The Mac Mini is VMWare certified and should run ESXi without issue. Linux on the other hand is not officially supported. That’s why I suggest virtualization for your project.

So, just updating everyone and no one on my quest.

I dynamically created a new partition on my Mac’s HDD from within Mac OS X using Disk Utility.

I was then able to tell the SangomaOS install that I wanted to use the HDD and I was all set to delete the partitions, create new mount points etc etc etc.

However at the point of creating a root password, I got a popup box saying:

“the package grub2-efi-ia32 is required does not exist”

I had to quit the installer. I’m left with nothing on the disk at all (Mac OS X partition has been wiped).

I figured this was a potential outcome of a failed install so it’s no biggie.

Current master plan is downloading CentOS “Everything” (a 10gb ISO) because apparently this install can cope with 32bit EFI but a 64bit system.


Centos is down-line from RedHat, RedHat is now (or will be soon) down-line from IBM, don’t paint yourself into a corner :wink:


Debian (also Ubuntu) have attested to that scenario

then maybe

FINALLY got Ubuntu 14 installed. FWIW, It was the ubuntu-14.04.3-desktop-amd64+mac ISO which finally worked (when booted off a DVD).

So now I have a vanilla Ubuntu GUI install. I’m wondering if I should have gone for server rather than desktop?!

I guess I could reinstall…?

No, the desktop is fine and pretty low impact on that hardware even when running, even advantageous if you ever want to drill through a firewall and get to internal phone’s html pages,

apt-get install xrdp

you then can use rdesktop or m$ remote desktop on port 3389

and to stop the gui starting on boot

systemctl set-default

( now just waiting for the cries of OhNo!!! you can’t do that from those who have never “done that” :wink: . . .),

Thanks. And then I just follow this?

Does anyone know (who would be the person to ask?) whether there is a SangomaOS which is capable of BIOS legacy mode? This is an excellent write up of the hardware situation.

If not, I might take a shot at modifying the Sangoma ISO

You might end up with a bogus (!) in the first line of /etc/asterisk/asterisk.conf but otherwise it works well , maybe a problem with libicu-dev on this OS so UCP wont install.

Modifying the SangomaOS ISO with isomacprog seems to be allowing me to install it just by popping the disc in and pressing next, next, next

Fingers crossed! (Ubuntu wiped)

This poor Mac…it won’t know whether it’s coming or going.

Install of SangomaOS in progress.