EPM not showing anywhere near a recent firmware .eff for Digium unless I'm missing something?

Am I missing something? When I use EPM, it seems to downgrade the firmware on my phone. When I look at the list of available firmware in EPM on FreePBX, the latest is 1.17, whereas the latest firmware for the D50 is 2.8.4.

Am I missing something? Feel I must be!

No, that’s the bundle, drag it into one of the slots and you should see the firmware for each model.

(1.17 has D50 2_8_2)

From https://wiki.asterisk.org/wiki/display/DIGIUM/Firmware#Firmware-PhoneFirmwareDownloads seems that 2.8.2 is the latest, unless I am missing something…

2.8.2 is stable and 2.8.4 is beta. Thanks for showing me about the bundles.

If you want that version you can install it manually.

see wiki: https://wiki.freepbx.org/display/FPG/EPM-Admin+User+Guide#EPM-AdminUserGuide-InstallingCustomFirmware

Yep, I’m there now with the firmware stuff and EPM.

Do you use EPM and a Digium D series?

Things that aren’t working for me at the moment:

  • Logo upload
  • Intercom/paging
  • Call park/visual voicemail
  • Correct time zone

Do you experience this?

I am not trying to be rude, I just want you to understand the the community here are all volunteers.
I understand that you are having trouble with getting your phone’s to work, but please don’t act aggressive and hijack 3 year old topics, this is resulting contributes to not check in very often, nobody likes coming to a place where they feel like they are arguing when all they want is trying to help you and the rest of the community.

Both answers I posted in this topic are very well documented in the wiki, which makes me assume you didn’t even try to Google these questions before posting here, but I might be wrong.

I hope I didn’t come across wrong.

Anyway, who am I to lecture…?

Now back to the issue. No, I don’t use Digium Phones (yet)

However, did you upgrade firmware to the latest version yet? and is your FreePBX on the latest version?

2 Likes

I’m sorry if I’m coming across this way - not my intention. I have been frustrated in the last couple of days I freely admit. But my main aim and wish is to constructively work with Sangoma and the community. I’ll try to wind my neck in! I don’t know about hijacking topics, I thought what I’d posted was (still) fully relevant to the topic in hand but if this isn’t the case, I’m sorry for this too!

I’ve been Googling like crazy!! :smiley: and searching this forum like crazy, too. At one point I got so disillusioned with the obstacles I was coming up against I got slack with checking against the documentation because a) I’d developed the view that any perceived bugs were definitely bugs, and the firmware thing definitely falls into that category - I noticed it later on in my problems and presumed it was a bug and b) I’d found the documentation to be wrong or out of date in places so lost faith in that too.

Yes, I’m either currently on or have tried latest/edge/beta all the things! :slight_smile:

I’m sorry for my bad/questionable netiquette and will try harder! I’m not normally a pest…not my intention to be one here! :slight_smile:

And to confirm the below issues are still existing? (Assuming you’re on FreePBX 14, and assuming with ‘Beta’ you are referring to the phones. (Did you confirm if the phones actually upgraded firmware?))

If so, then.
Logo upload: Can be a number of reasons why it’s not working, image is not the right size or format, the provisioning protocol etc. Maybe start by trying to manually upload the logo to the phone to see if it’s working and then try the same file in EPM.

Intercom/paging: As another user mentioned in a different topic, try playing in the phone GUI with the auto answer settings to work with speaker, and then make the necessary basefile changes in EPM.

Call park/visual voicemail: Not sure how you configured callpark, but VV is probably a phoneapps issue, make sure you can access the XML files on the port you specified, make sure phone apps is installed/licensed.

Correct time zone: Is the timezone on the server (does the PBX display the right time in SystemAdmin?) and the EPM template set right? Could be it’s a network issue where the phones have trouble reaching the time server?
Can you set the right timezone manually?

Yep, phones definitely are on latest. Have checked in ‘About’ on the phone itself.

Intercom/paging still not working, and I’ve tried the fix here but it doesn’t seem to make a difference. Interestingly, in MY logs, the intercom call doesn’t show as

<http://127.0.0.1>\;info=ring-answer
but
<http://127.0.0.1><uri>;answer-after=0) first
then
<http://127.0.0.1>;info=ring-answer (note the lack of a slash)

Call park WORKS on DPMA and doesn’t work on EPM
Visual voicemail WORKS on DPMA and doesn’t work on EPM without additional tweaking; I’m not sure
Timezones - not inherited from server on DPMA - not sure if there’s a setting I’m missing??

That was the first thing I did - the logo works fine if it’s uploaded to the phone’s web GUI. It is also accepted without complaint by both the DPMA GUI and the EPM GUI. But the only way to get it onto the phone (I’ve so far discovered) is to manually upload it, which you can’t do if you’re using DPMA or EPM - AFAIK.

Can’t find/see any auto answer settings in the phone’s GUI for this? Preferences>Call answering doesn’t show anything related to auto answering.

Timezone IS correct on the server. (I’m using DPMA at the moment not EPM). I CAN correct the timezone on each phone individually, yes.

Thank you for your help. :slight_smile:

Interestingly, this is what my res_digium_phone_devices.conf looks like (showing just one extension)

I notice:

there’s no timezone specified, no logo specified, no firmware, and the external phonebook entries aren’t shown either, only internal.

My …devices.conf looks really different to this one here. So possibly that’s the answer as to why the phone isn’t picking up this info - it isn’t being asked to by the module??

[20]
type=phone
full_name=Garage
parking_exten=70
parking_transfer_type=blind
active_locale=en_GB
application=voicemail
line=20
send_to_vm=yes
record_own_calls=yes
use_local_storage=yes
contact=contacts-internal.xml
blf_items=blf-internal.php?lines=1
blf_contact_group=Internal Phonebook
network=network--1
8021x_method=
application=status-available
application=status-chat
application=status-away
application=status-dnd
application=status-xa
application=status-unavailable

EDIT: Just noticed - there’s no custom ‘alert’ stuff in there either - now, I might be getting ahead of myself here, because for all I know, that custom alert stuff could be stored in another file entirely or passed to the phone in another way entirely, but if not, is that possibly why intercom functionality is reported broken at the moment by me and several others?

hmm, just trying different possibilities, I tried manually inserting these lines for a given (single) extension alongside all the other GUI generated lines:

d50_logo_file=user_image_1.png
timezone=Europe/London
web_ui_enabled=yes

and it resulted in that extension no longer being presented to me as an option on a D50 when “select your name and extension” is shown

Thanks for the information. Maybe I did something wrong, (but the FreePBX web GUI reported the beta firmware (2.8.4) was successfully instated). Anyway the phone wouldn’t download and install the beta firmware - first it said (straight away) 214% loaded then seconds later it simply failed
IMG_0961 IMG_0962

I’ve since told it to go back to the ‘recommended’ firmware (2.8.2) and it’s now stuck in a reboot loop where everytime it boots it ‘updates’ the software again.

As said, I never played with Digium Phones (yet) so I can’t answer…

Maybe @malcolmd can

Thanks. And I think @dolesec is investigating. Hopefully! :slight_smile:
Because of the firmware boot loop I encountered with EPM, I’ve again gone back to DPMA.
I would REALLY appreciate some help from Sangoma as soon as someone there is available to assist :slight_smile: :slight_smile: