Endpoint manager free version for Sangoma phones won't install


(Coulon Laurent) #1

Hello

I have a small-sized installation with only 2 extensions so use the free distro of Freepbx running on Debian.

Today i bought x3 Sangoma wired phones ( S705 - S305 ) and x1 Sangoma DECT (DC10M + DC201)

I tryed to install Endpoint manager to set up these new phones in free version as i read Endpoint manager might be free when used with Sangoma phones but process is unable to proceed as “PHP Component Zend Guard Loader” is required.

System Admin is also mandatory to get Endpoint managed installed, but when trying to install System Admin, i get the following message :

Errors with selection:

  • System Admin cannot be installed:
    * PHP Component Zend Guard Loader is required but missing from you PHP installation.
    • The File “/usr/sbin/incrond” must exist.
    Please try again after the dependencies have been installed.

No actions to perform

So i’m stuck when installing System Admin and PHP Component Zend Guard Loader component is also not listed into available downloads.

Many thanks for your help and advices,


(Charles Darwin) #2

#3

Yes Endpoint Manager is free for use with Sangoma Phones but the module is a Commercial Module which is only supported on the FreePBX Distro not Debian. If you install the official Distro then Zend Guard Loader will be installed and the System Admin module will be there.

Link to Distro: https://www.freepbx.org/downloads/freepbx-distro/