Distro Upgrade Error

Hi,

I’m getting an error when running system upgrade or yum upgrade:

[[email protected] ~]# yum update
Loaded plugins: fastestmirror, versionlock
Determining fastest mirrors
sng-base                                                                                                                                                  | 3.6 kB  00:00:00     
sng-epel                                                                                                                                                  | 3.2 kB  00:00:00     
sng-extras                                                                                                                                                | 3.4 kB  00:00:00     
sng-pkgs                                                                                                                                                  | 3.4 kB  00:00:00     
sng-updates                                                                                                                                               | 3.4 kB  00:00:00     
(1/8): sng-base/7/x86_64/group_gz                                                                                                                         | 166 kB  00:00:00     
(2/8): sng-epel/7/x86_64/group_gz                                                                                                                         |  88 kB  00:00:00     
(3/8): sng-base/7/x86_64/primary_db                                                                                                                       | 5.9 MB  00:00:00     
(4/8): sng-epel/7/x86_64/updateinfo                                                                                                                       | 933 kB  00:00:00     
(5/8): sng-epel/7/x86_64/primary                                                                                                                          | 3.6 MB  00:00:00     
(6/8): sng-extras/7/x86_64/primary_db                                                                                                                     | 205 kB  00:00:00     
(7/8): sng-updates/7/x86_64/primary_db                                                                                                                    | 6.0 MB  00:00:00     
(8/8): sng-pkgs/7/x86_64/primary_db                                                                                                                       | 664 kB  00:00:00     
sng-epel                                                                                                                                                             12642/12642
Resolving Dependencies
--> Running transaction check
---> Package audit.x86_64 0:2.8.1-3.el7 will be updated
---> Package audit.x86_64 0:2.8.1-3.el7_5.1 will be an update
---> Package audit-libs.x86_64 0:2.8.1-3.el7 will be updated
---> Package audit-libs.x86_64 0:2.8.1-3.el7_5.1 will be an update
---> Package bind-libs.x86_64 32:9.9.4-61.el7 will be updated
---> Package bind-libs.x86_64 32:9.9.4-61.el7_5.1 will be an update
---> Package bind-libs-lite.x86_64 32:9.9.4-61.el7 will be updated
---> Package bind-libs-lite.x86_64 32:9.9.4-61.el7_5.1 will be an update
---> Package bind-license.noarch 32:9.9.4-61.el7 will be updated
---> Package bind-license.noarch 32:9.9.4-61.el7_5.1 will be an update
---> Package bind-utils.x86_64 32:9.9.4-61.el7 will be updated
---> Package bind-utils.x86_64 32:9.9.4-61.el7_5.1 will be an update
---> Package device-mapper-multipath.x86_64 0:0.4.9-119.el7 will be updated
---> Package device-mapper-multipath.x86_64 0:0.4.9-119.el7_5.1 will be an update
---> Package device-mapper-multipath-libs.x86_64 0:0.4.9-119.el7 will be updated
---> Package device-mapper-multipath-libs.x86_64 0:0.4.9-119.el7_5.1 will be an update
---> Package dracut.x86_64 0:033-535.el7 will be updated
---> Package dracut.x86_64 0:033-535.el7_5.1 will be an update
---> Package dracut-network.x86_64 0:033-535.el7 will be updated
---> Package dracut-network.x86_64 0:033-535.el7_5.1 will be an update
---> Package firewalld.noarch 0:0.4.4.4-14.el7 will be updated
---> Package firewalld.noarch 0:0.4.4.4-15.el7_5 will be an update
---> Package firewalld-filesystem.noarch 0:0.4.4.4-14.el7 will be updated
---> Package firewalld-filesystem.noarch 0:0.4.4.4-15.el7_5 will be an update
---> Package ghostscript.x86_64 0:9.07-28.el7_4.2 will be updated
---> Package ghostscript.x86_64 0:9.07-29.el7_5.2 will be an update
---> Package initscripts.x86_64 0:9.49.41-1.el7 will be updated
---> Package initscripts.x86_64 0:9.49.41-1.el7_5.2 will be an update
---> Package java-1.8.0-openjdk.x86_64 1:1.8.0.181-3.b13.el7_5 will be updated
---> Package java-1.8.0-openjdk.x86_64 1:1.8.0.191.b12-0.el7_5 will be an update
---> Package java-1.8.0-openjdk-headless.x86_64 1:1.8.0.181-3.b13.el7_5 will be updated
---> Package java-1.8.0-openjdk-headless.x86_64 1:1.8.0.191.b12-0.el7_5 will be an update
---> Package kernel.x86_64 0:3.10.0-862.14.4.el7 will be installed
---> Package kernel-headers.x86_64 0:3.10.0-862.9.1.el7 will be updated
---> Package kernel-headers.x86_64 0:3.10.0-862.14.4.el7 will be an update
---> Package kexec-tools.x86_64 0:2.0.15-13.el7 will be updated
---> Package kexec-tools.x86_64 0:2.0.15-13.el7_5.2 will be an update
---> Package kpartx.x86_64 0:0.4.9-119.el7 will be updated
---> Package kpartx.x86_64 0:0.4.9-119.el7_5.1 will be an update
---> Package libblkid.x86_64 0:2.23.2-52.el7 will be updated
---> Package libblkid.x86_64 0:2.23.2-52.el7_5.1 will be an update
---> Package libmount.x86_64 0:2.23.2-52.el7 will be updated
---> Package libmount.x86_64 0:2.23.2-52.el7_5.1 will be an update
---> Package libuuid.x86_64 0:2.23.2-52.el7 will be updated
---> Package libuuid.x86_64 0:2.23.2-52.el7_5.1 will be an update
---> Package mariadb.x86_64 1:5.5.56-2.el7 will be updated
---> Package mariadb.x86_64 1:5.5.60-1.el7_5 will be an update
---> Package mariadb-libs.x86_64 1:5.5.56-2.el7 will be updated
---> Package mariadb-libs.x86_64 1:5.5.60-1.el7_5 will be an update
---> Package mariadb-server.x86_64 1:5.5.56-2.el7 will be updated
---> Package mariadb-server.x86_64 1:5.5.60-1.el7_5 will be an update
---> Package mokutil.x86_64 0:12-1.el7.centos will be updated
---> Package mokutil.x86_64 0:12-2.el7 will be an update
---> Package nss.x86_64 0:3.36.0-5.el7_5 will be updated
---> Package nss.x86_64 0:3.36.0-7.el7_5 will be an update
---> Package nss-sysinit.x86_64 0:3.36.0-5.el7_5 will be updated
---> Package nss-sysinit.x86_64 0:3.36.0-7.el7_5 will be an update
---> Package nss-tools.x86_64 0:3.36.0-5.el7_5 will be updated
---> Package nss-tools.x86_64 0:3.36.0-7.el7_5 will be an update
---> Package python-firewall.noarch 0:0.4.4.4-14.el7 will be updated
---> Package python-firewall.noarch 0:0.4.4.4-15.el7_5 will be an update
---> Package python-perf.x86_64 0:3.10.0-862.9.1.el7 will be updated
---> Package python-perf.x86_64 0:3.10.0-862.14.4.el7 will be an update
---> Package python36u.x86_64 0:3.6.4-1.ius.centos7 will be updated
---> Package python36u.x86_64 0:3.6.7-1.ius.centos7 will be an update
---> Package python36u-libs.x86_64 0:3.6.4-1.ius.centos7 will be updated
---> Package python36u-libs.x86_64 0:3.6.7-1.ius.centos7 will be an update
---> Package python36u-setuptools.noarch 0:36.6.0-1.ius.centos7 will be updated
---> Package python36u-setuptools.noarch 0:39.0.1-1.ius.centos7 will be an update
---> Package selinux-policy.noarch 0:3.13.1-192.el7_5.4 will be updated
---> Package selinux-policy.noarch 0:3.13.1-192.el7_5.6 will be an update
---> Package selinux-policy-targeted.noarch 0:3.13.1-192.el7_5.4 will be updated
---> Package selinux-policy-targeted.noarch 0:3.13.1-192.el7_5.6 will be an update
---> Package shim-x64.x86_64 0:12-1.el7.centos will be updated
---> Package shim-x64.x86_64 0:12-2.el7 will be an update
---> Package systemd.x86_64 0:219-57.el7 will be updated
---> Package systemd.x86_64 0:219-57.el7_5.3 will be an update
---> Package systemd-libs.x86_64 0:219-57.el7 will be updated
---> Package systemd-libs.x86_64 0:219-57.el7_5.3 will be an update
---> Package systemd-sysv.x86_64 0:219-57.el7 will be updated
---> Package systemd-sysv.x86_64 0:219-57.el7_5.3 will be an update
---> Package tuned.noarch 0:2.9.0-1.el7 will be updated
---> Package tuned.noarch 0:2.9.0-1.el7_5.2 will be an update
---> Package tzdata.noarch 0:2018e-3.el7 will be updated
---> Package tzdata.noarch 0:2018f-2.el7 will be an update
---> Package tzdata-java.noarch 0:2018e-3.el7 will be updated
---> Package tzdata-java.noarch 0:2018f-2.el7 will be an update
---> Package util-linux.x86_64 0:2.23.2-52.el7 will be updated
---> Package util-linux.x86_64 0:2.23.2-52.el7_5.1 will be an update
---> Package yum.noarch 0:3.4.3-158.7.sng7 will be updated
---> Package yum.noarch 0:3.4.3-161.9.sng7 will be an update
--> Finished Dependency Resolution
--> Running transaction check
---> Package kernel.x86_64 0:3.10.0-693.21.1.el7 will be erased
--> Processing Dependency: kernel(napi_complete_done) = 0x905307be for package: kmod-via-rhine-1.5.2-1.sng7.x86_64
--> Processing Dependency: kernel(napi_complete_done) = 0x905307be for package: kmod-via-velocity-1.16-1.sng7.x86_64
--> Running transaction check
---> Package kmod-via-rhine.x86_64 0:1.5.2-1.sng7 will be erased
--> Processing Dependency: kmod-via-rhine for package: sangoma-pbx-1902-3.sng7.noarch
---> Package kmod-via-velocity.x86_64 0:1.16-1.sng7 will be erased
--> Running transaction check
---> Package sangoma-pbx.noarch 0:1902-3.sng7 will be erased
--> Finished Dependency Resolution
Error: Trying to remove "sangoma-pbx", which is protected

Any ideas?

Thanks in advance.

Downgrade velocity and rhine two times then upgrade.

1 Like

Yep, that did it.

Many thanks for your help.

Andrew,
I’m getting the same issue - I did downgrade both velocity and rhine (2 times) still getting:
Error: Package: libblockdev-fs-2.12-3.el7.x86_64 (@sng-base)
Requires: libblockdev-utils(x86-64) = 2.12-3.el7
Removing: libblockdev-utils-2.12-3.el7.x86_64 (@sng-base)
libblockdev-utils(x86-64) = 2.12-3.el7
Updated By: libblockdev-utils-2.18-3.el7.x86_64 (sng-pkgs)
libblockdev-utils(x86-64) = 2.18-3.el7
Error: Package: libblockdev-mdraid-2.12-3.el7.x86_64 (@sng-base)
Requires: libblockdev-utils(x86-64) = 2.12-3.el7
Removing: libblockdev-utils-2.12-3.el7.x86_64 (@sng-base)
libblockdev-utils(x86-64) = 2.12-3.el7
Updated By: libblockdev-utils-2.18-3.el7.x86_64 (sng-pkgs)
libblockdev-utils(x86-64) = 2.18-3.el7
Error: Package: libblockdev-loop-2.12-3.el7.x86_64 (@sng-base)
Requires: libblockdev-utils(x86-64) = 2.12-3.el7
Removing: libblockdev-utils-2.12-3.el7.x86_64 (@sng-base)
libblockdev-utils(x86-64) = 2.12-3.el7
Updated By: libblockdev-utils-2.18-3.el7.x86_64 (sng-pkgs)
libblockdev-utils(x86-64) = 2.18-3.el7
Error: Package: libblockdev-crypto-2.12-3.el7.x86_64 (@sng-base)
Requires: libblockdev-utils(x86-64) = 2.12-3.el7
Removing: libblockdev-utils-2.12-3.el7.x86_64 (@sng-base)
libblockdev-utils(x86-64) = 2.12-3.el7
Updated By: libblockdev-utils-2.18-3.el7.x86_64 (sng-pkgs)
libblockdev-utils(x86-64) = 2.18-3.el7
Error: Package: libblockdev-2.12-3.el7.x86_64 (@sng-base)
Requires: libblockdev-utils(x86-64) = 2.12-3.el7
Removing: libblockdev-utils-2.12-3.el7.x86_64 (@sng-base)
libblockdev-utils(x86-64) = 2.12-3.el7
Updated By: libblockdev-utils-2.18-3.el7.x86_64 (sng-pkgs)
libblockdev-utils(x86-64) = 2.18-3.el7
Error: Package: libblockdev-swap-2.12-3.el7.x86_64 (@sng-base)
Requires: libblockdev-utils(x86-64) = 2.12-3.el7
Removing: libblockdev-utils-2.12-3.el7.x86_64 (@sng-base)
libblockdev-utils(x86-64) = 2.12-3.el7
Updated By: libblockdev-utils-2.18-3.el7.x86_64 (sng-pkgs)
libblockdev-utils(x86-64) = 2.18-3.el7
Error: Package: libblockdev-part-2.12-3.el7.x86_64 (@sng-base)
Requires: libblockdev-utils(x86-64) = 2.12-3.el7
Removing: libblockdev-utils-2.12-3.el7.x86_64 (@sng-base)
libblockdev-utils(x86-64) = 2.12-3.el7
Updated By: libblockdev-utils-2.18-3.el7.x86_64 (sng-pkgs)
libblockdev-utils(x86-64) = 2.18-3.el7
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Andrew (sorry replied to the wrong person)

I’m getting the same issue - I did downgrade both velocity and rhine (2 times) still getting (after running "yum upgrade:):

Error: Package: libblockdev-fs-2.12-3.el7.x86_64 (@sng-base)
Requires: libblockdev-utils(x86-64) = 2.12-3.el7
Removing: libblockdev-utils-2.12-3.el7.x86_64 (@sng-base)
libblockdev-utils(x86-64) = 2.12-3.el7
Updated By: libblockdev-utils-2.18-3.el7.x86_64 (sng-pkgs)
libblockdev-utils(x86-64) = 2.18-3.el7
Error: Package: libblockdev-mdraid-2.12-3.el7.x86_64 (@sng-base)
Requires: libblockdev-utils(x86-64) = 2.12-3.el7
Removing: libblockdev-utils-2.12-3.el7.x86_64 (@sng-base)
libblockdev-utils(x86-64) = 2.12-3.el7
Updated By: libblockdev-utils-2.18-3.el7.x86_64 (sng-pkgs)
libblockdev-utils(x86-64) = 2.18-3.el7
Error: Package: libblockdev-loop-2.12-3.el7.x86_64 (@sng-base)
Requires: libblockdev-utils(x86-64) = 2.12-3.el7
Removing: libblockdev-utils-2.12-3.el7.x86_64 (@sng-base)
libblockdev-utils(x86-64) = 2.12-3.el7
Updated By: libblockdev-utils-2.18-3.el7.x86_64 (sng-pkgs)
libblockdev-utils(x86-64) = 2.18-3.el7
Error: Package: libblockdev-crypto-2.12-3.el7.x86_64 (@sng-base)
Requires: libblockdev-utils(x86-64) = 2.12-3.el7
Removing: libblockdev-utils-2.12-3.el7.x86_64 (@sng-base)
libblockdev-utils(x86-64) = 2.12-3.el7
Updated By: libblockdev-utils-2.18-3.el7.x86_64 (sng-pkgs)
libblockdev-utils(x86-64) = 2.18-3.el7
Error: Package: libblockdev-2.12-3.el7.x86_64 (@sng-base)
Requires: libblockdev-utils(x86-64) = 2.12-3.el7
Removing: libblockdev-utils-2.12-3.el7.x86_64 (@sng-base)
libblockdev-utils(x86-64) = 2.12-3.el7
Updated By: libblockdev-utils-2.18-3.el7.x86_64 (sng-pkgs)
libblockdev-utils(x86-64) = 2.18-3.el7
Error: Package: libblockdev-swap-2.12-3.el7.x86_64 (@sng-base)
Requires: libblockdev-utils(x86-64) = 2.12-3.el7
Removing: libblockdev-utils-2.12-3.el7.x86_64 (@sng-base)
libblockdev-utils(x86-64) = 2.12-3.el7
Updated By: libblockdev-utils-2.18-3.el7.x86_64 (sng-pkgs)
libblockdev-utils(x86-64) = 2.18-3.el7
Error: Package: libblockdev-part-2.12-3.el7.x86_64 (@sng-base)
Requires: libblockdev-utils(x86-64) = 2.12-3.el7
Removing: libblockdev-utils-2.12-3.el7.x86_64 (@sng-base)
libblockdev-utils(x86-64) = 2.12-3.el7
Updated By: libblockdev-utils-2.18-3.el7.x86_64 (sng-pkgs)
libblockdev-utils(x86-64) = 2.18-3.el7
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Different issue.

You are on sangoma-devel. yum remove sangoma-devel

Andrew,
OK … did β€œyum remove sangoma-devel” , cleaned the yum cache and ran as many updates as possible manually. The following all failed to update:

RPM Name New Version Installed Version
anaconda-core.x86_64 21.48.22.147-8.sng7 21.48.22.134.6.sng7
anaconda-gui.x86_64 21.48.22.147-8.sng7 21.48.22.134.6.sng7
anaconda-tui.x86_64 21.48.22.147-8.sng7 21.48.22.134.6.sng7
anaconda-widgets.x86_64 21.48.22.147-8.sng7 21.48.22.134.6.sng7
kernel.x86_64 3.10.0-862.14.4.el7 3.10.0.862.9.1.el7
kernel-headers.x86_64 3.10.0-862.14.4.el7 3.10.0.862.9.1.el7
libblockdev-utils.x86_64 2.18-3.el7 2.12.3.el7

The same error as above: (yes I did disable the dev repo:

[[email protected] asterisk]# yum remove sangoma-devel
Loaded plugins: fastestmirror, versionlock
No Match for argument: sangoma-devel
No Packages marked for removal

Any thoughts? Thank you for your help.

yum clean all
yum upgrade

Hi Andrew,
Did all of the suggestions above … unfortunately still getting the same error.
Regards

I’ve seen a bunch of errors today so please help me out and just post the error here.

Since this is your first time posting to this thread I doubt you have the β€œsame error”

Sorry Andrew…
oaded plugins: fastestmirror, langpacks, versionlock
Loading mirror speeds from cached hostfile
Resolving Dependencies
–> Running transaction check
β€”> Package anaconda-core.x86_64 0:21.48.22.134-6.sng7 will be updated
β€”> Package anaconda-core.x86_64 0:21.48.22.147-8.sng7 will be an update
–> Processing Dependency: python-subprocess32 for package: anaconda-core-21.48.22.147-8.sng7.x86_64
–> Processing Dependency: libblockdev-nvdimm for package: anaconda-core-21.48.22.147-8.sng7.x86_64
β€”> Package anaconda-gui.x86_64 0:21.48.22.134-6.sng7 will be updated
β€”> Package anaconda-gui.x86_64 0:21.48.22.147-8.sng7 will be an update
β€”> Package anaconda-tui.x86_64 0:21.48.22.134-6.sng7 will be updated
β€”> Package anaconda-tui.x86_64 0:21.48.22.147-8.sng7 will be an update
β€”> Package anaconda-widgets.x86_64 0:21.48.22.134-6.sng7 will be updated
β€”> Package anaconda-widgets.x86_64 0:21.48.22.147-8.sng7 will be an update
β€”> Package asterisk-version-switch.noarch 0:5.1-2.sng7 will be updated
β€”> Package asterisk-version-switch.noarch 0:5.2-1.sng7 will be an update
β€”> Package htop.x86_64 0:2.2.0-1.el7 will be updated
β€”> Package htop.x86_64 0:2.2.0-3.el7 will be an update
β€”> Package incron.x86_64 0:0.5.10-10.sng7 will be updated
β€”> Package incron.x86_64 1:0.5.10-11.sng7 will be an update
β€”> Package libblockdev-utils.x86_64 0:2.12-3.el7 will be updated
–> Processing Dependency: libblockdev-utils(x86-64) = 2.12-3.el7 for package: libblockdev-mdraid-2.12-3.el7.x86_64
–> Processing Dependency: libblockdev-utils(x86-64) = 2.12-3.el7 for package: libblockdev-fs-2.12-3.el7.x86_64
–> Processing Dependency: libblockdev-utils(x86-64) = 2.12-3.el7 for package: libblockdev-swap-2.12-3.el7.x86_64
–> Processing Dependency: libblockdev-utils(x86-64) = 2.12-3.el7 for package: libblockdev-2.12-3.el7.x86_64
–> Processing Dependency: libblockdev-utils(x86-64) = 2.12-3.el7 for package: libblockdev-loop-2.12-3.el7.x86_64
–> Processing Dependency: libblockdev-utils(x86-64) = 2.12-3.el7 for package: libblockdev-part-2.12-3.el7.x86_64
–> Processing Dependency: libblockdev-utils(x86-64) = 2.12-3.el7 for package: libblockdev-crypto-2.12-3.el7.x86_64
β€”> Package libblockdev-utils.x86_64 0:2.18-3.el7 will be an update
β€”> Package openvpn.x86_64 0:2.4.6-1.el7 will be updated
β€”> Package openvpn.x86_64 0:2.4.7-1.el7 will be an update
β€”> Package pykickstart.noarch 0:1.99.66.18-1.el7 will be updated
β€”> Package pykickstart.noarch 0:1.99.66.19-2.el7 will be an update
β€”> Package python-blivet.noarch 1:0.61.15.69-1.el7 will be updated
β€”> Package python-blivet.noarch 1:0.61.15.72-1.el7 will be an update
–> Processing Dependency: python-blockdev for package: 1:python-blivet-0.61.15.72-1.el7.noarch
β€”> Package redis.x86_64 0:3.2.12-1.el7 will be updated
β€”> Package redis.x86_64 0:3.2.12-2.el7 will be an update
–> Running transaction check
β€”> Package libblockdev-nvdimm.x86_64 0:2.18-3.el7 will be installed
–> Processing Dependency: ndctl for package: libblockdev-nvdimm-2.18-3.el7.x86_64
–> Processing Dependency: libndctl.so.6(LIBNDCTL_3)(64bit) for package: libblockdev-nvdimm-2.18-3.el7.x86_64
–> Processing Dependency: libndctl.so.6(LIBNDCTL_1)(64bit) for package: libblockdev-nvdimm-2.18-3.el7.x86_64
–> Processing Dependency: libndctl.so.6()(64bit) for package: libblockdev-nvdimm-2.18-3.el7.x86_64
β€”> Package libblockdev-utils.x86_64 0:2.12-3.el7 will be updated
–> Processing Dependency: libblockdev-utils(x86-64) = 2.12-3.el7 for package: libblockdev-mdraid-2.12-3.el7.x86_64
–> Processing Dependency: libblockdev-utils(x86-64) = 2.12-3.el7 for package: libblockdev-fs-2.12-3.el7.x86_64
–> Processing Dependency: libblockdev-utils(x86-64) = 2.12-3.el7 for package: libblockdev-swap-2.12-3.el7.x86_64
–> Processing Dependency: libblockdev-utils(x86-64) = 2.12-3.el7 for package: libblockdev-2.12-3.el7.x86_64
–> Processing Dependency: libblockdev-utils(x86-64) = 2.12-3.el7 for package: libblockdev-loop-2.12-3.el7.x86_64
–> Processing Dependency: libblockdev-utils(x86-64) = 2.12-3.el7 for package: libblockdev-part-2.12-3.el7.x86_64
–> Processing Dependency: libblockdev-utils(x86-64) = 2.12-3.el7 for package: libblockdev-crypto-2.12-3.el7.x86_64
β€”> Package python2-blockdev.x86_64 0:2.12-3.el7 will be installed
β€”> Package python2-subprocess32.x86_64 0:3.2.6-12.el7 will be installed
–> Running transaction check
β€”> Package libblockdev-utils.x86_64 0:2.12-3.el7 will be updated
–> Processing Dependency: libblockdev-utils(x86-64) = 2.12-3.el7 for package: libblockdev-mdraid-2.12-3.el7.x86_64
–> Processing Dependency: libblockdev-utils(x86-64) = 2.12-3.el7 for package: libblockdev-fs-2.12-3.el7.x86_64
–> Processing Dependency: libblockdev-utils(x86-64) = 2.12-3.el7 for package: libblockdev-swap-2.12-3.el7.x86_64
–> Processing Dependency: libblockdev-utils(x86-64) = 2.12-3.el7 for package: libblockdev-2.12-3.el7.x86_64
–> Processing Dependency: libblockdev-utils(x86-64) = 2.12-3.el7 for package: libblockdev-loop-2.12-3.el7.x86_64
–> Processing Dependency: libblockdev-utils(x86-64) = 2.12-3.el7 for package: libblockdev-part-2.12-3.el7.x86_64
–> Processing Dependency: libblockdev-utils(x86-64) = 2.12-3.el7 for package: libblockdev-crypto-2.12-3.el7.x86_64
β€”> Package ndctl.x86_64 0:58.2-3.el7 will be installed
–> Processing Dependency: daxctl-libs(x86-64) = 58.2-3.el7 for package: ndctl-58.2-3.el7.x86_64
–> Processing Dependency: libdaxctl.so.1(LIBDAXCTL_5)(64bit) for package: ndctl-58.2-3.el7.x86_64
–> Processing Dependency: libdaxctl.so.1(LIBDAXCTL_4)(64bit) for package: ndctl-58.2-3.el7.x86_64
–> Processing Dependency: libdaxctl.so.1(LIBDAXCTL_3)(64bit) for package: ndctl-58.2-3.el7.x86_64
–> Processing Dependency: libdaxctl.so.1(LIBDAXCTL_2)(64bit) for package: ndctl-58.2-3.el7.x86_64
–> Processing Dependency: libdaxctl.so.1()(64bit) for package: ndctl-58.2-3.el7.x86_64
β€”> Package ndctl-libs.x86_64 0:58.2-3.el7 will be installed
–> Running transaction check
β€”> Package daxctl-libs.x86_64 0:58.2-3.el7 will be installed
β€”> Package libblockdev-utils.x86_64 0:2.12-3.el7 will be updated
–> Processing Dependency: libblockdev-utils(x86-64) = 2.12-3.el7 for package: libblockdev-mdraid-2.12-3.el7.x86_64
–> Processing Dependency: libblockdev-utils(x86-64) = 2.12-3.el7 for package: libblockdev-fs-2.12-3.el7.x86_64
–> Processing Dependency: libblockdev-utils(x86-64) = 2.12-3.el7 for package: libblockdev-swap-2.12-3.el7.x86_64
–> Processing Dependency: libblockdev-utils(x86-64) = 2.12-3.el7 for package: libblockdev-2.12-3.el7.x86_64
–> Processing Dependency: libblockdev-utils(x86-64) = 2.12-3.el7 for package: libblockdev-loop-2.12-3.el7.x86_64
–> Processing Dependency: libblockdev-utils(x86-64) = 2.12-3.el7 for package: libblockdev-part-2.12-3.el7.x86_64
–> Processing Dependency: libblockdev-utils(x86-64) = 2.12-3.el7 for package: libblockdev-crypto-2.12-3.el7.x86_64
–> Finished Dependency Resolution
Error: Package: libblockdev-fs-2.12-3.el7.x86_64 (@sng-base)
Requires: libblockdev-utils(x86-64) = 2.12-3.el7
Removing: libblockdev-utils-2.12-3.el7.x86_64 (@sng-base)
libblockdev-utils(x86-64) = 2.12-3.el7
Updated By: libblockdev-utils-2.18-3.el7.x86_64 (sng-pkgs)
libblockdev-utils(x86-64) = 2.18-3.el7
Error: Package: libblockdev-mdraid-2.12-3.el7.x86_64 (@sng-base)
Requires: libblockdev-utils(x86-64) = 2.12-3.el7
Removing: libblockdev-utils-2.12-3.el7.x86_64 (@sng-base)
libblockdev-utils(x86-64) = 2.12-3.el7
Updated By: libblockdev-utils-2.18-3.el7.x86_64 (sng-pkgs)
libblockdev-utils(x86-64) = 2.18-3.el7
Error: Package: libblockdev-loop-2.12-3.el7.x86_64 (@sng-base)
Requires: libblockdev-utils(x86-64) = 2.12-3.el7
Removing: libblockdev-utils-2.12-3.el7.x86_64 (@sng-base)
libblockdev-utils(x86-64) = 2.12-3.el7
Updated By: libblockdev-utils-2.18-3.el7.x86_64 (sng-pkgs)
libblockdev-utils(x86-64) = 2.18-3.el7
Error: Package: libblockdev-crypto-2.12-3.el7.x86_64 (@sng-base)
Requires: libblockdev-utils(x86-64) = 2.12-3.el7
Removing: libblockdev-utils-2.12-3.el7.x86_64 (@sng-base)
libblockdev-utils(x86-64) = 2.12-3.el7
Updated By: libblockdev-utils-2.18-3.el7.x86_64 (sng-pkgs)
libblockdev-utils(x86-64) = 2.18-3.el7
Error: Package: libblockdev-2.12-3.el7.x86_64 (@sng-base)
Requires: libblockdev-utils(x86-64) = 2.12-3.el7
Removing: libblockdev-utils-2.12-3.el7.x86_64 (@sng-base)
libblockdev-utils(x86-64) = 2.12-3.el7
Updated By: libblockdev-utils-2.18-3.el7.x86_64 (sng-pkgs)
libblockdev-utils(x86-64) = 2.18-3.el7
Error: Package: libblockdev-swap-2.12-3.el7.x86_64 (@sng-base)
Requires: libblockdev-utils(x86-64) = 2.12-3.el7
Removing: libblockdev-utils-2.12-3.el7.x86_64 (@sng-base)
libblockdev-utils(x86-64) = 2.12-3.el7
Updated By: libblockdev-utils-2.18-3.el7.x86_64 (sng-pkgs)
libblockdev-utils(x86-64) = 2.18-3.el7
Error: Package: libblockdev-part-2.12-3.el7.x86_64 (@sng-base)
Requires: libblockdev-utils(x86-64) = 2.12-3.el7
Removing: libblockdev-utils-2.12-3.el7.x86_64 (@sng-base)
libblockdev-utils(x86-64) = 2.12-3.el7
Updated By: libblockdev-utils-2.18-3.el7.x86_64 (sng-pkgs)
libblockdev-utils(x86-64) = 2.18-3.el7
You could try using --skip-broken to work around the problem

yum install sangoma-devel
yum clean all
yum upgrade -y
1 Like

Hi Andrew,
That fixed it - thank you VERY much.
Regards

yay!!!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.