Digium Phones proxy timeout, out of the blue

digium
Tags: #<Tag:0x00007fb47af67a80>

(Aaron) #1

As of this week, I have tried to provision digium phones, but they are timing out when trying to get to the asterisk server.

As a band-aid fix, I have used the webUI of the phones to register them through freepbx. This is of course not perfect, as a bunch of features such as RDK/etc are not able to be applied through the web interface.

Has there been any changes in the last week or two that cause my phones to no longer be able to contact Asterisk?

A note on network topology: For testing, the phones in question are on the same subnet/in the same building as the server, with no firewall or other network stuff in between them besides my switch.


(Lorne Gaetz) #2

(Aaron) #3

Got this error when I tried to update the digium phone module.

As a note, I was on Freepbx 12 and just updated to 13.


(Itzik) #4

Although it should be working on 13 (tried yum update?) I would suggest you upgrading to 14.


(Aaron) #5

Whats the command to use for yum update to go to 14 from 12?

I was using the freepbx updater from inside the gui for this.


(Itzik) #6

I mentioned two things: one, which is updating the packages and modules, the second thing is, about upgrading to 14.

First, run:

yum update -y
fwconsole ma upgradeall
fwconsole chown
fwconsole reload
reboot

This might actually solve your issue.

To upgrade to 14, see wiki: https://wiki.freepbx.org/display/PPS/Upgrading+from+FreePBX+10.13.66+to+SNG7


(Aaron) #7

image

Yum ran into an error, do I need to add a repo to this?

Also, I do not have fwconsole as a command.

My original distro btw was AsteriskNOW


(Itzik) #8

IMO: Your best route is to restore a backup into a new v15. Or if you don’t have a ton of data, then build it from scratch.


(Aaron) #9

I use VMs so yeah this may be the proper route. Anything I should be aware of when restoring from an AsteriskNOW distro of freepbx 12 into freepbx 15?


(R. Stindl) #10

I would not recommend a restore from AsteriskNOW to freePBX-15. Simply go back to the last VM version which worked, open the web-ui. Then install freePBX-15 to a new VM (with a different IP), open the web-ui. Now copy and paste manually every entry, which applies…and adjust the settings in the new distro.


(Aaron) #11

This isn’t the greatest option as my distro has quite a bit of data on it. We use the server for phones across 6 different satellite sites.


(R. Stindl) #12

I understand…
You could also go back to your last working version (Virtualbox VM) and then try to manually update the DPMA module.
Check my last post in this thread. There is a link to a special DPMA-version for Asterisk 11 (if you have this version). I don’t know if it works, but you could try. You could always go back…that’s the beauty of Virtualbox :wink:


(Aaron) #13

I assume I just upload this version through module administration.

I will do this after hours today after I take a snapshot.


(R. Stindl) #14

I once followed the update instructions for DPMA from here…on a freePBX 14 system.

https://wiki.asterisk.org/wiki/display/DIGIUM/DPMA+Installation


(Lorne Gaetz) #15

The restore in FreePBX 15 is designed to allow a legacy restore from FreePBX version 2.9 and up. It really shouldn’t matter what distro you are running.

Legacy restore It generally works, BUT there are an enormous number of module combinations and versions, so it does happen that a restore is incomplete or fails completely. If you spin up a 15 system in a temp location and restore the tarball, it will give you an idea of what to expect.


(Aaron) #16

That is what I am currently doing. I have backed up everything from my freepbx 12 system. I have yet to actually do the restore just in case it tries to use the same IP from the original config.

So I will be clicking the restore button after hours.


(Aaron) #17

An issue. The new DPMA module on freepbx 15 is missing both the edit action, and is missing phonebooks/logos/some other menu items on the right.


(system) closed #18

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.