Dial numbers without pressing "send" on sangoma phones?

I have a client who wants to pick up the phone and dial without pressing send. How can this be accomplished?

tell him to dial the number with a # at the end as this will cause the phone to send the digits to the pbx
or edit the basefile to change the timeout value - i am not 100% sure (perhap the sangoma gang can comment) but i think the parameter you might be looking for is
entryTimeout # NO Key Entry Timeout(in seconds, 0 means never timeout, default is 0 seconds)

change the value to be say 3 seconds. what i think this should do is cause the phone to wait 3 seconds after a digit is entered and if nothing else is entered it will send the number to the pbx. the only side effect of this is that if you have someone that is a very slow dialer (more than 3 seconds between digits) the phone will initiate the call with an incomplete number

where is that setting? I can test on my end

in the endpoint manager - go to basefile edit and select the phone type and scroll through the list of parameters until you find it. the basefile editor will let you change the setting. generally it puts the revised line at the very bottom of the parameter list in red. don’t forget to rebuild the phone config

is there another option to just force it instead of changing the timeout?

this is a training issue. tell him to either press # after he finishes dialing the number or tell him to leave the handset in the cradle, then dial the number and then pick up the handset.

all sip phones have similar behavior

  1. dial the number then pick up the handset - the phone will not use it’s local dial plan but will simply send all digits that were dialed before he picks up the handset immediately to the pbx.
  2. pickup the handset and then dial - the phone uses its dial plan to match against the dialed numbers. most phones have a default timeout so that once you quit dialing and you don’t have a match to anything in the phone dial plan, the phone will send all dialed digits to the pbx after the digit timeout.

sangoma phones appear to be a bit different in that they have the digit timeout value disabled by default which probably forces you to either press # or the send button. the advantage is that if you enter the number wrong you can correct it before pressing # or dial.

a quick update here. if you don’t want to edit the basefile you can change the digit timeout in the EPM.

By setting up dial pattern/s correctly in your Outbound route/s.
See http://wiki.freepbx.org/display/FPG/Outbound+Routes+Configuration+Examples

You’re welcome.

You are correct that the outbound route needs to be set up correctly, but that’s only half the solution. If the phone never actually sends the number (which can happen with digit timeout disabled, for example), the outbound route will never be accessed. Picking up the phone and dialing (the POTS method) works only if your digit timeout kicks in and sends the number to the system.

SIP isn’t the only place this happens, by the way. SCCP handles each digit press in the channel driver but will still not send the call to the server until the “dial” button is pressed or the digit timeout is reached.

You can emulate the “cell phone” model (dial the number and press “send”) using a SIP phone by dialing the number and picking up the receiver (or pressing “send” or pressing the “#” key, if configured), the call gets sent to the system and off you go.

set the digit timeout either in the emp or by editing the basefile. if you set it to something like 3 seconds, there will be a 3 second pause after the last digit before the phone dials.

you and also do things with the dial plan which is also in the epm.

I got a few s500’s for testing a while back, and the issue of not having to press send or # been one of the issues we’ve been trying to resolve.
We are using the same dial pattern that we’ve used with asterisk and Polycom phones for the past 10 years.
[2-9]11|0T|011xxx.T|9[0-1][2-9]xxxxxxxxx|9[2-9]xxxxxxxxx|9[2-9]xxxxxxT|[2-9]xxxxxxxxxT|xxxT|*xx.T|7xT
However the sangoma phones do not seem to honor the T argument. I have not been able to locate any documentation from Sangoma on this topic.

I have the Dial Now timeout set to 2

http://wiki.freepbx.org/display/PHON/Dial+Patterns

That dial pattern is missing the { and } around it, by the way, and I’m not sure what ‘T’ is meant to do?

Wiki.freepbx.org under phones has a wiki on diaplan.

Thanks Rob,
I’ll check this out.
with Polycom phones the T specifies that a time-out will be used to determine when to send the digits to the PBX.
http:// support.polycom.com/global/documents/support/technical/products/voice/Understanding_Digit_Maps_Tech_Tip.pdf

I haven’t tested all of the digit maps yet but this does the trick.
{[2-9]11|0|011xxx|9[0-1][2-9]xxxxxxxxx|9[2-9]xxxxxxxxx|9[2-9]xxxxxx|[2-9]xxxxxxxxx|xxx|*xx|7x+}

Thank you for your help.

1 Like

awesome. Thanks guys

1 Like

when I try to add that dial pattern, it just erases half of it and goes back to the default

Those two conflict. That says to dial when you dial 9 then the next number is 2 through to 9, then 9 digits, AND it says to dial when you dial 9, then the next number is 2 through to 9, then 6 digits.

Can I suggest you start a bit simpler, and try to change it a bit at a time? Then you’ll find out where your mistakes are.

The time out doesn’t work for me because I have users who dial slow. What would the dial pattern be so they do not have to hit send?

I was going to say the timeout is risky because of slow dialers, looking at screen or notes trying to find the rest of the phone number they want to dial. I tell my clients # at the end of the number, your fingers are already dialing so it’s a quick way to go.