Deactivated again

I haven’t changed any hardware in a month, it deactivated 2 weeks ago and again in the past day. if this happens when i bring it on line for real this sucks, how can i trust it. if i go through the steps to release I have no more i will have used up the 2 resets. any idea on what to look for.

1 Like

You should submit a ticket, if for no other reason than this is really a discussion you and Sangoma (and not the rest of us) should be having. I’m sure there’s a reasonable explanation and they have the resources to tell you what that is, where there’s no way we can help you, except to say “I have <number> installations and this has never happened to me.”.

guess i will have to I just rebooted and it again deactivated, keeps saying new interface detected,but it was installed weeks ago, installed a 2 port intel nic to interface to our soon to be installed sip trunk
My internal traffic goes out the on-board nic.


Sounds like you are having the same issue…

Good luck and have a nice day!


1 Like

yep, that was me a week ago, tried to reset again this morning and i have reached my limit. wont reset.
guess i have a choice to make, pay for support or uninstall and not use the commercial modules i have paid for.
My 2 systems are behind a firewall all interfaces and i have locked down the SSH to internal IP’s only and their support requires direct SSH access so at the moment I am stuck.

rebooted my west coast server and it too is now deactivated, talked with the project management and we have came to the discussion to uninstall the purchased modules and just work around them. at least i hadn’t purchased the modules for the west coast server. I have read several posts on this and even sangoma in one post says they don’t even know what will cause a reset and since they only give you 2 resets then you have to pay to find out why, we don’t want to depend on a feature just to reboot and get it disabled. i would rather pay for a hardware key to plug into the box. I think they need a better way to protect the licensed modules.
At least i can say i tried.


Well I sent an email to sangoma about their license deactivation and the fact it cost more than the modules just to get support about why it deactivated my systems. I know i am a small fish but it never hurts to give feedback.

You running inside a Virtual Machine by chance? If so default behavior for all major virtualization platforms (ESXi, Hyper-v, KVM, Xen, etc) is to assign a dynamic MAC address to the VM NICs on startup. You have to set the MAC to static through the virtualization platform or you will risk deactivation of purchased modules on reboot/shutdown. This is because freepbx uses your MAC address to register your system.

FYI, I had a similar issue with Hyper-v where on reboot a new interface kept showing up. Was able to figure out the original MAC by looking through my firewall rules. I posted about it on these forums in the past.

Good luck.

nope, I use ESXI on all my windows servers but not on my Freepbx 13 box, i was using the on-board NIC then added a new dual Intel NIC to tie it to the SIP trunk and the other port to a Openvpn to use for phones. The on-board NIC is attached to my internal network and has a Fortigate router/firewall to the internet and it doesn’t support Openvpn. All 3 NIC’s will route to the internet when done. I may activate it again and reboot it to see if it happens again. I just wonder if every time i reboot and it accesses the net it bounces to the other NIC is will deactivate again. I only need the Conference pro, and it requires the Admin pro. Its cheaper to just repurchase them than spend the money for support. If it deactivates again then i will never use any commercial modules again. I have read a post where the sangoma guys don’t even know what will trigger a deactivation, and on a production system that is unacceptable. We use engineering design tools here at work that are locked down with codes and a license server that never have failed.

First we never said we don’t know what will deactivate it but when using PHP your options are limited for license and encoding based on the nature of how PHP works. Both license and encoding engines being Zend and Ioncube for logical reasons don’t state the exact alogrithim they use for hardware lock but it for sure uses the Mac and if that Mac changes then your license vanishes.

You can reset the hardware lock from the portal and have it issue a new Zend ID once you have your new NICs setup and in place and you should be good to go.

Secondly lets set the record straight here with another mis-information you stated as a fact. You don’t need to buy support for things like this. Your commecial module allows you to open free support related to the commercial module as long as your have active maint renewal on your module.

if i am wrong i will admit it, not trying to give bad info or piss anyone off, i know at least one post i read that had sangoma attached to name mentioned that they didn’t know what triggers it. My original MAC address on the on-board card hasn’t changed I just added a new dual NIC card.

As for support, if i go to the create support ticket there is no mention of commercial modules or reactivation. so how do you proceed if there isn’t a choice here, and the Freepbx choice says you have to have a positive support credit to get help, which is where i am basing my comment from. if there is a different direction i need to take it isn’t clear.

I also followed the reset instructions that lgaetz pointed me to to only have it deactivate again, which i reset it again, then after a reboot it deactivated again, now i have no resets left.

I apologize if i am ruffling feathers, i usually don’t speak out till i hit a wall.

Found the post on why I said what I said about the deactivation.


1 Like

Yes I said in that post we don’t know 100% just like here I said it’s a protected algorithm but we know for sure changes in network cause it.

As far as support their are different departments. One of them is called FreePBX commecial module which does not require support credits.

1 Like

When i go to support and click on submit ticket that option isn’t there.
Sorry if i am a bother.

If you click on FreePBX Support you will see the sub category of Commercial Module that shows no credits are needed.

thanks, just got back to this, i am the IT dept for 60 employees…to many hats.

I didn’t know there was sub options, might want to tell the web developers to add a note at the top of the page about that.

again sorry about being a pain.

It’s Micro$oft business model. Many years ago, I purchase a server with a license system as this. The editor was bought by another which cancel my server software and when I wanted to migrate to a new hardware, nothing to do. Activation server was killed. So now I never buy such a product. Never.