Changing the voicemail email FROM address?


(United States) #11

I have confirmed that /etc/asterisk/voicemail.conf has been updated with the proper value.

I followed all of the steps listed here to setup the voicemail e-mail.

I also tried suggestions from a couple of other web sites, but I don’t recall which one.


(Liviu) #12

I’ve been struggling with the same issue for the past couple of days.
I have the correct/configured value for the FROM: email address in /etc/asterisk/voicemail.conf, but emails go out from asterisk@hostname.local
Can you please detail a little bit what you did to make it work for you?


(United States) #13

I never found a solution. I found several places that offered similar instructions but none of them fixed my problem.


(Dave Burgess) #14

Try ‘cd /etc’ and “grep -v asterisk@hostname.local * */* */*/*”.

Those two commands should get you any file that has that string in it. Post the result and we’ll see what we can do.


(Jared Busch) #15

Then, I assume, you never contacted support either.


(United States) #16

I worked quite a while with support from the vendor who sold us the equipment, without any success. (I don’t think he had any idea how to setup emails for Office365.)

This is pretty low on my priority list, so I moved on to other things. The next step was to create a GMail account and give up on using Office365.

I think I have everything configured properly, but no matter what I do the “from” is “asterisk@” which Office365 rejects.


(Itzik) #17

Try adding

asterisk@your.pbx.hostname email@yourdomain.com

To /etc/postfix/generic

And then run

postmap /etc/postfix/generic
service postfix restart

See details here

https://wiki.freepbx.org/display/PPS/Setup+Postfix+Manually


(United States) #18

I had already tried those steps, but I went through it again, just in case. Here is what I get from the debug page.

Jun 13 12:50:05 uc-37817158 postfix/pickup[25686]: 8F687C1B5D51: uid=995 from=<asterisk>
Jun 13 12:50:05 uc-37817158 postfix/cleanup[25711]: 8F687C1B5D51: message-id=<20190613165005.8F687C1B5D51@ctwautomation.com>
Jun 13 12:50:05 uc-37817158 postfix/qmgr[25687]: 8F687C1B5D51: from=<asterisk@ctwautomation.com>, size=502, nrcpt=1 (queue active)
Jun 13 12:50:07 uc-37817158 postfix/smtp[27212]: 8F687C1B5D51: to=<*******@carolina.rr.com>, relay=smtp.office365.com[40.97.24.34]:587, delay=1.6, delays=0.01/0.04/1.2/0.33, dsn=5.2.0, status=bounced (host smtp.office365.com[40.97.24.34] said: 554 5.2.0 STOREDRV.Submission.Exception:SendAsDeniedException.MapiExceptionSendAsDenied; Failed to process message due to a permanent exception with message Cannot submit message. 16.55847:E20D0000, 17.43559:0000000004020000000000000000000000000000, 20.52176:140FAD870000F01FCB030000, 20.50032:140FAD877017401080030400, 0.35180:D0030000, 255.23226:0A00438A, 255.27962:0A000000, 255.27962:0E000000, 255.31418:1F000130, 16.55847:00010000, 17.43559:00000000E0020000000000000000000000000000, 20.52176:140FAD870000401080030400, 20.50032:140FAD87701710103A000000, 0.35180:03000136, 255.23226:21000000, 255.27962:0A000000, 255.27962:32000000, 255.17082:DC040000, 0.27745:44000000, 4.21921:DC040000, 255.27962:FA000000, 255.1494:49000000, 0.38698:00000000, 0.37692:0F010480, 0.37948:09000100, 5.33852:00000000534D545000000100, 4.56248:DC040000, 7.40748:010000000000010B09000100, 7.57132:000000000000000009000100, 1.63016:32000000, 4.39640:DC040000, 8.45434:12D7678E383E41458440B5993CCBA0C131344D42, 5.10786:0000000031352E32302E313936352E3030303A424E38505231344D42323831383A37333863613031662D386462362D343835632D383662622D38663531666435363663636400383333000000, 255.1750:9D000000, 255.31418:80000000, 0.22753:03000236, 255.21817:DC040000, 4.60547:DC040000, 0.21966:03001736, 4.30158:DC040000 [Hostname=BN8PR14MB2818.namprd14.prod.outlook.com] (in reply to end of DATA command))
Jun 13 12:50:07 uc-37817158 postfix/cleanup[25711]: 3C1B9C1B5D53: message-id=<20190613165007.3C1B9C1B5D53@ctwautomation.com>
Jun 13 12:50:07 uc-37817158 postfix/bounce[27213]: 8F687C1B5D51: sender non-delivery notification: 3C1B9C1B5D53
Jun 13 12:50:07 uc-37817158 postfix/qmgr[25687]: 3C1B9C1B5D53: from=<>, size=5219, nrcpt=1 (queue active)
Jun 13 12:50:07 uc-37817158 postfix/qmgr[25687]: 8F687C1B5D51: removed
Jun 13 12:50:07 uc-37817158 postfix/local[25728]: 3C1B9C1B5D53: to=<asterisk@ctwautomation.com>, relay=local, delay=0.01, delays=0/0/0/0, dsn=2.0.0, status=sent (delivered to mailbox)
Jun 13 12:50:07 uc-37817158 postfix/qmgr[25687]: 3C1B9C1B5D53: removed


(Tom Ray) #19

Add the following to this:

asterisk email@yourdomain.com
root email@yourdomain.com

See if that helps.


(Kris Dfw) #20

it helped.


(United States) #21

I missed this reply earlier. I gave that a try and received hundreds of lines of results, the majority of which seem to have nothing to do with e-mail.


(United States) #22

No change. Everything is still being sent from asterisk@

Jun 17 10:22:54 uc-37817158 postfix/master[28501]: daemon started – version 2.10.1, configuration /etc/postfix
Jun 17 10:23:01 uc-37817158 postfix/pickup[28502]: 84A6EC1BE726: uid=995 from=<asterisk>
Jun 17 10:23:01 uc-37817158 postfix/cleanup[28536]: 84A6EC1BE726: message-id=<20190617142301.84A6EC1BE726@ctwautomation.com>
Jun 17 10:23:01 uc-37817158 postfix/qmgr[28503]: 84A6EC1BE726: from=<asterisk@ctwautomation.com>, size=887, nrcpt=1 (queue active)
Jun 17 10:23:01 uc-37817158 postfix/local[28555]: 84A6EC1BE726: to=<asterisk@ctwautomation.com>, orig_to=<asterisk>, relay=local, delay=0.22, delays=0.19/0.02/0/0.01, dsn=2.0.0, status=sent (delivered to mailbox)
Jun 17 10:23:01 uc-37817158 postfix/qmgr[28503]: 84A6EC1BE726: removed
Jun 17 10:23:22 uc-37817158 postfix/pickup[28502]: 7E9ACC1BE726: uid=995 from=<asterisk>
Jun 17 10:23:22 uc-37817158 postfix/cleanup[28536]: 7E9ACC1BE726: message-id=<20190617142322.7E9ACC1BE726@ctwautomation.com>
Jun 17 10:23:22 uc-37817158 postfix/qmgr[28503]: 7E9ACC1BE726: from=<asterisk@ctwautomation.com>, size=506, nrcpt=1 (queue active)
Jun 17 10:23:22 uc-37817158 postfix/local[28555]: 7E9ACC1BE726: to=<@ctwautomation.com>, relay=local, delay=0.03, delays=0.01/0/0/0.02, dsn=5.1.1, status=bounced (unknown user: "")
Jun 17 10:23:22 uc-37817158 postfix/cleanup[28536]: 8467CC1BE727: message-id=<20190617142322.8467CC1BE727@ctwautomation.com>
Jun 17 10:23:22 uc-37817158 postfix/bounce[28712]: 7E9ACC1BE726: sender non-delivery notification: 8467CC1BE727
Jun 17 10:23:22 uc-37817158 postfix/qmgr[28503]: 8467CC1BE727: from=<>, size=2291, nrcpt=1 (queue active)
Jun 17 10:23:22 uc-37817158 postfix/qmgr[28503]: 7E9ACC1BE726: removed
Jun 17 10:23:22 uc-37817158 postfix/local[28555]: 8467CC1BE727: to=<asterisk@ctwautomation.com>, relay=local, delay=0.01, delays=0/0/0/0, dsn=2.0.0, status=sent (delivered to mailbox)
Jun 17 10:23:22 uc-37817158 postfix/qmgr[28503]: 8467CC1BE727: removed


(United States) #23

This is what is at the end of my /etc/postfix/generic file

root website@ctwautomation.com
root@localhost website@ctwautomation.com
root@localhost.localdomain website@ctwautomation.com
root@freepbx website@ctwautomation.com
root@freepbx.localdomain website@ctwautomation.com
asterisk website@ctwautomation.com
asterisk@localhost website@ctwautomation.com
asterisk@localhost.localdomain website@ctwautomation.com
asterisk@freepbx website@ctwautomation.com
asterisk@freepbx.localdomain website@ctwautomation.com
vm@asterisk website@ctwautomation.com
asterisk@ website@ctwautomation.com
@freepbx.localdomain @ctwautomation.com
smtp_generic_maps = hash:/etc/postfix/generic
asterisk@ctwautomation.com website@ctwautomation.com
asterisk@pbx.ctwautomation.com website@ctwautomation.com


(Tom Ray) #24

This should be in the main conf file not the generic file.


(United States) #25

I have moved that line to my “generic” file. (The file was previously empty.) The e-mails are still being bounced.


(TheWebMachine Networks (Sangoma Software Development Partner)) #26

Did you find a solution to this? I’m having the same issue with Office365 emails being rejected and have tried everything in this post and then some. Still getting emails sending out as asterisk@ instead of the proper email address.


Bug in voicemail sending address
#27

If you are using postfix, then often the easy fix is to alias the email address to the wanted one in /etc/aliases (then run newaliases)

asterisk: you@your.realdomain.com


(B. Martinez) #28

Anyone ever get a solution to this? I am having exact same issue on my 15 system. FPBX 15.0.16.38 and Asterisk 13.27.1.

Correct address is setup in email setup, and in voicemail config. It exists correctly in the /etc/asterisk/voicemail.conf file. I’ve tried adding aliases in both /etc/postfix/generic and in /etc/aliases.

In the SMTP dump, it keeps showing it’s trying to send with “asterisk@fqdn” and not the address configured to be used, which is subsequently getting bounced by O365 SMTP as asterisk@ isn’t an allowed send-as for the email account being authenticated with. I could add asterisk@ with send-as permission, but that’s a bandaid for the root problem here that I’d like to get sorted.

I have dozens of other systems out there all working correctly. I am unclear what the difference is on mine, OTHER than I am on 15. All other notices from FPBX itself go out properly with the correct from address, it’s ONLY voicemail that is still trying to use “asterisk@fqdn” as it’s from address.


(B. Martinez) #29

I found the solution.

For whatever reason, in the /etc/postfix/main.cf, the entry for “smtp_generic_maps = hash:/etc/postfix/generic” was missing. So even though I had the mappings built out, they were not being used.

I added that entry into main.cf and all the mappings started working properly and the problem is now resolved.


(system) closed #30

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.