FreePBX | Register | Issues | Wiki | Portal | Support

Changing the voicemail email FROM address?


(Kenny Riley) #1

I am using FreePBX Distro 14 on Asterisk 11

What is the correct process on changing the FROM email address that emailed voicemails are sent out as? Right now they are being sent out as asterisk@hostname.local and I need to change this to a more realistic domain name so voicemails will not be classified as spam on our end.

Thanks,
Kenny


(Lorne Gaetz) #2

Settings, Voicemail Admin, Settings tab, Email config tab, Server Email


(Kenny Riley) #3

Hi Lorne

Thanks for the reply. I performed that process and the voicemail email FROM address didn’t change. Is there anything else that needs to be modified?

Here’s a snippet from the maillog of leaving a test voicemail after making that change:

Feb 13 17:21:16 ****** postfix/qmgr[17113]: 7636F22CAD: from=**<asterisk@hostname.local>**, size=105678, nrcpt=1 (queue active)
Feb 13 17:21:16 ******* postfix/smtp[18383]: 7636F22CAD: to=<******@******.com>, relay=aspmx.l.google.com[2607:f8b0:4003:c03::1b]:25, delay=0.38, delays=0.04/0.01/0.12/0.21, dsn=5.7.1, status=bounced (host aspmx.l.google.com[2607:f8b0:4003:c03::1b] said: 550-5.7.1 [2600:3c00::f03c:91ff:fe7b:2367] Our system has detected that this 550-5.7.1 message does not meet IPv6 sending guidelines regarding PTR records 550-5.7.1 and authentication. Please review 550-5.7.1  https://support.google.com/mail/?p=IPv6AuthError for more information 550 5.7.1 . v132si2068275oib.15 - gsmtp (in reply to end of DATA command))

(Kenny Riley) #4

I fixed my issue by configuring postfix to send with IPv4 only, but it’d still be nice to know how to change the voicemail FROM email address if anyone can shed some light :slight_smile:


#5

Did you ever find a solution?


(Dave Burgess) #6

If this didn’t work:

you need to submit a ticket. This is how that is supposed to get set.


(Lorne Gaetz) #7

Before submitting a ticket, first confirm the value is properly written to the file /etc/asterisk/voicemail.conf.


(Vikram Malhotra) #8

Did we find the solution of this problem … I am having same issue .

Even though an email address is configured in ‘Serveremail’ it still send out FROM asterisk@hostname.local and hence get rejected by external SMTP server …


(United States) #9

Has anyone found a solution for this? I’ve found a number of suggestions online, but none of them work. No matter what I do my e-mails are from “asterisk@…”


(Itzik) #10

Can you share with us what you did?

Also, please see this:


(United States) #11

I have confirmed that /etc/asterisk/voicemail.conf has been updated with the proper value.

I followed all of the steps listed here to setup the voicemail e-mail.

I also tried suggestions from a couple of other web sites, but I don’t recall which one.


(Liviu) #12

I’ve been struggling with the same issue for the past couple of days.
I have the correct/configured value for the FROM: email address in /etc/asterisk/voicemail.conf, but emails go out from asterisk@hostname.local
Can you please detail a little bit what you did to make it work for you?


(United States) #13

I never found a solution. I found several places that offered similar instructions but none of them fixed my problem.


(Dave Burgess) #14

Try ‘cd /etc’ and “grep -v asterisk@hostname.local * */* */*/*”.

Those two commands should get you any file that has that string in it. Post the result and we’ll see what we can do.


(Jared Busch) #15

Then, I assume, you never contacted support either.


(United States) #16

I worked quite a while with support from the vendor who sold us the equipment, without any success. (I don’t think he had any idea how to setup emails for Office365.)

This is pretty low on my priority list, so I moved on to other things. The next step was to create a GMail account and give up on using Office365.

I think I have everything configured properly, but no matter what I do the “from” is “asterisk@” which Office365 rejects.


(Itzik) #17

Try adding

asterisk@your.pbx.hostname email@yourdomain.com

To /etc/postfix/generic

And then run

postmap /etc/postfix/generic
service postfix restart

See details here

https://wiki.freepbx.org/display/PPS/Setup+Postfix+Manually


(United States) #18

I had already tried those steps, but I went through it again, just in case. Here is what I get from the debug page.

Jun 13 12:50:05 uc-37817158 postfix/pickup[25686]: 8F687C1B5D51: uid=995 from=<asterisk>
Jun 13 12:50:05 uc-37817158 postfix/cleanup[25711]: 8F687C1B5D51: message-id=<20190613165005.8F687C1B5D51@ctwautomation.com>
Jun 13 12:50:05 uc-37817158 postfix/qmgr[25687]: 8F687C1B5D51: from=<asterisk@ctwautomation.com>, size=502, nrcpt=1 (queue active)
Jun 13 12:50:07 uc-37817158 postfix/smtp[27212]: 8F687C1B5D51: to=<*******@carolina.rr.com>, relay=smtp.office365.com[40.97.24.34]:587, delay=1.6, delays=0.01/0.04/1.2/0.33, dsn=5.2.0, status=bounced (host smtp.office365.com[40.97.24.34] said: 554 5.2.0 STOREDRV.Submission.Exception:SendAsDeniedException.MapiExceptionSendAsDenied; Failed to process message due to a permanent exception with message Cannot submit message. 16.55847:E20D0000, 17.43559:0000000004020000000000000000000000000000, 20.52176:140FAD870000F01FCB030000, 20.50032:140FAD877017401080030400, 0.35180:D0030000, 255.23226:0A00438A, 255.27962:0A000000, 255.27962:0E000000, 255.31418:1F000130, 16.55847:00010000, 17.43559:00000000E0020000000000000000000000000000, 20.52176:140FAD870000401080030400, 20.50032:140FAD87701710103A000000, 0.35180:03000136, 255.23226:21000000, 255.27962:0A000000, 255.27962:32000000, 255.17082:DC040000, 0.27745:44000000, 4.21921:DC040000, 255.27962:FA000000, 255.1494:49000000, 0.38698:00000000, 0.37692:0F010480, 0.37948:09000100, 5.33852:00000000534D545000000100, 4.56248:DC040000, 7.40748:010000000000010B09000100, 7.57132:000000000000000009000100, 1.63016:32000000, 4.39640:DC040000, 8.45434:12D7678E383E41458440B5993CCBA0C131344D42, 5.10786:0000000031352E32302E313936352E3030303A424E38505231344D42323831383A37333863613031662D386462362D343835632D383662622D38663531666435363663636400383333000000, 255.1750:9D000000, 255.31418:80000000, 0.22753:03000236, 255.21817:DC040000, 4.60547:DC040000, 0.21966:03001736, 4.30158:DC040000 [Hostname=BN8PR14MB2818.namprd14.prod.outlook.com] (in reply to end of DATA command))
Jun 13 12:50:07 uc-37817158 postfix/cleanup[25711]: 3C1B9C1B5D53: message-id=<20190613165007.3C1B9C1B5D53@ctwautomation.com>
Jun 13 12:50:07 uc-37817158 postfix/bounce[27213]: 8F687C1B5D51: sender non-delivery notification: 3C1B9C1B5D53
Jun 13 12:50:07 uc-37817158 postfix/qmgr[25687]: 3C1B9C1B5D53: from=<>, size=5219, nrcpt=1 (queue active)
Jun 13 12:50:07 uc-37817158 postfix/qmgr[25687]: 8F687C1B5D51: removed
Jun 13 12:50:07 uc-37817158 postfix/local[25728]: 3C1B9C1B5D53: to=<asterisk@ctwautomation.com>, relay=local, delay=0.01, delays=0/0/0/0, dsn=2.0.0, status=sent (delivered to mailbox)
Jun 13 12:50:07 uc-37817158 postfix/qmgr[25687]: 3C1B9C1B5D53: removed


(Tom Ray) #19

Add the following to this:

asterisk email@yourdomain.com
root email@yourdomain.com

See if that helps.


(Kris Dfw) #20

it helped.