Can't activate new PBX


(Bob Reiber) #1

Not sure what’s going on here but it’s been happening since yesterday. I tried to activate it, it goes through the normal steps, it says “Install Branding Updates”, and then kicks me out to a page saying the connection isn’t secure. It sends me to https://[IP address]:80

When I remove the port 80 and get back in it goes right back to trying to activate and I can’t get out of it. It recognizes that it’s been activated before and shows the Zend ID. If I click restart instead I get the same results.

Tried rebooting, tried running updates from the command prompt, not sure how to do anything with the GUI at this point.

FreePBX 15.0.16.76

Is there a way to either force it to stop trying to activate or to complete the activation via the command prompt?


Activation screen will not finish
PBX Activated, but not Activated
(Bob Reiber) #2

I just found this, looks like the same issue and he’s already tried it from the command prompt.

Is there a way to de-register it from the command prompt?


(Bob Reiber) #3

I can make new Zend IDs but it still doesn’t work and when the popup inevitably comes back it finds the first one.

I then went to /etc/sangoma and tried just deleting everything and while the PBX now thinks it’s not registered it still remembers the Zend ID and the popup persists.

image

Next I went into the Sangoma portal and found the deployment. The Zend ID matches but the Deployment ID does not. Tried activating with the other ID and got the same result, and it remembers the same number as before. For what it’s worth both deployments in the Sangoma portal show the same Zend ID.

At this point I’m guessing this is what Mark said in his thread, a port issue rather than an issue with licenses/accounts. Hopefully someone has some idea what’s going on.


(Mark) #4

Hi Bob,

Glad I’m not the only one having this issue! For what it’s worth I managed to stop the Activation pop-up by disabling ALL commercial modules via the CLI using the following;

fwconsole ma list | grep Enabled | grep Comm | awk '{print $2}' | xargs -I % sh -c 'fwconsole ma disable %'

I can now at least access the GUI but still cannot get it to activate.


(Bob Reiber) #5

I might have to try that if I can’t figure anything else out. Right now I’m poking around in the asterisk database trying to see if I can’t break something while trying to change the sslacp port to 80 and leport to anything other than 80.


(Bob Reiber) #6

I’m not very good at mysql… what’s the right way to do this?

update sysadmin_options set value = 81 where key = leport;


(Dave Burgess) #7

UPDATE sysadmin_options SET value = '81' WHERE key = 'leport';


(Bob Reiber) #8

I get:

You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ‘key = ‘leport’’ at line 1


(Dave Burgess) #9

Is the field called ‘key’? If so, you can try this:

UPDATE sysadmin_options SET value = '81' WHERE sysadmin_options.key = 'leport';

or

Try putting the keyword ‘key’ in ‘backticks’ (up by the ‘1’). One of those should work.


#10

key is a mysql ‘reserved word’, surround it with back-ticks " ` "


(Bob Reiber) #11

Thanks, that worked.

MariaDB [asterisk]> UPDATE sysadmin_options SET value=81 WHERE key = “leport”;
MariaDB [asterisk]> UPDATE sysadmin_options SET value=80 WHERE key = “acp”;

I was able to finish activating the PBX, go to Port Management and set the ports back, and so far the popup hasn’t come back.

The moral of the story here (I THINK) is to leave http set to port 80 until the machine is activated. IE dont screw with the ports on the machine you’re going to clone from if cloning a VM.


#12

It’s unlikely that letsencrypt (HTTP-01) will work on port 81.

(forum formatting (markup) needs triple backquotes around single backquotes

UPDATE sysadmin_options SET value=81 WHERE `key` = “leport”

)


(Bob Reiber) #13

I dont need letsecrypt to work on port 81, just needed to get the thing activated. Afterwards I set http back to 8080 and letsencrypt back to 80

Thanks for the help with the syntax.


(system) closed #14

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.