FreePBX | Register | Issues | Wiki | Portal | Support

Alert-Info


(Pace44) #1

Hi,
I’m migrating from FreePBX 12.0.76.6 to FreePBX 14.0.5.5. We like to have different ringer sounds for internal and external call.

For our Snom and Gigaset Phones, I need the Alert-Info like this

Alert-Info: <http://telefon.iris-spielwelten.ch/ringer239.wav>;x-line-id=0;info=iris;delay=0

This works well with my old PBX, I can see it in the log of a Snom Phone.

If I put the same line in Inbound-Routes in FreePBX 14.0.5.5.

The header gets like this:

Alert-Info: &lt;http://telefon.iris-spielwelten.ch/ringer239.wav&gt;;x-line-id=0;info=iris;delay=0

So there is a problem with the encoding, FreePBX adds the &lt; (“lower than”) and &gt; (“greater than”) HTML-Tags, and those gets also in the Dialplan and SIP-Header. The phones don’t recognize this format.

How can I solve this problem?
Thank you for your answers.

Kind regards
pace44


After module updates on Friday Alert Info not working?
(Dave Burgess) #2

The server is encoding your URL to avoid cross-site scripting. This is a good thing and (I assume) on purpose.

Since cross-site scripting is one of the easy ways to lose control over a website, this is a good thing and I suspect that there aren’t actually many ways to avoid this. Things you could try include “escaping” the &lt with a back-slash (which may or may not work) or copying the ring-tone to your phones and using a local alias for the wav file.

If neither of those work, you could submit a feature request and see if Sangoma will fix it. In the past, they’ve been reticent to do much with this field, since they use it as a market differentiator for their phones, but they may be able to get you going on this.


(Pace44) #3

Thank you for your answer.

Escaping unfortunatly don’t work. The escape caracter rests, the result looks like this:

\&lt;http://telefon.iris-spielwelten.ch/ringer239.wav&gt;\;x-line-id=0\;info=iris\;delay=0

The problem with &lt; even ocurs with local IPs/ domains:

&lt;http://127.0.0.1/Ringer3&gt;

So the idea with local ringtones also don’t work.

In need the format like this: Alert-Info: <http://127.0.0.1/Ringer3>

Do you have an idea how to replace the &lt; and &gt; in the dialplan?
Maybe I can change something in the func-apply-sipheaders?


(United Kingdom) #4

I am also having this same problem, it has been working fine until recently. Now it just removes the URL from the string (under advanced settings). So my Snom phones dont recognise it. Any help is much appreciated.


(Tom Ray) #5

Open a bug report or see if one is opened. This is a FreePBX issue with submitting forms and writing out diaplan. Its using HTML encoding and not fixing it before submission.


(Andrew Nagy) #6

A report is already opened about this.


(United Kingdom) #7

Where can i view it?


(Tom Ray) #8

https://issues.freepbx.org or click on the “Issues” link at the top of the forum.


(Andrew Nagy) #9

https://issues.freepbx.org/browse/FREEPBX-18801


(Pace44) #10

I like to try the patch. Should I insert it in ./modules/core/functions.inc.php ?

@tm1000: How long does it take to fix this issue?


(United Kingdom) #11

I tried this, but it didnt seem to work. My issue is that when saving Internal Alert on the Advanced Settings, it strips all the html tags and url. It never used to do this.


(Lorne Gaetz) #12

https://issues.freepbx.org/browse/FREEPBX-18785


(Andrew Nagy) #13

6 posts were split to a new topic: No Alert Info passing through after 14 Upgrades


(system) #14

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.