1und1 Incoming calls not working


I have installed FreePBX and I have the issue, that the Incoming calls from 1und1 are not working properly.
Outbound calls are possible without any issue.
I have created in FreePBX a chan_sip Line for the 1und1 MSN Trunk and it lso seems to be Registering successfully.
If I do a sip reload, then it is working for 2 or 3 incoming calls and then it stops working.

I have replaced the Telephone Numbers with placeholders.
Is there something which I do wrong, that the Incoming calls are only working for a short time?
Please let me know, if you need additionals information from me.

I am not able to Provide the Logs, because it says I can’t post with any links.

Thank you.

The first thing you are doing wrong is using chan_sip on a new install; you should be using chan_pjsip.

I’m not sure you you tried to post logs in line. If so the preference is to upload them to pastebin.freepbx.org, and then just provide a link, or the last component of the path from the URL.

If you were posting in line, you should have marked the logs as pre-formatted text ( </> on the tool bar). That can also be used to post links, although they can’t be used as links but must be copied and pasted into the address bar.

It could be a configuation problem or it could be a NAT realted issue. You need to provide a complete SIP trace and possibly your configuration.

Possibly, this thread will help:

If not, try setting Expiration to 120 or Qualify Frequency to 30.

If no luck, report whether the trunk still shows as registered after incoming calls stop working, as well as whether anything appears in the Asterisk log on a failed call.

Also, do a test by making an outgoing call, then immediately (within 30 seconds) trying incoming. If that works, post router/firewall make/model and any VoIP related settings.

Thanks for your responses.

@david55 I have changed from chan_sip to chan_pjsip and I get an Error Message 403 at registration.
Please see the Error Message on the Pastebin Link. I have setup the PJSIP Line as written in the Link which was provided by @Stewart1
I have also provided the different SIP Logs which I get in the Pastbin Link:

Link: https://pastebin.freepbx.org/view/5f25bd2f

I see after a sip reload the Incoming Call but it doesn’t ring on the Telephone and I get only a busy sign on my Iphone and then the call ends.

If I do a Incoming Call after a Outbound call, then I don’t see any reaction for the Incoming Call.

Could it be that maybe this my issue for the Incoming call: No matching peer for ‘+4916xxxxxxx’ from ‘’ because the SIP Register was to the IP Address ?

I wasn’t able to post the Screenshots with my PJSIP Registration because I am a new user.

My SIP Line is a MSN Line and not a Real Trunk with extensions. Maybe that is the issue for the PJSIP Registration?

Edit: I got now the PJSIP Line working and can make Outgoing calls but still no incoming calls.

I found something in my routers firewall maybe this is the reason why it isn’t working.

Source IP Source Port 5060 Destiniation IP Destination Port:5160

I have an Cisco Router and according to this it is blocked by the outside to self zone. The Self Zone is the Router. Maybe this blocks the Incoming calls?
Please let me know, if ou need any additonal information. Thanks.

what is listening on your (presumably UDP) port 5160 and presumably your DTAG device at ?

lsof -i:5160
whois -h whois.cymru.com  " -f -v"
whois -h whois.cymru.com  " -f -v"

sip.1und1.de resolves to both and

In your trunk settings, set Match (Permit) to,
and retest. If you still have trouble, paste the log for a failing call (including pjsip logger).

see what sngrep sees for inbound (and outbound) calls

sngrep sees traffic ‘before’ your PBX’ firewall but after your ‘gateway’ router

@Stewart1 I have permitted, and for test and also which I have found in another Thread but also no luck.

@dicko With sngrep I don’t see anything when an Incoming call should be coming.
I have also disabled the Firewall on ym Router completely but this didn’t help either. is my current IP Address.

Is there maybe anything else which I can check?

Thank you.

i would look closely at you rules on you external router. what about that 5160 thing?

This is very strange. The ‘No matching peer’ error was almost certainly triggered by an incoming INVITE, which surely should have been seen by sngrep. Is sngrep reporting other SIP traffic? There should be an OPTIONS request sent to the trunk every minute and a corresponding reply, assuming default Qualify settings.

Potentially you can get calls from all of the 4 IPs that sip.1und1.de resolves to. AFAIK, this actually happens. A couple of years ago, I configured such an account for a customer in Germany, but at that time I didn’t look at the IPv6 connections.

You really need to post your complete configuration plus a relevant trace from pjsip set logger on.

@jgttgns I got the Incoming calls now to work.
On my Router I changed the Port Forwarding of 5060 from my Fritz Box to the FreePBX Server.
In sngrep I see now also INVITES when I do a Incoming Call.
I had also to update my external IP in the Asterisk SIP Settings, that I couldget a sound on the phones.
I have to check, if this can be done automatically, because I have a Dynamic IP which changes.
For my other question for Voicemailbox and so on, then I will maybe open another Thread for it.


I found now a Script to Update my IP Address to my current IP Address but this isn’t updated in the Webinterface or is this a normal behaviour when the change isn’t made via the Webinterface?
The Script updtes the File pjsip.transports.conf.

Thank you.

That isn’t really suitable for a business server, and you will get service disruptions around the times of changes, but, as long as dnsmgr is enabled, they should, eventually correct themselves.

There is no good reason for addresses to change, even if they are dynamic. It is either doesn’t consider doing it properly necessary for their market, or they want to discourage the use of servers on their type of account.

Note that your ITSP may also cache IP addresses, so you may need a short registration interval. You won’t be able to use the more up market offerings that match by IP, rather than registrations.

The reason is why the IP Adresses changes is, that it is a Residential DSL Line and not a business DSL Line.
I just want to use it as a Home Telephone Server but I will check, if the Script which I have found suits my needs. I have a DynDNS Nam but I think this doesn’t work for PJSIP.
My FritzBox which I have used also didn’t had an issue when the IP has changed and it was also behind my Router.


I have had four residential lines (in different locations) for many years and on average, see an IP address change per line about once every ten years. The cause is almost always maintenance activity, a lengthy power outage, etc.

Some DSL services forcibly change the IP address every 24 hours. I have only seen this in developing countries and doubt that it would occur in Germany. But if your ISP is doing this, you could have a script that forces a daily router reboot at (for example) 3 AM, so the change would be very unlikely to interrupt a phone call or other session.

Otherwise, with many DSL setups, loss of line sync caused by a brief noise burst results in an address change. If this occurs often (several times per day), try to get the ISP to fix the line, such as by using a different pair in the cable. Otherwise, I suspect that your router is renegotiating PPPoE whenever it loses sync. I don’t know the details of your setup, but a possible fix is to have the modem in bridge mode, connected to a separate router. A sync loss should recover in ~12 seconds, which is much less than the 30-second LCP keepalive timeout, so the router won’t redo PPPoE. Unfortunately, this isn’t a perfect solution; although the call won’t technically drop, after 12 seconds of silence most people will assume that the line has gone dead and hang up. Of course, immediately calling back will work.

Finally, for small systems (such as at home), I recommend running FreePBX on a cloud server. If your power or internet goes out, the system continues to function, with calls sent to mobile SIP apps or forwarded to mobile numbers. This also avoids the issue of IP address changes. It’s generally more robust in other ways. If the hardware fails, the cloud provides a replacement. If the software fails, restore from a snapshot or backup takes only a few minutes.

1und1 is different, about a year ago they switched the IP once a day (also during the lunch break), DTAG does it about every two months.

Port forwarding is actually mostly irrelevant. You need a predictable way for replies. This feature is typically called “Outbound NAT Rules” (e.g. pfSense/opnSense). You don’t find that on plastic home routers like a FitzeFatzeBox, I think.

It’s only true for systems that have no external extensions and never forward incoming calls to external destinations. On such calls, Asterisk is not sending any audio so there is nothing to reply to.

Of course. You do that with port forwarding. Merely setting the router to avoid needlessly rewriting the source port is unreliable, because the UDP port chosen by Asterisk may already be in use by another device on the LAN. These days with Zoom, Meet, etc., it happens quite often.

That is awful. Any phone call, meeting, download, etc., over lunchtime will fail. Are they still doing that? If so, would most users have access to an alternate ISP without this problem?

@jgttgns 1und1 changes the IP Address for me every 24 hours but they are using a DTAG Line in my area.
I could setup a FreePBX Server on my OVH Server where I am also able to provide it a own static IP Address but I think then I have also to open the Firewall to connect for example with a SIP Client which could maybe a security risk or not?
If FreePBX works properly, then I can switch off the FritzBox.
Now I have to check how to create a shared Voicemailbox, because I want that every telephone is possible to use the same Mailbox, like it is on the FritzBox.

I have now entered my DynDNS Address at the External Address in the NAT Settings which seems to work for now but I don’t know if it will work when the IP Address changes.
I have also found a Script which replaces the IP Address. Maybe I can use this, if the DynDNS doesn’t work properly.