Config problem 1und1 provider Germany

siptrunk
configuration
asterisk
freepbx
Tags: #<Tag:0x00007f7031ef4338> #<Tag:0x00007f7031ef4108> #<Tag:0x00007f7031ef4540> #<Tag:0x00007f7031ef5c60>

(Homephone) #1

Hello together.

I installed freePBX a few days ago and the most things work well. The provider Sipgate I have already setup successfully with pjsip.

Does anyone have a tutorial for setting up 1&1 with pjsip?

PBX Version: 15.0.17.12
Asterisk Version: 16.15.1

Thanks for helping.


(Homephone) #2

I have attached my current configuration by means of screenshots.

13 24 46 01 11 35


#3

Yes, I am also interested, because I also have a 1und1 connection.

Kind regards
TGL

//Edit:
I solved the calling over 1und1 but only outgoing calls.
Can you call outgoing?


(Dirk2358) #4

What’s exactly your problem? You have to route the outgoing call to the 1und1 trunk. Same procedure as with Telekom. What happens afterwards? What’s the reaction of 1und1 regarding your try to put an outgoing call? You need to do a SIP trace as already described in my other post.


#5

Hello dirk,
yes youre right, but 1und1 need´s the 49Number as Username.
My Problem is right now, when i call my Line, i recieved 4 calls on the localphone.

See here:
== Using SIP RTP Audio CoS mark 5
– Connected line update to PJSIP/1und1_privat-00000144 prevented.
– PJSIP/521-00000147 is ringing
– PJSIP/521-00000147 is ringing
– PJSIP/521-00000148 is ringing
– PJSIP/521-00000148 is ringing
– PJSIP/521-00000149 is ringing
– PJSIP/521-00000149 is ringing

What i do wrong?


(Dirk2358) #6

I’m not sure at the moment: do you have an inbound (-> incoming calls from the provider) or outbound (placing calls to the provider to call your neighbor e.g.) problem?

According your log, you seem to have a problem with the routing of incoming calls. You have to take care, that the inbound call is routed correctly through the inbound routes on base of the DID. You have to define the correct “Durchwahlnummer” in the inbound route and the desired device (“Ziel einstellen”) where to route the call to.

Caution:
The “Durchwahlnummer” must be spelled correctly - I don’t know how 1und1 presents the DID (= your own number, which has been dialed by the caller) - Telekom uses +4989… e.g… Therefore you have to use those formats at the “Durchwahlnummer” field. This could be 004989 or 4989… or maybe something else. You will see this in the pcap trace, too.

If this doesn’t solve your problem: you have to describe, what you’re exactly doing and what you’re expecting to happen and what happens instead.


#7

I´ve got the Solution :slight_smile:

It is true to setup 1und1 about telekom.
But some Caracters is to set:
“Hauptleitungen”
inband Progress = yes
Force rport = yes
Server URI: sip:49XXXXXXXX@sipbalance-c-bap.1und1.de
Client URI: sip:49XXXXXXXX@sip.1und1.de
Send Connected Line = yes
Username is right “049phonenumber” eg (4989123456)

@dirk:
when i don´t set the options i recieve more than one call.

And thank you for help :slight_smile: