Zulu UC Softphone


I am interested in the Zulu UC application for FreePBX. I went ahead and activated the 2 free licenses on my FreePBX system to test out the software before purchasing the 20 user license.

Seems to be pretty slick, the only issue I am having with Zulu is the softphone option on the call tab is not showing up. I can only do ‘originate call’. I have the ‘enable softphone’ set to ‘yes’ in user management. I followed the wiki. What else is necessary to make this work? Let me know if additional information is required please.

FreePBX Firmware: 10.13.66-21
Zulu Version:
Zulu Desktop Client Version: 2.1.14
Zulu UC is installed on Windows 10 OS

Do you have the necessary ports open? WebRTC and RTP ports?

FreePBX and the computer I am testing from are on the same LAN, so no hardware firewall between. I allowed the Zulu application through Windows firewall. I also ended up completely turning off Windows firewall to confirm and still the same results.

Since you mentioned WebRTC. I just ran a sniffer on my network and did not pickup any tcp 8089 traffic at all from source or destination. I am seeing TCP 5000 and 8002.

The option for softphone is the only thing not functioning (not even an option for it on the call tab of Zulu).

Any other suggestions? Want me to gather any logs that could be helpful?

Figured this out. My self signed certificate was not ‘default’. After defaulting the self signed certificate, rebooted asterisk and the softphone option became available. Everything is working now.

Glad you got it working but you can always contact support for free for help next time. Also any proper cert set as default will work. For example on our Corp PBX we have a real cert and set it as default and it works fine as long as it’s a cert for the same domain you connect Zulu to.

Good to know, appreciate the information. Thank you.