Zulu Phone Not Ringing when Ring Group or Queue contains too many extensions


(Vincent) #1

I do like the feature that you can log into a few different extensions with one zulu app. I think that’s a nifty feature with different voicemails and ring groups.

My problem when logged into one extension or many with zulu is,
When I call the ring group, all handsets ring right away. ring time set to 20 seconds.
The popup comes up after about 16 seconds, just before the call goes to voicemail.
I did have some issues with zulu, and tested by calling that softphone extension with an unavailable message and no pop up at all for ring group call. After a reboot, then I could call any zulu extension, and an incoming ring group call will pop up a few seconds before voicemail.

Is there a setting I am missing? I went item by item, line by line checking settings.

Thank you, Vincent


(Sergio Lobera) #2

Hi @skitterlad !
What I do not understand is how a call to a ringgroup is reaching a voicemail, that is not normal, unless the failover destination is a voicemail.
About Zulu not being able to ring at the same time as your extensions: Are you using the latest Zulu server and Desktop/Mobile ?
How many extensions are on the ringgroup ?


(Vincent) #3

application version 3.5.0+206 osx and windows are same version, same issue
PBxact 40 system updated to latest version.
Current PBX Version: 14.0.13.28
Current System Version: 12.7.6-2002-2.sng7
Zulu 14.0.58.3 Stable [Commercial]
Failover is the virtual voicemail.
When I use FOP2 The softphone only extensions are not seen when they are logged in to zulu and presense state set to available.
When I dial the extension for the softphone, it rings right away.
This interaction does seem a bit buggy since I did have to reboot asterisk for me to call an extension softphone last night.
I have about 30 extensions on this ring group.
its really just at the last ring does zulu ring, but desktop phones would ring for 16 seconds.


(christrati) #4

Just to confirm, is this Zulu on a mobile device? Android or iOS?

I know we have issues with mobile devices and queues delayed ringing. Usually it takes about 1-2 rings before they ring.

In contrast the desktop version has been working well.


(Vincent) #5

Desktop version.
Using Chan_SIP

Should I be using PJ_SIP?
I’t converting one extension to pjsip to see if there is a difference.
Does zulu work better with pjsip?

Update, pjsip same issue.


(christrati) #6

What version of asterisk are you running? I’m on 16.9.

Chris


(Ivana72) #7

We had the same problem with one of our clients using Zulu Desktop App. The delay was around 10 seconds until the call was presented to Zulu clients. The calls were coming through a ring group with 15 extensions and ringall strategy. If the call was made directly to the extension Zulu Client presented the call immediately but it never worked appropriately when it was coming from the ring group. We were not able to fix and the support ticket with Sangoma went nowhere. The client switched to Bria Enterprise.


(Vincent) #8

At least I’m not the only one with this issue so hopefully sangoma can find a solution. see if there is an open ticket for this issue, if not should i open up one?

If I log into zulu with an extension that has a physical polycom phone linked to as well, then it rings 10 seconds later. If there is no polycom with that extension, then it rings just before the 20 sec mark, then goes to the fail over. Maybe there is a solution for now until this bug is fixed. I hate to have to use Bria instead of Zulu, but I do need it to work. Were the Bria soft phone extensions on their own, or were they mapped to a physical phone?


(christrati) #9

I’ll have to see about setting up a ring group and see if I have a similar issue. We’ve had the most trouble with the mobile, rather than the desktop version. I would check the following:

  1. Try using Asterisk 16
  2. Go through the Sangoma Zulu Desktop setup, and make sure you check the settings showing in the video:
    https://youtu.be/-lWHmrIeV5w?t=183
  3. Verify the Firewall settings as well, make sure you have WebRTC, and Zulu allowed on your Internet port, or that your subnet is added as a local network.

You can also go to the Zulu and do an echo call test and see how that works.

Right now, we use Queues instead of ring groups and haven’t had issues like this with the desktop client. I’ll see about testing it in a couple of days and can post a followup if I have issues with ring groups.

Chris


(christrati) #10

Just to give an update. I setup the following:

  • Test extension - 2012, no phone attached, so it shows offline in PJSIP
  • Used Zulu Desktop and signed in with the account attached to that extension
  • Added Extension 2012 to a Ring Group that is setup for ringall
  • Called the ring group

The desktop client rang right away for me.

I then added in another extension in Zulu and had them both in the ring group. Again I called the ring group and now both Zulu clients rang right away.

If you call the extension directly I assume it rings right away on the desktop client?

Chris


(Vincent) #11

I’m running Asterisk CLI 14.0.1
I believe this is the most up to date version for PBxact 40
It does seem that the updates for PBexact are delayed awhile even if you have the sangoma POMP plan, you’ll be behind on updates? it seems vs FreePBX

When I call the extension directly, it does ring right away. But even that was a little buggy a day ago, requiring me to restart to be able to call a softphone only extension.

I tried the method you listed. I removed the softphone only extension from the ring group.updated, logged into zulu with that extension. then added that extension back to ring group. then updated.
nothing.
I use FOP2 and only the extensions with phones light up.
If I hang up on the call early before 20 seconds, the call does pop up on zulu for one second. Im using Chan_sip for all extensions with and without phone. I changed one extension to pjsip to test, but nothing. I did watch that video and it was insightful.


(christrati) #12

I would upgrade to Asterisk 16.0. I changed from 13 LTS to 16 LTS about 6 months ago. I know prior to that, we really didn’t use Zulu as it didn’t work well. With the current situation, we decided to start testing it again in March 2020 and had some issues with the mobile version. However, the desktop has been pretty good so far. I’m wondering if it is now required to be on Asterisk 16.

I’m also running PBXact, a PBXact 400.

It was very easy to switch, but did require downtime, as it will restart asterisk.
https://wiki.freepbx.org/display/PPS/Changing+Major+Asterisk+Versions+on+the+Fly

asterisk-version-switch

Chris


(Vincent) #13

I just updated asterisk 16. zulu sip calls not going to soft only extensions. Zulu will ring half way into a ring length if that extension has a physical phone. UCP has a ring delay setting, but its set low.
In UCP the phone there rings in the widget, but if i also add a zulu widget, that does not ring. why does FOP2 not show extensions that zulu is logged in under? do you use FOP2? Its a nice way to see all the lines that are connected .


(christrati) #14

Zulu uses WebRTC, so you need to make sure that is enabled in your Advanced Settings. And that you have wss enabled, etc as instructed in their Wiki and guide. Generally, you’ll see the Zulu softphone show up as 99. So in my case, I show 992012 as registered.

And no, i do not use FOP2. It may only see the SIP and may not see those WebRTC connections.

So to confirm, if you call the soft only extension directly, does the Zulu desktop client ring?

Chris


(Vincent) #15

Zulu desktop extension with softphone only rings right away when you call that extension.

In advanced settings what is
Default Follow Me Ring Strategy There are options, ringallv2, ringallv2-prim, ringall
what setting should it be?
what about "Default Follow Me Ring Time "

WebRTC I read about this, kept trying to find it in settings. It does not exist. It seems that WebRTC is not installed, nor is it an option to install. I followed the instructions
https://wiki.freepbx.org/display/F2/WebRTC+Phone-UCP#WebRTCPhone-UCP-Overview
There is no Module Admin to select in advance

Also advance settings do not have WEBRTC anywhere. UCP does not have webrtc.

How do i install via putty, I looked online for commands, and cannot find them for freepbx

I have one working Let’s Encrypt certificate.
is another type of certificate needed to allow the words WEBRTC to show up?
FOP2 does work with WEBRTC, but i wouldn’t know until i have it installed.

Thank you so much for your help. I’m sure another user will find this info helpful.


I read this post, but that does not at all show how to install webrtc

In my PBxact 40 system, I cannot find WebRTC anywhere in updates, modules, settings. What am I missing?


(Sergio Lobera) #16

Type this on your CLI and see if it’s installed

fwconsole ma list | grep webrtc

If it’s disabled: fwconsole ma enable webrtc
If it’s not installed: fwconsole ma downloadinstall webrtc

After that go User Management > Edit an user > go to UCP tab > Then go to Phone Tab and enable it.

You should add the webrtc phone as a “Side Bar Widget”
This is what it looks like:


(Vincent) #17

[root@securesip ~]# fwconsole ma list | grep webrtc
| webrtc | 14.0.3.8 | Enabled | GPLv3+ |

the word webrtc is in red, it is enabled.
I disabled it, enabled it. i installed to make sure it was up to date.
In module updates -> connectivity, I see WebRTC, I dont know if it was hidden before or not.
WebRTC Phone 14.0.3.8 Stable Sangoma Technologies Corporation[GPLv3+] Enabled
I do not see WebRTC anywere in UCP settings for a user settings. what tab would it be next to, Zulu, Chat? or in the UCP settings tab, voicemail, phone. I am able to add softphones to my UCP widget for phone and zulu. but i dont see any webrtc settings.

When I call the extension, the green phone icon rings, but the zulu widget icon does nothing.

So for now, Ill use UCP phone works, I can call, rings right away, I can answer, and this is a softphone only extension, but UCP Zulu phone will not ring and zulu desktop phone no ring until a second before the timeout that is set.

with FOP2, I do see the WebRTC phone extension listed because the UCP is logged in, so calls will go to that. so for my system, WebRTC not working with zulu correctly.


(Vincent) #18

I’ve reviewed the settings in the “Follow-Me List” to enter in the softphone extensions, no luck.
I toggled some other settings, and no go.
So Softphone in UCP works right away, but Zulu in UCP doesn’t ring until the last ring of the ring group.
There has to be a setting Im missing or something to check what is going on.

Thanks for your help troubleshooting this.


(Vincent) #19

I’m still having this issue with extensions without a real phone connected.

WebRTC phone works in UCP as it rings right away with an inbound SIP call and shows up as an active available extension on asterisk and FOP2.

Zulu UCP or app zulu phone when logged in alone, does not show up in asterisk as an available extension, and only rings just before the call goes to fail over. Zulu softphone does allow outbound calls, and calls directly to the zulu extension works instantaneously. Any settings I can apply to make this work?


(Vincent) #20

UCP phone works and rings immediately on inbound sip calls.
Zulu does not ring when logged in the same extension that has no physical phone attached.
also the Zulu widget does not ring for inbound SIP calls. Xulu only rings immediately when an extension calls it. Zulu inbound SIP call will ring just before the failover happens.
No different result if chansip or pjsip for that extension.