Zulu Phone Not Ringing when Ring Group or Queue contains too many extensions


(Vincent) #21

Any help, please. The more extensions I add to a ring group, the slower Zulu will ring. Im using ring all.
If I have under 10 extensions it rings a few seconds later. If I have more, it takes a lot more time. If I have over 15, then It will ring just before the failover.
I am watching the incoming call on FOP2.
I can’t get Zulu to ring on an extension that doesn’t have a physical phone paired to that extension when it is part of a ring group with more than 15 numbers. WebRTC fully works with UCP phone and will ring right away.
Zulu phone only rings if the incoming SIP is sent directly to that extension or a small ring group with just a few extensions.

Is it possible that this problem can’t be solved with the current software?

ringall : Ring all available channels until one answers (default)
hunt : Take turns ringing each available extension
memoryhunt : Ring first extension in the list, then ring the 1st and 2nd extension, then ring 1st 2nd and 3rd extension in the list… etc. This strategy will work only when Confirm Calls is disabled.
*-prim : These modes act as described above. However, if the primary extension (first in list) is occupied, the other extensions will not be rung. If the primary is FreePBX DND, it won’t be rung. If the primary is FreePBX CF unconditional, then all will be rung
firstavailable : ring only the first available channel. This strategy will work only when Confirm Calls is disabled.
firstnotonphone : ring only the first channel which is not offhook - ignore CW. This strategy will work only when Confirm Calls is disabled.
random : Makes a call could hop between the included extensions without a predefined priority to ensure that calls in the groups are (almost) evenly spread. Simulates a Queue when a Queue can not otherwise be used.


(Vincent) #22

When there are too many extensions in the ring group, more than 5, it starts to slow down. when more than 10, cuts time in half, and when more than 15, only rings just before failover. This seems like a bug.


(Vincent) #23

My extension 994037 only shows up when I log into UCP with webrtc phone.
If I only log in with zulu, then the extension does not show as on.
But zulu will ring if only a few extensions in the ring group.
i even tried to add 994037 to the ring group and 4037#, but that didnt change the ring time when there were more than 10 extensions added to a ring group, even if all extensions were softphones.


(christrati) #24

Have you tried setting up a queue instead of a ring group? I only have a queue with about 6 extensions, and the desktop zulu works great. The mobile takes a while.

Chris


(Vincent) #25

I have 20 physical phones in the office. I have 20 soft phone extensions. total 40 extensions. My physical phones are polycom phones, and since dont do openvpn, i didnt give them to the staff for home usage since i didnt want to open up the firewall to each ip address.
Im not sure if a queue with all these 40 extensions would work?
FOP2 is really nice because you could see what webrtc phones are connected and give the extension people names, and all staff could see who is available to take calls, and who is on a call.
When I sign in with zulu, my extension 99407 is not seen as logged in, only when i sign in with ucp webrtc phone does it show im available.
Any reason why ring groups that have too many extensions would stop working well with zulu?
If you have an example of making queue work for all these extensions? A ring group with only 6 extensions rings great for me. only when I add more does the time for zulu to ring increase, until its saturation point where it rings only when it reaches fail over. possibly each extension adds a second to the wait time before zulu rings?


(christrati) #26

I would just setup a queue and put the same number of phones in that queue and see what happens. Essentially, I started with ring groups, but for queue reports (a paid module), it was easier, and you had more options, compared to the ring groups. Just curious if it works better, since it is different from ring groups.

I will say, there is a bug with queues with the Zulu mobile app, that if you answer the call in about 1 ring, the mobile device will ring constantly.

Chris


(Vincent) #27

PBxact 15 was released, so we can upgrade now from 14. possibly there are zulu fixes with this?
do you have Queues Pro and Queue Reports modules? Does that include the queue call back?
What happens to your queue when you add 20 extensions? does it then delay the zulu ring with ring all?

i watched this zulu video https://www.youtube.com/watch?v=-lWHmrIeV5w
All the settings are there, no help. It must be a bug with the number of extensions someone has in a ring group. Maybe Sangoma support just thinks im a Newibe that doesn’t know asterisk from a distro, which is correct, but I got it functioning well, and was able to trouble shoot the problem to zone in on the exact problem.


(christrati) #28

Correct, I do have the Call Center bundle, which includes Queues Pro and Queue reports.

What PBXact system are you running? Is there a chance you’re over taxing the CPU with all the extensions ringing at the same time? Just curious if you run htop while you ring it if it goes high?

I’ll have to see if I can find a queue with more than 10 members and see what happens with my desktop zulu. I know the Zulu mobile will be delayed.

Chris


(christrati) #29

Just to follow up on Zulu. I have the desktop version (3.5.0) running an extension that has no phone associated with it. I added this to a queue that has 16 phones. I called it and it popped up pretty much right away (ie, 1-2 secs) when my outside call rang.

I haven’t tried a ring group, but my queue with 16 extensions is operating as expected.

Chris


(Vincent) #30

I checked the CPU usage, no spikes at all.
I installed PBxact 15 last night. that install made the CPU spike to about 15%.

Update: I set up queues. The same problem when there are too many extensions on the queue. if there are 10 extensions, it takes about 10 seconds for the zulu phone to ring. UCP rings 3 seconds after the physical phone no matter how many extensions there are. If I lower the number of extensions, then zulu will start ringing (delayed) depending on how many extensions are in queue. If 3 extensions, then zulu rings right away.

I heard there is a paging issue as well that you cant page too many phones at once, and you would need a multicast paging pro set up to reduce overhead. I do not see my CUP usage going up on pbxact 40 when calling in. the cpu graph is kind of weird to interpret on the dashboard, I dont know if there is a normal way to see the stats like a pfsense dashboard.

I wish someone who codes from sangoma would try to recreate my problem, and see if there are max usage limitations with ring groups when it comes to soft phone webrtc extensions only. It has to be in the code, and I bet it is reproducible.


(christrati) #31

Hmm, maybe there is still something else. I created a ring group with 15 desk phone and the 1 zulu softphone, and again, it range in 1-2 secs of the others. Again, this is with the desktop Zulu application.

Are you enabling Zulu via group in User Management?

Have you tried resetting Zulu via the Zulu and click Reset? I’ve done this before and have to go back to USer Management, make sure Zulu is enabled for the group of users I have it enabled on (about 5 users) and then submit and hit apply again. After that, Zulu started working like it was a clean system.

I’ll have to see about creating a bunch of zulu only extensions and see what happens as well. In either case, based on my system, I’m not able to reproduce the issue you’re describing. I can for sure reproduce it on the Zulu mobile, but not the desktop versions.

Chris


(Benoit) #32

I’m seeing similar behaviour when using large queues, created a topic as well: Zulu, delayed ringing in larger queues


(Vincent) #33

I reset Zulu, disabled, enabled the user group setting. Still the same problem. Zulu desktop will only ring just before failover when there are more than 15 extensions listed. I’ll have to pair a physical phone with each extension with zulu to make ring correctly.


(christrati) #34

What version of Zulu server are you running? I’m on version 14.0.58.7. Not sure if that makes a difference or not.

And just to make sure, you have an extension created, and a user created, and they are linked as the primary extension? And I assume if you perform a Zulu test call or test push those work pretty quick as well?

My guess is it would be best to see about capturing Asterisk and Zulu logs when it happens and giving that to support. If you’re lucky, possibly Sangoma can connect via the Support VPN and monitor the issue as well.

And you’re running Asterisk 16.9 correct?

Chris


(Dave Burgess) #35

IIRC, there has always been a problem like this with large ring-groups. Don’t get fixated on Zulu - it could be something else.


(Vincent) #36

My Trunk settings is a SIP trunk, not PJSip. I don’t know if this matters, But i will switch to pjsip trunk and see if makes a difference.


(Dave Burgess) #37

OK - I helped a customer with a trunk conversion from Chan-SIP to PJ-SIP this weekend and it was a little bit of a pain in the neck, but once done, his connectivity problems went away. Make sure you set the transport in the trunk setup - we didn’t do that until we’d tried a dozen other unrelated rabbit holes.

Another thing is that we’ve been seeing reports about Zulu ringing “later” than other extensions, for which there could be a dozen explanations that aren’t related to Zulu or FreePBX.


(Vincent) #38

I have udp - 0.0.0.0 - All set yes for transport. tcp - 0.0.0.0 - All was set no. does zulu work on tcp? should i set tcp as yes?