Zulu is disabled, will not update

FreePBX 13.0.195.2
Asterisk 14.7.5

After module updates I noticed the ZULU module is in a status of :Disabled; Pending Upgrade to 13.0.54.31.2

When I try to update ZULU I get:
Installing zulu
Updating tables zulu_interactions_interaction_states, zulu_softphones, zulu_tokens, zulu_interactions_contacts, zulu_interactions_interactions, zulu_interactions_members, zulu_interactions_streams, zulu_interactions_stream_bodies, zulu_interactions_stream_links, zulu_login_tokens…Done
Enabling PJSIP Websocket server
Unable to enable websocket driver!
Error(s) installing zulu: •Failed to run installation scripts
Updating Hooks…Done
Setting Permissions…Done

I found this thread which seemed to mirror my issue:

I enabled both SIP drivers (previously only CHAN), on the PJSIP side I enabled ws and wss. I rebooted the server, I ran fwconsole reset from the ssh interface, still I get the above errors. Any ideas?

Thanks!

Please open a commercial module ticket at https://support.sangoma.com

Ticket opened. We are under a time crunch in order to procure a 1000 licenses, but before we can signoff on that we need a working demo (this box).

Just an FYI that I have this exact same issue on two FreePBX systems that I applied the latest batch of module updates to. On one of them, it seems to be causing a “Whoops!” error when I try to access “Inbound Routes”, but the other system seems to otherwise be fine. Zulu is not used on either system.

I have submitted a ticket under commercial modules as well, so hopefully a solution will be found soon.

@comtech - I may have the solution for you, assuming you have not received anything yet. I did some more digging and came across this post:

https://community.freepbx.org/t/zulu-is-disabled-and-i-cant-upgrade-it/49902

After I went under “Settings > Asterisk Sip Settings”, I went to the “PJSIP Settings” tab. Under “Transports”, I set “ws” and “wss” both to “YEs”, then issued a ‘fwconsole restart’ from the command line.

Once I did that, I was able to upgrade Zulu no problem.

Unfortunately (for me), the system I did this on was the system not exhibiting the “Whoops!” page error when I go into “Inbound Routes”, as they are a much busier system then the one I just did it on (I waited until there were zero calls going on before I restarted Asterisk). For the system with the “Whoops!” page, I will need to wait until after hours (for them) :frowning:

I will update here once I have tried the other system too.

Or post the Whoops error for us to fix.

I had the same issue today applying module updates. Mine puked on Zulu as well. I had to go into the SIP settings and change the WS and WSS transports for pjsip to “Yes.” Once I applied that I was able to upgrade the Zulu module.

We’re having the same issue, but enabling WS and WSS transports did not resolve the problem. In attempting the initial upgrade from the CLI, I received this output:

SIP Channel Driver must be set to both or chan_pjsip in Advanced Settings. Then restart Asterisk

I changed this, and then changed the settings for WS and WSS to Yes. However, we’re using chan_sip, so I’m guessing it’s related to that – Zulu continues to work fine on our other (not-yet updated) server, also using solely chan_sip throughout (set to “chan_sip”, not “Both” in advanced settings).

Zulu requires pjsip to be enabled. You can’t use it with chan_sip only. Sorry.

Everyone here upgrade to the next version of zulu and it will install but it won’t start (the server) if the requirements aren’t met. But it wont be in a disabled stated.

So this was just rolled out today, because we’ve been using Zulu solely on chan_sip for over a month now. Do we need to change the config for our whole server for this?

This was rolled out yesterday. And no you don’t need to change your config. Your extensions can be any technology dahdi, iax, chan_sip or chan_pjsip. But to use Zulu you must at least enabled pjsip (Hence me stating “You can’t use it with chan_sip only”. There is no way around this. Zulu requires chan_pjsip. but that doesnt mean your extensions have to be chan_pjsip. Never said that.

If your extension is chan_sip and you use zulu then zulu creates an ad-hoc device in the background for the chan_sip extension in pjsip. Again you have to enable pjsip though for Zulu to work and be able to do this.

WebRTC does the same thing.

This was done because chan_sip is no longer supported by Digium. It’s a deprecated channel driver. New features for WebRTC are being added to pjsip, not featurss and bugs and security issues are also not fixed in chan_sip.

I’m having the same problem since most recent updates. I’ve changed the sip channel driver to both. I’ve enabled ws and wss in chanpjsip settings. I’ve restarted asterisk from the console. I’ve ran the commands asterisk -rx ‘module load res_pjsip_transport_websocket.so’ - That returns

asterisk -rx ‘module load res_pjsip_transport_websocket.so’
Unable to load module res_pjsip_transport_websocket.so
Command ‘module load res_pjsip_transport_websocket.so’ failed.

STILL cannot update Zulu. It’s still disabled. I receive the following error:

Unable to enable websocket driver!
Error(s) installing zulu:

Failed to run installation scripts

Any other ideas???

I have tried to upgrade the Zulu module as well, and am seeing the following error:

Zulu 13.0.53.4 will be upgraded to 13.0.54.31.2

Installing zulu
Updating tables zulu_interactions_interaction_states, zulu_softphones, zulu_tokens, zulu_interactions_contacts, zulu_interactions_interactions, zulu_interactions_members, zulu_interactions_streams, zulu_interactions_stream_bodies, zulu_interactions_stream_links, zulu_login_tokens…Done
Enabling PJSIP Websocket server
Unable to enable websocket driver!
Error(s) installing zulu:
Failed to run installation scripts
Updating Hooks…Done
Setting Permissions…Done

I do have both Chan_Sip and Chan_PJSip enabled, though I have been using Chan_Sip for my endpoints. I am under the impression it’s OK to use both modules, when both are enabled? I did the ‘fwconsole restart’ as well as rebooted the server, but still unable to update the Zulu module…

How do we do this?

Can you confirm that you are following the steps which I’ve documented at https://wiki.freepbx.org/display/ZU/Zulu+3+Server+Installation?

NOTE: That we are working to make this easier to configure after installation and have a new version of the module in EDGE (which hasn’t passed our internal QA yet).

Thanks for the guidance Brian.

Following the linked instructions yields the same result.
•Navigate to Advanced Settings
•Change Display Readonly Settings to YES
•Change Override Readonly Settings to YES
•Search for Force WebSocket Mode and change it to PJSIP
•Search for Enable the Asterisk REST Interface and change it to YES
•Search for SIP Channel Driver and change it to BOTH if it’s not PJSIP or BOTH already
•I also enabled ws and wss on the pjsip settings tab of Asterisk SIP settings

[[email protected] ~]# fwconsole ma downloadinstall zulu
No repos specified, using: [standard,extended,commercial] from last GUI settings

Starting zulu download..
Processing zulu
Verifying local module download...Verified
Extracting...Done
Module zulu successfully downloaded
Updating tables zulu_interactions_interaction_states, zulu_softphones, zulu_tokens, zulu_interactions_contacts, zulu_interactions_interactions, zulu_interactions_members, zulu_interactions_streams, zulu_interactions_stream_bodies, zulu_interactions_stream_links, zulu_login_tokens...Done
Enabling PJSIP Websocket server
Unable to enable websocket driver!
Unable to install module zulu:
 - Failed to run installation scripts
Updating Hooks...Done
[[email protected] ~]#

Just a heads up, I tried the normal (module admin) upgrade path on another FreePBX 13 distro test box and am getting the same result (pjsip websocket driver, cant install/enable).

@comtech Couple things I don’t see from your paste of the procedure. Did you also Saved and Applied Config Changes as well as restart Asterisk?

Yes, sorry, I saved and applied config, then I ran fwconsole restart before running fwconsole ma upgradeall and fwconsole ma downloadinstall Zulu.