Cant yum update


#1

Any ideas how to resolve this error? run yum --enablerepo=sng-pkgs clean metadata does not do any good.

yum clean all
Loaded plugins: fastestmirror, versionlock
Cleaning repos: sng-base sng-epel sng-extras sng-pkgs sng-updates
Other repos take up 458 M of disk space (use --verbose for details)

yum update -y
Loaded plugins: fastestmirror, versionlock
Determining fastest mirrors
sng-base | 3.6 kB 00:00:00
sng-epel | 2.9 kB 00:00:00
sng-extras | 2.9 kB 00:00:00
sng-pkgs | 3.4 kB 00:00:00
sng-updates | 2.9 kB 00:00:00
(1/6): sng-base/7-8.2003.3.el7.sangoma/x86_64/group_gz | 153 kB 00:00:00
(2/6): sng-extras/7-8.2003.3.el7.sangoma/x86_64/primary_db | 206 kB 00:00:00
(3/6): sng-pkgs/7-8.2003.3.el7.sangoma/x86_64/primary_db | 785 kB 00:00:00
(4/6): sng-base/7-8.2003.3.el7.sangoma/x86_64/primary_db | 6.1 MB 00:00:00
(5/6): sng-epel/7-8.2003.3.el7.sangoma/x86_64/primary_db | 7.3 MB 00:00:00
(6/6): sng-updates/7-8.2003.3.el7.sangoma/x86_64/primary_db | 4.5 MB 00:00:00
Resolving Dependencies
–> Running transaction check
—> Package sangoma-pbx.noarch 0:2008-1.sng7 will be updated
—> Package sangoma-pbx.noarch 0:2011-5.sng7 will be an update
–> Finished Dependency Resolution

Dependencies Resolved

============================================================================================================================================================
Package Arch Version Repository Size

Updating:
sangoma-pbx noarch 2011-5.sng7 sng-pkgs 17 k

Transaction Summary

Upgrade 1 Package

Total download size: 17 k
Downloading packages:
sng-pkgs/7-8.2003.3.el7.sangoma/x86_64/prestodelta | 78 B 00:00:00
sangoma-pbx-2011-5.sng7.noarch FAILED
http://sng7.com/sng7-7.8/sng7/RPMS/sangoma-pbx-2011-5.sng7.noarch.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=sng-pkgs clean metadata
Trying other mirror.

Error downloading packages:
sangoma-pbx-2011-5.sng7.noarch: [Errno 256] No more mirrors to try.


(Franck Danard) #2

There was some problems yesterday.
Try again please. It looks better now.


#3

Worked. Thanks!


(Franck Danard) #4

You’re welcome sir :slight_smile:


(Simon Telephonics) #5

This problem appears to be back, different package:

Downloading packages:
asterisk-version-switch-6.1-4. FAILED                                          
http://sng7.com/sng7-7.8/sng7/RPMS/asterisk-version-switch-6.1-4.sng7.noarch.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=sng-pkgs clean metadata
Trying other mirror.

Error downloading packages:
  asterisk-version-switch-6.1-4.sng7.noarch: [Errno 256] No more mirrors to try.

Neither the suggested yum --enablerepo=sng-pkgs clean metadata nor yum clean all resolve the situation.


(Simon Telephonics) #6

I worked around the problem for now with yum --exclude=asterisk-version-switch update


Error Downloading yumupdate
(Tom Ray) #7

Having the same issue.


(Brian Johnson) #8

same issue here different package than the original post.
Upgrade 1 Package

Total download size: 4.4 k
Is this ok [y/d/N]: y
Downloading packages:
sng-pkgs/7/x86_64/prestodelta                              |   78 B   00:00
asterisk-version-switch-6.1-4. FAILED
http://sng7.com/sng7-7.8/sng7/RPMS/asterisk-version-switch-6.1-4.sng7.noarch.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=sng-pkgs clean metadata
Trying other mirror.


Error downloading packages:
  asterisk-version-switch-6.1-4.sng7.noarch: [Errno 256] No more mirrors to try.

Ran the recommendations still an issue.


(Simon Telephonics) #9

Do this for now:


(John Jarrett) #10

Seems like a 2 week long issue and should not be that difficult to fix(?) IMHO.

Same this AM and the asterisk-switch being the only RPM update. Therefore at this point ignoring it would be moot.


(Ken Yiu) #11

Try download the file manually then run the yum update again

# wget http://sng7.com/sng7-7.8/sng7/RPMS/asterisk-version-switch-6.1-4.sng7.noarch.rpm
# yum update asterisk-version-switch-6.1-4.sng7.noarch.rpm

This worked for me:grinning:


Asterisk-version-switch fails
Asterisk-version-switch fails
Mirror error on brand new installation
(United States) #12

Cheers mate!! Solved!


(Ben) #13

Having same problem on a new build and the manual download resolved it.
Thanks


#14

What about today? Been down for over a a day now


(Jared Busch) #15

I updated a system this morning, yum & modules. No issues.


#16

Which version? I am not the only one complaining.

yum update
Loaded plugins: fastestmirror, versionlock
Loading mirror speeds from cached hostfile
Could not retrieve mirrorlist http://mirrorlist.sangoma.net/?release=7-8.2003.3.el7.sangoma&arch=x86_64&repo=os&dist=$dist&staging=$staging error was
12: Timeout on http://mirrorlist.sangoma.net/?release=7-8.2003.3.el7.sangoma&arch=x86_64&repo=os&dist=$dist&staging=$staging: (28, ‘Connection timed out after 30001 milliseconds’)

One of the configured repositories failed (Unknown),
and yum doesn’t have enough cached data to continue. At this point the only
safe thing yum can do is fail. There are a few ways to work “fix” this:

 1. Contact the upstream for the repository and get them to fix the problem.

 2. Reconfigure the baseurl/etc. for the repository, to point to a working
    upstream. This is most often useful if you are using a newer
    distribution release than is supported by the repository (and the
    packages for the previous distribution release still work).

 3. Run the command with the repository temporarily disabled
        yum --disablerepo=<repoid> ...

 4. Disable the repository permanently, so yum won't use it by default. Yum
    will then just ignore the repository until you permanently enable it
    again or use --enablerepo for temporary usage:

        yum-config-manager --disable <repoid>
    or
        subscription-manager repos --disable=<repoid>

 5. Configure the failing repository to be skipped, if it is unavailable.
    Note that yum will try to contact the repo. when it runs most commands,
    so will have to try and fail each time (and thus. yum will be be much
    slower). If it is a very temporary problem though, this is often a nice
    compromise:

        yum-config-manager --save --setopt=<repoid>.skip_if_unavailable=true

Cannot find a valid baseurl for repo: sng-base/7-8.2003.3.el7.sangoma/x86_64

Can ping it just fine


(Jared Busch) #17

Not saying you don’t have an issue.
Updated 4 systems today. All were FreePBX 15. Only one had system package updates. But the upgrade check didn’t fail.


(system) closed #18

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.