You have 1 tampered files This is a critical issue and should be resolved urgently

How do I fix this?

Module: “Digium Phones Config”, File: "/var/www/html/admin/modules/digium_phones/etc/res_digium_phone.conf altered

I tried to rebuild EPM configfiles, then get this error. Did a full restore, but sill have this issue. (See the vpn issue that started this all in General Help)

This is the file content. minus the commented lines

[general]
#include res_digium_phone_general.conf
#include res_digium_phone_devices.conf
#include res_digium_phone_network.conf

Thanks

Need to update your modules. This was fixed

All my modules are updated and current, I keep them updated daily.

error is back, so this did not help.

amportal ma refreshsignatures`

amportal a reload

Module: “Digium Phones Config”, File: “/var/www/html/admin/modules/digium_phones/etc/res_digium_phone.conf altered”

Also got this on resign:

Module http://mirror1.freepbx.org/modules/packages/digium_phones/digium_phones-13.0.7.4.tgz.gpg successfully downloaded
Unable to install module digium_phones:

  • Failed to install Digium Phones Config due to the following conflicting module(s): EndPoint Manager

Current PBX Version:

14.0.5.25

Current System Version:

12.7.5-1807-1.sng7

Total Module Count:

116

Enabled:

110

Disabled:

1

The numbers below may be inaccurate if new modules have been released since the last check:

Last online check:

2019-01-30T01:08:42+00:00

Modules with Upgrades:

0

System Upgrades Available:

0

fwconsole ma upgrade digium_phones --edge

[[email protected] mike]# fwconsole ma upgrade digium_phones --edge
Edge repository temporarily enabled
No repos specified, using: [standard,commercial] from last GUI settings

digium_phones is the same as the online version, unable to upgrade
Updating Hooks…Done
Resetting temporarily repository state

This is what is written to the file causing issue:

[[email protected] mike]# vi /var/www/html/admin/modules/digium_phones/etc/res_digium_phone.conf
;--------------------------------------------------------------------------------;
; Do NOT edit this file as it is auto-generated by FreePBX. ;
;--------------------------------------------------------------------------------;
; For information on adding additional paramaters to this file, please visit the ;
; FreePBX.org wiki page, or ask on IRC. This file was created by the new FreePBX ;
; BMO - Big Module Object. Any similarity in naming with BMO from Adventure Time ;
; is totally deliberate. ;
;--------------------------------------------------------------------------------;
[general]
#include res_digium_phone_general.conf
#include res_digium_phone_devices.conf
#include res_digium_phone_network.conf

ALSO, no vpn up, so no phones are connecting. See the VPN thread in General Help.

I did this (fwconsole ma refreshsignatures) 2 more times, it seems to be sticking now, and the security issue is no longer displaying. Why is my vpn no longer connecting, no phones are connected and I cannot seem to start the vpn.

This only started about 4:30PM EST.

VPN has always worked great until about 4 hours ago, and I cannot figure out how to restart the vpn server, as per my previous posts.

At this point, I need to get the VPN server up. Any ideas?


OK, got it working, fingers crossed, as I have no idea why it stopped working. I could not restart the VPN server, much as I tired, via ssh.

So I went ahead into System Admin and disabled it, and re-enabled it, and it seems to be working, for now at least. I was leery to do this disable based on the warnings you get if you disable it.

then I could use the ssh command to also check status, and it was up, so I am not sure why it got in such a funky state, and why I could not start it in ssh.

systemctl status [email protected]_server1.service

this command starts it if it is not running, but I was too chicken to stop it and try to start it. They gotta work tomorrow, and its my a… if there are problems.

This is still happening. Logged into a client system to run updates and saw this.

Attempting to force the install again pukes on a conflict with EPM.

My solution is to just remove the package as we are not using it at this site.
image

As happened on the last system I did this on, the reload failed.

I go back to the GUI and the tamper warning is gone, but I have the notice from the failed reload.

Reboot the system and then reload, and all good.
image

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.