Yealink templates losing their provisioning type when saved

I’ve been having some bad luck lately with the latest EPM ( I upgraded a few days ago and today had something very similar to this unexplained event from over a year ago:

Basically, I discovered that if I touch one of my Yealink templates in EPM and save it, then I can no longer update an endpoint from the Extension Mapping page. If I do, I get this message:

Please select a Provisioning Server Protocol in the template [ 'template123' ].

Note that the ONLY option for Provisioning in the Template is HTTP and it is selected (and can’t even be unselected).

What is funny is that, from the Template editor side, I can tell it to Save and Update and it does it properly – all works fine. But I just can’t do the same thing from the Extension Mapping side. I could work around that except that it means that I can’t add any NEW endpoints because it won’t save it with the given template from the Mapping page.

To try to give a better example… I added 2 new endpoints on the Extension Mapping page – both linked to a Yealink template named “acme”. I hadn’t edited that template in weeks or maybe months. Those two added just fine and I worked with them a little bit. Then I decided that I wanted to edit the template slightly. I went in and made an edit adding a BLF for Parking. Nothing special. I saved it from the Template page including updating the extensions – they updated fine and work fine – no errors.

I then decided that I wanted to add another endpoint. I went to the Extension Mapping page, just like I did the other two earlier, and added the third – selecting the “acme” template. It refused to save and gave the same error:

Please select a Provisioning Server Protocol in the template [ 'template123' ].

I did some testing and I can now add that extension for any templates that I have NOT touched recently, but any that I have touched recently, I cannot assign to a new endpoint or it will give the error about provisioning server protocol. (Again, HTTP is the only option and cannot even be changed in the template, so there is nothing to select/fix.)

Any thoughts? I’ll report this as a bug, but wanted to check here also in case anyone had any ideas as I’m kinda in a bind now.

Note that I also have Polycom templates in this config and they are working fine. I can edit them and still assign new decides to them just fine (they use TFTP). Only the Yealink ones are being an issue.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.