Yealink T48G says No Service in some locations

Hey All,

First … I have learned a ton from both this forum and also the wiiki info. Great job to all!

I’m hoping maybe somebody out there has dealt with this one. I just set up and provisioned our office with T48Gs. My FreePBX is cloud hosted with a public IP. All the phones in the office and some other locations work great. However … we shipped a phone to an employee in another state and when they plugged it in … the phone reports “No Service” and everything is grey.

To provision the phones we used the auto provision option on the Yealink phone menu. We entered the FreePBX public IP number in the Server URL field, then hit “auto provision” and everything came up golden. When our employee received the phone and plugged it in … no service.

One idea I came across said to add “tftp://” followed by the public ip number since perhaps the T48G might default to http//. I tried that from the remote location and we still get nothing.

I am wondering if I am missing anything in my provisioning that any of you might know of that might help.

Thank you in advance!

Assuming you have the FreePBX firewall enabled and set up using sensible defaults, you do not have tftp exposed to untrusted access. You should be provisioning via http (and using apache credentials if the phone supports it). Provisioning from remote locations means white listing the phone IP in the FreePBX firwall (networks tab) so it is able to reach the pbx provision service(s).

Sure enough, Igaetz. It turned out to be my oversight on the firewall setting … gotta’ keep these systems as secure as we can. Thank you for sharing. I’ve noticed you are all over these forums and you have already helped me out a ton.

I very much appreciate your insight … onward and upward!

1 Like