Yealink T-32G won't provision!

Running the latest FreePBX x64 v10.13.66-7 and EPM My phones are not grabbing the .cfg file from my server. I did a factory reset on the phones, and I get nothing. I also have T46G phones on my reception desks, and they seem to be provisioning OK. Any ideas would be appreciated.

What firmware on the phones?
Are you using tftp?
if you
cd /tftpboot/
Do you see the .cfg for that MAC? in other words is it being generated?

Firmware, which according to the Yealink Web site is the latest firmware.

Yes, using tftp.

My tftpboot directory has the .cfg file for the MAC of the phone. I went into EPM and performed a “Save, Rebuild Configs and Update Phones” command, and it did update the date and time of the .cfg file. The files are there, but the phone is not pulling the file. I did a factory reset on the phone, put in the ip address of my server in the “Provisioning Server” entry in the Web interface, and rebooted. No luck. I am starting to run out of ideas.

I have the Extension configured in FreePBX for PJSIP, which is on 5060, and the phone’s setting for “Local SIP Port” is 5060, so that looks OK.

On my phones in the auto provision field I put: tftp://
I don’t know if maybe this is mandatory in the older 3 series phones

I just tried that. Still did not work.

I checked my server, and it looks like the xinet.d service is running properly. I fired up the command line and ran “asterisk -rvvv” and rebooted the phone. I get nothing coming across the console, so I am not sure that the phone is even talking to the server.

Can you ping the phone from the server?

Yes. The phone pings fine from the FreePBX server.

turn up the verbosity in the tftp server and tail the messages file to see if the phone is hitting the server. you will not see tftp requests in the asterisk/full file.

to turn up the verbosity
edit the file /etc/xinetd.d/tftp and add several -vvvv to the server_args line
server_args = -s /tftpboot -vvvv
restart the tftp server service xinetd restart
tail -f /var/log/messages

now restart/reboot the phone and see what shows up.

Thanks for the response. I did as suggested. the tftpd entries in my messages file are these:

Feb 1 16:08:08 FreePBX in.tftpd[18949]: RRQ from filename y000000000032.cfg
Feb 1 16:08:08 FreePBX in.tftpd[18949]: sending NAK (1, File not found) to
Feb 1 16:08:08 FreePBX in.tftpd[18950]: RRQ from filename 001565831b55.cfg

That is it. I look in my tftpboot directory, and file 001565831b55.cfg is there with necessary rights and owner “asterisk”.

What is going on???

log into the phone and take a look at what got loaded. it looks like the config file is provisioning properly however something is not loading correctly. my guess is that the sip server address will be missing.
i would also compare the firmware level on the phone to the firmware level you have specified in the EPM. go to /tftpboot/yealink/1 (or whatever firmware slot you are using) and look at the file called version. it will list the firmware version by phone type. if the firmware levels are significantly different, then manually update the firmware on the phone by downloading it from the pbx to your laptop/pc and then log into the phone and file the upgrade screen. we have discovered that if the firmware on the phone is too old, that it will not provision from the tftp or ftp server properly.
if the firmware matches, then i would factory reset the phone (either log in and reset it) or simply hold the “ok” button until the phone factory resets and then provision the phone again.
my guess is that you will find that everything but the sip server address loaded correctly. if you manually enter it you will probably see the phone register.

Thanks for your help. I got this to work. There is an option in Endpoint Manager for “Config Style”. Apparently the SIP-T32G will fail if it is on “Legacy Style”. That solved my problem.

I learned something today.