Why I can’t link Linphone with my PBX?


(Yoann B) #21

Yes I can read well, could you just tell me which chapter deals with the subject of connectivity between Freepbx and a softphone please


(Simon Telephonics) #22

https://wiki.freepbx.org/display/FPG/Extensions+Module+-+PJSIP+Extension


(Yoann B) #23

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)


(Yoann B) #24

but I don’t understand, am I not supposed to use the chansip extension instead of the pjsip? For link the PBX with a softphone ??


(Richard Smith) #25

It is best if you can use PJSIP for trunks and extensions.

Connecting the Softphone is just using the information that is in FreePBX. If you have an extension as ChanSip then you connect to the PBX with the chansip port but if you have created using PJSIP use the PJSIP port as defined in Asterisk SIP Settings.


#26

I assume that the VirtualBox host is the same Windows 10 machine that is running Linphone. If not, please explain.

Confirm that the VirtualBox VM is using Bridged Networking. If you type
ifconfig
from a shell prompt on the PBX, you should see for your (virtual) Ethernet interface, something like
inet addr:192.168.123.7
This is the local IP address of your PBX.

And if you type
ipconfig
at a command prompt in Windows,
you should see for your (real) Ethernet interface or bridge, something like
IPv4 Address . . . . : 192.168.123.4
This is the local IP address of your Windows machine. Both should be in the same subnet.

Now, in Linphone, set up something like
Adresse SIP* "yoannB" <sip:4840@192.168.123.7:5061>
Adresse du serveur SIP* <sip:192.168.123.7:5061;transport=udp>

Replace 4840 with the extension you set up in FreePBX.
Replace 192.168.123.7 with the actual local IP address of the PBX.
Replace 5061 with the value of “Port to Listen On” (if you set up a pjsip extension) or with the value of “Bind Port” (if you set up a chan_sip extension).

If you still have trouble, report what, if anything, appears in the Asterisk log when Linphone attempts to register.


(Yoann B) #27

Ok so when you say “the host” I hope you mean the person behind the screen which is me indeed I hope it’s not in the “technical” sense, my virtual machine is configured in NAT because I’m using a vpn (that’s why I posted my ip address), I hope it’s not a problem because I already have problems with virtualbox network settings and it’s horrible to fix…

Anyway, when I type ifconfig on Ubuntu I don’t get an address that looks like yours, it’s something like 127.X.X.X (of course there are numbers instead of X’s), it’s this address that allows me to access the freepbx panel, I typed ipconfig on Windows and it gives me 192.168… and it’s not the same as the other one, so that’s where the problem is?

I will continue and deal with the problem above later, then on the suite I have exactly the same thing except for the ip address which seems to be a local ip address and I put my ip address (of the vpn) and my port is :5060

I have to put the local ip address or the public ip address in the Linphone settings?

Do you recommend me to use the port 5060 (chansip) or 5061 (pjsip) ?

And I guess the problem of local ip addresses (windows and Ubuntu) that don’t match is a very big problem?


(Simon Telephonics) #28

Do you not understand IP addresses at all?

127.x.x.x is the loopback IP; that’s not the one you want. Inteface lo is also not the one you want.

How are you at solving captcha puzzles??


(Yoann B) #29

you’re right I was wrong but it doesn’t change anything, the windows ip address doesn’t coordinate with the Ubuntu one, this is what it says:

enp0s3: inet: 10.X.X.X5
netmask: 25x.xxx.2xxx.0
broadcast: 10.X.X.X5X

And the rest is ipv6

Here is


#30

That’s because as ever you refuse to listen or read, where you not just a few hours ago advised to

…Confirm that the VirtualBox VM is using Bridged Networking…

Did you do that?

I suspect we are all wasting our time with all your identities, you just seem incapable of comprehending anything .


(Yoann B) #31

This post was flagged by the community and is temporarily hidden.


(Defcomllc) #32

An understanding of Virtualbox and Networking in general will allow you to resolve all your issues. You have reading to do if you truly want to resolve your issues and get everything working as you like. These are not FreePBX issues…


(Yoann B) #33

This post was flagged by the community and is temporarily hidden.


(Defcomllc) #34

You should probably hire an IT professional if you arent interested in educating yourself on the issues you are having.


(Yoann B) #35

This post was flagged by the community and is temporarily hidden.


(Simon Telephonics) #36

If you want to talk about IncrediblePBX, go to their forum.


#37

There are 2 ways for solving your problems

  1. Start reading and listening to learn basic stuff about SIP/VOIP, Networking and Virtualization
  2. Pay a IT-Professional for it to set it up for you.

Generally a PBX on Virtualbox isn’t a good idea in a production environment

And before you starting with thinking about VPN you’ll need the basics as well.
At the point where you are at the moment, you’ll have these problems with every PBX system - because the problem is in your general setup and not a PBX problem


(Yoann B) #38

This post was flagged by the community and is temporarily hidden.


#39

Technically its not a problem to set it up on a VirtualBox Enviroment - if you know how to configure the settings of the VM.
(I think thats the easier part against a PBX over VPN)

But if you know how to setup that vps and configure the VPN connection it will work as well.

But save the money


(Yoann B) #40

But concretely for someone who doesn’t know anything like me it will be easier to start over on a vps or else there will be the same problems and might as well stay on the virtual machine