When on Zulu softphone call BLF's are not lighting up on physical phone

I know that Zulu is a commercial model I was just hoping someone had seen this and had a fix. We are using the Zulu softphone and when a user is on a call on the softphone their BLF is not lighting up on the physical phone indicating they are on a call. Is this by design or is there someone to fix this?

Because they aren’t the same account from what I understand. You have your extension and your “zulu” account for the softphone and it’s using two different accounts to register each device and then it calls both.

As I recall, the Zulu extension is prefixed with “99” (check with your hints section just to make sure).

So, for the BLF to work, you’ll have to check the ‘99+ext’ status, not just the extension status.

BLFs for Zulu activity should work as expected. I just tested from Asterisk CLI. Here is extension at rest:

11*CLI> core show hint 4022
[email protected]      : SIP/4022&PJSIP/90402  State:Idle            Presence:available       Watchers 11
1 hint matching extension 4022

and here is when I have an active call in Zulu (and only Zulu):

11*CLI> core show hint 4022
[email protected]      : SIP/4022&PJSIP/90402  State:InUse           Presence:available       Watchers 11
1 hint matching extension 4022

Note that the hint monitors several devices including the associated Zulu device.

2 Likes

I’m using PJSIP (I don’t know if that matters) and the Zulu extension is the same as the desk phone. None of the BLF’s light up when they use Zulu softphone but they do if they use their physical phone.

Check your Hints and make sure the off-hook hint for the Zulu phone is actually exactly the same as your desk phone.

Unless something has changed very recently, the Zulu device extension will be different than your desk phone.

I’m sorry I’m not sure how to do this

From the “Reports” menu - Asterisk Info

Under Asterisk Info -> Subscriptions I see nothing that mentions “off-hook”.

This makes no sense to me. How do you show both SIP and PJSIP on the same extension? Here are the steps that I use to enable Zulu softphone for a user.

  1. Convert their regular hard phone extension to PJSIP
  2. Go into User Manager and enable Zulu
  3. Download and install Zulu softphone on the users PC
  4. Sign in using "(extension)@(IP address of FreePBX server) example: [email protected]

After doing this both the hard phone at the desk and Zulu softphone have the same extension. I can choose which one rings first and is default etc.

How do you get a different extension for the Zulu client and why would I want to do this?

Here’s the output from the CLI using show hint on an extension set up just like I said above:
[email protected] : PJSIP/77228&Local/90 State:Idle Presence:available Watchers 13

That is a hint. It is valid to have multiple technologies on a hint. It is also valid to have multiple technologies on a dialstring. Zulu uses PJSIP but it’s irrelevant on what you are using.

You don’t have to do this at all. If there is somewhere you learned this it is wrong and I would like to fix it. Zulu can be used against IAX2, DAHDI, SIP and SCCP extensions. It can even be used against techs we don’t know about.

Explained above.

Tried just about everything. Still the BLF’s on other users phones do not light up when the softphone user makes a call.

Try upgrading zulu to the current edge version

I did that already. No love.

I updated it wrong. Put it on the edge version and now its working as intended. Thanks!

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.