WebRTC suddenly doesn't work


We’ve had a fully functional FreePBX running for the last 3 months, primarely used with WebRTC clients.
Now the sudden, these clients can’t make calls.
They can see incoming calls, but can’t answer them.
Softphones (Microsip) are working just fine.

Every module is up to date.

Verbose logging and pjsip logger doesn’t show anything, when I try to make a call from a WebRTC client.

Where to look?


I would start with the browser’s developers console and look at the logs or errors showing up there.

Thanks, I did.
I’m using jssip, and the last debug message is “createLocalDescription()”, then nothing more happens

Was there a browser update? Did you try an alternate browser?

I have tried Edge with the same result.


The same with Firefox.
Is there another way I can test WebRTC? Perhaps with some more informative debug messages?

One other thought. Did you start using IPv6 in your network? The webrtc client doesn’t work with IPv6, and just fails without a good error message. (Something I decided I would dig into at some point…)

It turned out (haha), that it was the turn server that wasn’t working.

turn server? i am also having an issue with WebRTC (just detected today; not certain when it stopped working) and am trying to diagnose…

How do you connect to your server?

In my case we are using the FreePBX UCP client from the LAN.

On further investigation, this is a client specific issu; Firefox works, Chromium Edge works, but Google Chrome is only one way audio (no inbound audio, but outbound audio works; e.g., the other end of the call can hear us, but we can’t hear them).

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.