FreePBX | Register | Issues | Wiki | Portal | Support

WebRTC and Chrome 57


(Roll4life) #1

Has anyone been able to get the WebRTC phone in the UCP working successfully with Chrome 57? We’ve had WebRTC up and running for about 6 months now, with no real issues, but since the release of Chrome 57 it no longer works for Chrome users. It does still work in firefox without issue.
I have found a few different resources that reference the problem but it is not entirely clear to my how to resolve this issue in freepbx, without having users switch to firefox or downgrading them to chrome 56 and then disabling updates for chrome.

https://issues.asterisk.org/jira/browse/ASTERISK-26732


we’re using FreePBX 13.0.190.19 with Asterisk 13.9.1


(Andrew Nagy) #2

This is fixed in FreePBX 14. We have not fixed it in FreePBX 13 at this time


(Roll4life) #3

Thanks, are there any know good work-a-rounds for freepbx 13, aside from using a different browser?


(Andrew Nagy) #4

Use WebRTC 13.0.32.4


(Roll4life) #5

I have updated to WebRTC 13.0.32.4
Still seeing the following in Chrome
chrome://webrtc-internals/

setRemoteDescriptionOnFailure
Failed to set remote answer sdp: Session error code: ERROR_CONTENT. Session error description: rtcpMuxPolicy is ‘require’, but media description does not contain ‘a=rtcp-mux’…

Is there some other setting that needs to be adjusted?


(Andrew Nagy) #6

More needs to be done. There will be an update later today.


(Roll4life) #7

Thanks!


(Andrew Nagy) #8

webrtc v13.0.32.5


(Roll4life) #9

Looks like that works. Thanks!