WARM spare FreePBX setup

I am using FreePBX distro 14. I have the latest patches installed and still having a problem with the WARM spare configuration, in effect I have had to disable my backup server. I followed all the directions and setup a WARM spare and the backups run fine and the backup server is a complete copy of the production server. The issue is that even though I click the box to disable the trunks on the backup server it keeps leaving them on (I did open a bug report on this). I had a work around with a “post backup script” that would disable the trunks but even that wasn’t reliable. The trunks would often be enabled and since my trunks are on authentication with the sip I would end up with 2 PBX’s connecting to my sip provider (causing all sorts of havoc). I havent heard anything on the bug request but looking to see if anyone else has solved this?

my 2 PBX’s are in geographically different states so I cant use the High-Redundancy option (besides the outrageous cost for the commercial module). The WARM spare seems like the perfect solution but has been nothing but trouble so far. For now I disabled the automatic backup and I manually run the backups after most changes and manually disable the backups trunks.


There was a few reports on this lately.

As always, if you need this resolved asap you can open a support ticket by clicking the link on top.

Are you using registered trunks as that option only works for registered trunks.

Hi Tony

In my case I am using registered trunks. This issue was noticed by us on a PJSIP trunk over a month ago, when it was reported to support. As yet, there hasnt been any progress as far as we are aware.


Is their a bug report here.

Hi Tony

I haven’t personally logged one, however there are two others:


This has been resolved and now is in code review under FREEPBX-16782
Once complete (enters “EDGE”) you should be able to update core and resolve this.

This is a known issue (that really messed me up for a week or so) because I couldn’t figure out why I was intermittently having calls get rejected. Turns out, it was the warm backup not disabling the backup server’s trunk.

I just wanted to chime in and let you know that until now, the warm backup setup has worked flawlessly.

It should be fixed soon, so don’t despair!

Registered trunks? My sip trunks are User name/ Password authenticated for two reasons, (1) they couldn’t get IP authentication to work with freePBX, my SIP tech support tried for hours, it just wouldn’t authenticate. We switched to username/Password and it worked instantly. (2) I also like username/password authentication so I dont have to manually switch all my numbers to a different trunk if I switch to the warm backup, I just have to enable the trunks on the backup server (and disable on the production server if its still up). Not sure if that makes a difference.

You have registered trunks… Looks like it is fixed…

fwconsole ma --edge upgrade core

I’ve finally got around to testing this; but unfortunately it isn’t fixed.

AFAIK if you are using PJSIP trunks, there is no way to use FreePBX/PBXAct with a ‘warm’ backup node.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.