Voicemail not responding on *97 and *98 as expected

Hi,

I’m far from a Linux/Asterisk/FreePBX expert.

I’m running Asterisk V 1.4.29.1 and FreePBX V 2.7 on CentOS, using a Linksys SPA962 VoIP Phone - generally all working beautifully. I just can’t get Comedian Mail to respond as expected.

If I dial *98, I get the following response:
"Comedian Mail. Mailbox?"
I enter the extension number, e.g. "201"
"Password?"
I enter the password, e.g. "1234"
“Login Incorrect. Mailbox?”

The mailbox/password details are 100% correct.

Even more strange is if I dial *97, I get exactly the same - it doesn’t appear to pick up the extension number automatically and just ask me for the password.

Below is taken from the logfile for the *97 event:


[Mar 8 17:40:34] VERBOSE[725] logger.c: – Executing [*[email protected]:4] Macro(“SIP/201-000000b2”, “get-vmcontext|201”) in new stack
[Mar 8 17:40:34] VERBOSE[725] logger.c: – Executing [[email protected]:1] Set(“SIP/201-000000b2”, “VMCONTEXT=default”) in new stack
[Mar 8 17:40:34] DEBUG[725] app_macro.c: Executed application: Set
[Mar 8 17:40:34] VERBOSE[725] logger.c: – Executing [[email protected]:2] GotoIf(“SIP/201-000000b2”, “0?200:300”) in new stack
[Mar 8 17:40:34] VERBOSE[725] logger.c: – Goto (macro-get-vmcontext,s,300)
[Mar 8 17:40:34] DEBUG[725] app_macro.c: Executed application: GotoIf
[Mar 8 17:40:34] VERBOSE[725] logger.c: – Executing [[email protected]:300] NoOp(“SIP/201-000000b2”, “”) in new stack
[Mar 8 17:40:34] DEBUG[725] app_macro.c: Executed application: NoOp
[Mar 8 17:40:34] VERBOSE[725] logger.c: – Executing [*[email protected]:5] MailboxExists(“SIP/201-000000b2”, “[email protected]”) in new stack
[Mar 8 17:40:34] VERBOSE[725] logger.c: – Executing [*[email protected]:6] GotoIf(“SIP/201-000000b2”, “0?mbexist”) in new stack
[Mar 8 17:40:34] VERBOSE[725] logger.c: – Executing [*[email protected]:7] VoiceMailMain(“SIP/201-000000b2”, “”) in new stack
[Mar 8 17:40:34] VERBOSE[725] logger.c: – <SIP/201-000000b2> Playing ‘vm-login’ (language ‘en’)
[Mar 8 17:40:35] VERBOSE[726] logger.c: == Parsing ‘/etc/asterisk/manager.conf’: [Mar 8 17:40:35] VERBOSE[726] logger.c: Found
[Mar 8 17:40:35] VERBOSE[726] logger.c: == Parsing ‘/etc/asterisk/manager_additional.conf’: [Mar 8 17:40:35] VERBOSE[726] logger.c: Found
[Mar 8 17:40:35] VERBOSE[726] logger.c: == Parsing ‘/etc/asterisk/manager_custom.conf’: [Mar 8 17:40:35] VERBOSE[726] logger.c: Found
[Mar 8 17:40:35] VERBOSE[726] logger.c: == Manager ‘admin’ logged on from 127.0.0.1
[Mar 8 17:40:36] VERBOSE[726] logger.c: == Manager ‘admin’ logged off from 127.0.0.1
[Mar 8 17:40:38] VERBOSE[734] logger.c: == Parsing ‘/etc/asterisk/manager.conf’: [Mar 8 17:40:38] VERBOSE[734] logger.c: Found
[Mar 8 17:40:38] VERBOSE[734] logger.c: == Parsing ‘/etc/asterisk/manager_additional.conf’: [Mar 8 17:40:38] VERBOSE[734] logger.c: Found
[Mar 8 17:40:38] VERBOSE[734] logger.c: == Parsing ‘/etc/asterisk/manager_custom.conf’: [Mar 8 17:40:38] VERBOSE[734] logger.c: Found
[Mar 8 17:40:38] VERBOSE[734] logger.c: == Manager ‘admin’ logged on from 127.0.0.1
[Mar 8 17:40:38] VERBOSE[734] logger.c: == Manager ‘admin’ logged off from 127.0.0.1
[Mar 8 17:40:39] VERBOSE[725] logger.c: – <SIP/201-000000b2> Playing ‘vm-password’ (language ‘en’)
[Mar 8 17:40:43] VERBOSE[737] logger.c: == Parsing ‘/etc/asterisk/manager.conf’: [Mar 8 17:40:43] VERBOSE[737] logger.c: Found
[Mar 8 17:40:43] VERBOSE[737] logger.c: == Parsing ‘/etc/asterisk/manager_additional.conf’: [Mar 8 17:40:43] VERBOSE[737] logger.c: Found
[Mar 8 17:40:43] VERBOSE[737] logger.c: == Parsing ‘/etc/asterisk/manager_custom.conf’: [Mar 8 17:40:43] VERBOSE[737] logger.c: Found
[Mar 8 17:40:43] VERBOSE[737] logger.c: == Manager ‘admin’ logged on from 127.0.0.1
[Mar 8 17:40:44] VERBOSE[725] logger.c: – Incorrect password ‘1234’ for user ‘201’ (context = default)
[Mar 8 17:40:44] VERBOSE[725] logger.c: – <SIP/201-000000b2> Playing ‘vm-incorrect-mailbox’ (language ‘en’)

I’d be really grateful if anyone could make any suggestions, or pick something obvious out of the logfile.

I also get the same results when using a softphone - CounterPath’s Bria for Outlook V 2.0.2.196.

Many thanks in advance,

Colin

The extension voicemail password is not the same as the extension secret. The voicemail password is unique to the voicemail and is created in the Voicemail & Directory section under FreePBX when you create the extension.

Hi Eugene,

Many thanks for your response.

My Voicemail Password is already set as you suggested, with my Extension Secret being totally different.

Kind regards,

Colin

Reserved extensions:
200 Park Notify
300-399 Reserved for speed dial
666 Reserved for Fax dialing
70-79 Reserved for calls on hold
700-799 Reserved for calls on hold
7777 Reserved extension for incoming calls simulation

What about accessing the voicemail through the web interface?

Hi Eugene,

Thanks again for your response and your suggestion.

My Asterisk/FreePBX setup is for my home/home-office, so only has 5 extensions, none of which appear to clash, as follows:
101
102
111
201
202

I’m starting to consider the sledgehammer approach of a complete re-install of Asterisk!

Kind regards,

Colin

Hi,

I’ve just been browsing other posts, and it appears that sometimes FreePBX can insert “[]” into the voicemail.conf file, which prevents all mailboxes after the [] from working.

AND

In the Extensions screen, under the Device Options section, the value against Mailbox was e.g. [email protected] When I investigated the file structure, there was no var/spool/asterisk/voicemail/default directory, but there was a var/spool/asterisk/voicemail/device directory.

SO…
I edited the voicemail.conf file to remove any occurances of [], then changed the Mailbox value in FreePBX to [email protected], and it has now started working as expected.

Kind regards,

Colin

Good to know. Will have to put that one in the troubleshooting book.

Just a note, don’t know if it was subtle humor but “Comedian Mail. Mailbox?” is actually Chameleon Mail.

I have the same problem. It used to work then I altered one users password via FreePBX and it deleted everyones VM settings from voicemail.conf [default]. The VM directories exist in my case. Changing back to ‘device’ instead of ‘default’ doesn’t change anything. Any suggestions? Thanks.

paynecs,

the issue you mentioned wrt to the []

That is a very old bug that was very short lived. What version are you running that you encountered that problem? That was squashed well over a year ago iirc???

Hi,

I had the same problem. I ran asterisk -r and watched as I entered the password. When I used 3CX as my softphone, each button I pressed displayed twice, so password ‘1234’ became ‘11223344’.

I changed to Zoiper for my phone, and the problem went away. I looked, but could not find where the echoed chars might be configurable in 3CX.

Cheers,

Jonathan.

Hello All,

When I run *98 put in 105 ( of course for x105 ) tell it the password which is currently set to 4321 in the WebUI, it errors out.
I changed the password, recreated the extension, but all with no luck.
I’m running the current FreePBX ISO distro.

-- Executing [*[email protected]:5] NoOp("SIP/101-00000019", "app-dialvm: Got Mailbox 105") in new stack
-- Executing [*[email protected]:6] Macro("SIP/101-00000019", "get-vmcontext,105") in new stack
-- Executing [[email protected]:1] Set("SIP/101-00000019", "VMCONTEXT=default") in new stack
-- Executing [[email protected]:2] GotoIf("SIP/101-00000019", "0?200:300") in new stack
-- Goto (macro-get-vmcontext,s,300)
-- Executing [[email protected]:300] NoOp("SIP/101-00000019", "") in new stack
-- Executing [*[email protected]:7] Set("SIP/101-00000019", "VMBOXEXISTSSTATUS=FAILED") in new stack
-- Executing [*[email protected]:8] GotoIf("SIP/101-00000019", "0?good:bad") in new stack
-- Goto (from-internal,*98,14)
-- Executing [*[email protected]:14] NoOp("SIP/101-00000019", "app-dialvm: BAD mailbox [email protected]") in new stack
-- Executing [*[email protected]:15] Wait("SIP/101-00000019", "1") in new stack
-- Executing [*[email protected]:16] NoOp("SIP/101-00000019", "app-dialvm: Asking for password so people can't probe for existence of a mailbox") in new stack
-- Executing [*[email protected]:17] Read("SIP/101-00000019", "FAKEPW,vm-password,,,3,2") in new stack
-- <SIP/101-00000019> Playing 'vm-password.alaw' (language 'en')
-- User entered nothing, 2 chances left
-- <SIP/101-00000019> Playing 'vm-password.alaw' (language 'en')
-- User entered nothing, 1 chance left
-- <SIP/101-00000019> Playing 'vm-password.alaw' (language 'en')
-- User entered '4321'
-- Executing [*[email protected]:18] NoOp("SIP/101-00000019", "app-dialvm: Asking for mailbox again") in new stack
-- Executing [*[email protected]:19] Read("SIP/101-00000019", "MAILBOX,vm-incorrect-mailbox,,,3,2") in new stack

I have tried this on other extensions with no luck.
Any suggestions?

Thanks!

Have you updated to the latest distro. There was a bug with free bs 2.9 creating a corrupt voicemail.conf file. What version of the ISO are you using?

Hi Tony,

I see your a 24x7 tech as well.
I just downloaded the distro yesterday, but I see there are some yum updates available. I posted a question if it’s OK with this distro to trust yum and update because with trixbox we used to see a lot of issues.

Thanks!
yum check-update
Loaded plugins: fastestmirror, kmod
Loading mirror speeds from cached hostfile

asterisk18.i386 1.8.3.2-4_centos5 pbx
asterisk18-addons.i386 1.8.3.2-4_centos5 pbx
asterisk18-addons-bluetooth.i386 1.8.3.2-4_centos5 pbx
asterisk18-addons-core.i386 1.8.3.2-4_centos5 pbx
asterisk18-addons-mysql.i386 1.8.3.2-4_centos5 pbx
asterisk18-addons-ooh323.i386 1.8.3.2-4_centos5 pbx
asterisk18-app_flite.i386 0.6-2 pbx
asterisk18-core.i386 1.8.3.2-4_centos5 pbx
asterisk18-curl.i386 1.8.3.2-4_centos5 pbx
asterisk18-dahdi.i386 1.8.3.2-4_centos5 pbx
asterisk18-voicemail.i386 1.8.3.2-4_centos5 pbx
freepbx.noarch 2.9.0-beta6 pbx
gdb.i386 7.0.1-23.el5_5.2 updates

http://www.freepbx.org/forum/freepbx-distro/distro-discussion-help/no-voicemail-login This talks about the voicemail bug

Follow this thread for updates; http://www.freepbx.org/forum/freepbx-distro/distro-discussion-help/release-versions

Yes the way we do yum and that all yum repos are on our servers you can safely upgrade but I would use the upgrade scripts I have outlined above as they do other cleanup of bugs and not just RPM installs.

We will have a Distro GUI based updates system at some point. Just not sure if it will be free or part of a cheap $100.00 a year maint program to have safe and trustable updates tested and vested by us. We currently handle auto updates for about 2500 Commercial PBX customers on our PBXact and PBXtended platform and very rarely break things and this includes kernal updates and jumping between big asterisk versions. We took a large install base about 18 months ago from centos 4.5 to 5.5 and asterisk 1.2.18 to 1.4.39 and did not break a single system.

Also if you email me your voicemail.conf file I can let you know if there is a issue with it.

tony dot lewis at schmoozecom.com

I will run through the updates real quick, and then send you the file if I still have a problem. I checked it and it looked good when I first was looking for solutions to the issue. I appreciate your help!
I am cramming this distro in because I have a decent sized install and I want to run this version instead of TB. I ended up converting my system, which baseically means config from scratch. Its given me a couple of small speed bumps but more stuff is running.
Again thanks for your quick response!!!

IF after “SOLUTION!!!” (by Colin) your VoiceMail dont work, try this:

*** MAKE THIS UNDER YOUR OWN RISK ***

  1. Enable your voicemail with password and an email.

  2. Ensure you the solution given by Colin is saved.

  3. Make a connection ssh to your Asterisk (ssh [email protected]).

  4. See the directory of device:
    ls -l /var/spool/asterisk/voicemail/device

  5. If you can see one o many simbolic links in blinking leters, you have a problem.

  6. Try the next step loged with root account.

  7. mkdir /var/spool/asterisk/voicemail/default/NNNN && chown asterisk:asterisk /var/spool/asterisk/voicemail/default/NNNN

    Where NNNN = Extension with problems

    *** WARNING: Please make a backup first. ***

  8. Now, try *98 and access to your VoiceMail.

I hope this procedure helps you.

Tanks and sorry my very bad Eng.

_JPGO / @JPGO
Santiago Chile

Hi all,

Something very weird here, i am using FreePbx 2.4
When i try to call this extension x3805 and no one picking up the phone, it prompt me to record message,and i recorded the message. when i go back to the 3805 phone and press *97, after keying in the password, it says you have no messages.

Im fairly new to FReepbx, any help will be appreciated, thanks

Jeremy

1 Like

Jeremy - You are clearly new to forums also. Hijacking a thread and changing the topic is a sure way to not get help.

I am sorry , i will create a new post, thanks