Voicemail not responding on *97 and *98 as expected

It seemed to work fine for the first day voicemail was working fine, but then when trying to check voice mail it indicated that the password was incorrect… I checked the voicemail conf file and it seems normal… I can access voicemail thru the web but not a softphone…
any suggestions? centOS release 5.7 kernel 2.6.18 - 238.9.1.e15

piaf version
free pbx ver.2.8.14

I was having the same issue but all the links and conf files checked out OK. Same scenario as ricmitch, I could not log in to voicemail from a phone but I could log in to the voicemail web interface.

My fix: Log in to the web interface for the affected extension (146 in my case). Go to the Settings section. Enter a new password, confirm the password and click Update. Now I am able to log in from a phone!!

I do not know what the difference was in changing the VM password here as opposed to the FreePBX Admin module, but this made it work for me!

I have tried all the above suggestions but nothing works, wrong password, and why a password prompt at all when using *97?

I found this http://fonality.com/trixbox/node/14044
Removed all INBAN settings on the phone, and it works.

Make sure to enable support for RFC2833 DTMF. It works for me. Using 3CXPhone.
(RFC2833 DTFM, INBAND DTMF, & SIPINFO DTMF were all disabled on mine.)
Thank you stigolar for that hint.