Voicemail hanging up

Hello, When I’m calling into my pbx It goes to voicemail and after it says its message it just hangs up. I have never say that in the voicemail before. I have looked up for this problem and it is all over the place and I’m not sure what is going on. Can someone help me to figure this out?

Its stating when the voicemail comes up saying the phone number then saying the voicemail is unavailble follow by it hanging up the call.

One thing is doesn’t do is saying the Ext number like it did before. This is strange.


How do you end up in the voicemail to begin with? Is this after you call an extension that doesn’t answer? Or do you have a call flow configured that eventually ends with the call being sent to the voice mailbox.

What i did was I set a extension that is not attached to a phone. When they call in it goes to extension 650 automatically then if no answer it redirects to extension 100 that has no phone attached to it that I use for voicemail only. It worked into we had some power out in the building. When power came back everything was working but voicemail stopped. I changed nothing at all.

You’ll need to provide relevant logs showing the call and when it hits the VM and then when it hangs up not allowing you to leave a message.

I put is in pastebin way to much to be in here.


I am not seeing it do any of the things that you are saying you are expecting it to do.

The call just rings extension 654 and 653 and then hangs up after nobody answers the call. You didn’t pull this from the asterisk log so it doesn’t really have any time stamps to tell me for how long the call rings but it’s looking like it’s doing what it’s configured to do.

-- PJSIP/654-00000036 is ringing
-- PJSIP/653-00000035 is ringing
   > 0x7f6b7c02b2b0 -- Strict RTP learning complete - Locking on source address
-- Stopped music on hold on PJSIP/609788xxxx
-- PJSIP/653-00000035 Internal Gosub(crm-hangup,s,1) start

I went into ssh and put in asterisk -rvvvv and got it from there is what I copied when I called in The whole thing.

Is there any other place I need to go to get the logs? Also is there anything I can screenshot and show?

So there is the /var/log/asterisk/full log that shows the full log but with timestamps to give you context about what happens and when. In this case it doesn’t really matter. You need to go back and look at your call flow configuration as the call log that you did provide does not show any of the call flow that you said you were expecting in a previous comment.

Extension 650 never rings nor does the call get forwarded to extension 100 after the call isn’t answered.

Check your flow starting with the inbound route (or wherever the entry point for the call is) and verify that you are connecting all the dots you want to connect as you want the call to flow through your system.

I can only ssh remote into it or web login. I don’t have any other access to it at the moment. I’m not there.

Again, no need for further logs. Your configuration and what you are expecting the system to do don’t line up.

The way it is configure now is that. When someone calls in it goes to ring group 600 to two phones. Then if no one answers in 20 seconds then it goes to ring group 601 that rings to all phones at the same thing after 20 seconds if no one picks up it goes to voicemail Ext 100. But the problem is after it rings it normally says Ext 100 is unavilalble please leave a message or something like that.

It doesn’t even say that. it just says the phone number that is from the pbx and hangs up. Voicemail was working and it was perfectly fine now this and I have no clue what happen.

What happens if you just call extension 100 directly from one of the phones and let it ring? Will it eventually let you leave a voice mail message?

IT goes straight to voicemail. I have tried to switch it to a phone extension mailbox because each phone has a mail box. However ext 100 is just a ll over general mail box.

When I try to change it to one of the phone mail box i get the same results.

Edit: I made some progress If I put the incoming route to extension 100 it goes straight to that mailbox so that works. But If i put it to ringgroup 1 then straight to voicemail afterwords it doesn’t work.

I don’t understand what’s going on here actually. Your screenshots show only extension 654 as the member of ring group 600 but extensions 653 and 654 are ringing instead. The call never actually is forwarded to your next ring group 601 and those other extensions that are listed in that ring group never ring (other then 653 and 654) initially.

I made a new ring group and pointed to inbound routes. I have it only ring to ext 650 and 651. If no answer then It goes to voicemail extension 100. I get the same results as before somehow it doesn’t ring to voicemail after being redirect from the ring group if no answer.

I deleted all the other ring groups. I just have this new one.

however I still get the same results. I don’t know what is wrong or what I’m missing.

Can you upload a new call log that shows a call going to this ring group? I’d like to compare to the previous call log.

here it is.

I do not hang up the call. It hangs up on me.

just a update: If I disabled the phones and straight to voicemail in the ring group it is fine it works with no problems. But Once I add the phones into it then that is when I get that error.

How long do the phones ring for? Are these extensions next to you and can you hear them ringing? In this latest log I don’t see extension 651 ringing, it says that it’s offline. That shouldn’t prevent it from moving the call to VM but I am not understanding why that’s not happening right now. Maybe somebody else here will notice something that I am missing.