Voicemail Direct Dial Prefix not functioning

This is a fresh setup with only a couple of extensions connected.

In Feature Code admin section I can see it set to an asterisk.
Using Asterisk 15.5.0

Here is the call result.

– Executing [*[email protected]:1] Answer(“PJSIP/1001-00003e34”, “”) in new stack
– Executing [*[email protected]:2] Macro(“PJSIP/1001-00003e34”, “user-callerid,”) in new stack
– Executing [[email protected]:1] Set(“PJSIP/1001-00003e34”, “TOUCH_MONITOR=1550515101.17142”) in new stack
– Executing [[email protected]:2] Set(“PJSIP/1001-00003e34”, “AMPUSER=1001”) in new stack
– Executing [[email protected]:3] GotoIf(“PJSIP/1001-00003e34”, “0?report”) in new stack
– Executing [[email protected]:4] ExecIf(“PJSIP/1001-00003e34”, “1?Set(REALCALLERIDNUM=1001)”) in new stack
– Executing [[email protected]:5] Set(“PJSIP/1001-00003e34”, “AMPUSER=1001”) in new stack
– Executing [[email protected]:6] GotoIf(“PJSIP/1001-00003e34”, “0?limit”) in new stack
– Executing [[email protected]:7] Set(“PJSIP/1001-00003e34”, “AMPUSERCIDNAME=Test Line”) in new stack
– Executing [[email protected]:8] ExecIf(“PJSIP/1001-00003e34”, “0?Set(__CIDMASQUERADING=TRUE)”) in new stack
– Executing [[email protected]:9] GotoIf(“PJSIP/1001-00003e34”, “0?report”) in new stack
– Executing [[email protected]:10] Set(“PJSIP/1001-00003e34”, “AMPUSERCID=1001”) in new stack
– Executing [[email protected]:11] Set(“PJSIP/1001-00003e34”, “__DIAL_OPTIONS=HhTtr”) in new stack
– Executing [[email protected]:12] Set(“PJSIP/1001-00003e34”, “CALLERID(all)=“Test Line” <1001>”) in new stack
– Executing [[email protected]:13] GotoIf(“PJSIP/1001-00003e34”, “0?limit”) in new stack
– Executing [[email protected]:14] ExecIf(“PJSIP/1001-00003e34”, “0?Set(GROUP(concurrency_limit)=1001)”) in new stack
– Executing [[email protected]:15] ExecIf(“PJSIP/1001-00003e34”, “0?Set(CHANNEL(language)=)”) in new stack
– Executing [[email protected]:16] NoOp(“PJSIP/1001-00003e34”, “Macro Depth is 1”) in new stack
– Executing [[email protected]:17] GotoIf(“PJSIP/1001-00003e34”, “1?report2:macroerror”) in new stack
– Goto (macro-user-callerid,s,18)
– Executing [[email protected]:18] GotoIf(“PJSIP/1001-00003e34”, “0?continue”) in new stack
– Executing [[email protected]:19] ExecIf(“PJSIP/1001-00003e34”, “1?Set(__CALLEE_ACCOUNCODE=)”) in new stack
– Executing [[email protected]:20] Set(“PJSIP/1001-00003e34”, “__TTL=64”) in new stack
– Executing [[email protected]:21] GotoIf(“PJSIP/1001-00003e34”, “1?continue”) in new stack
– Goto (macro-user-callerid,s,37)
– Executing [[email protected]:37] Set(“PJSIP/1001-00003e34”, “CALLERID(number)=1001”) in new stack
– Executing [[email protected]:38] Set(“PJSIP/1001-00003e34”, “CALLERID(name)=Test Line”) in new stack
– Executing [[email protected]:39] GotoIf(“PJSIP/1001-00003e34”, “0?cnum”) in new stack
– Executing [[email protected]:40] Set(“PJSIP/1001-00003e34”, “CDR(cnam)=Test Line”) in new stack
– Executing [[email protected]:41] Set(“PJSIP/1001-00003e34”, “CDR(cnum)=1001”) in new stack
– Executing [[email protected]:42] Set(“PJSIP/1001-00003e34”, “CHANNEL(language)=en”) in new stack
– Executing [*[email protected]:3] GotoIf(“PJSIP/1001-00003e34”, “0?from-internal,1”) in new stack
– Executing [*[email protected]:4] Goto(“PJSIP/1001-00003e34”, “bad-number,s,1”) in new stack
– Goto (bad-number,s,1)
– Executing [[email protected]:1] Goto(“PJSIP/1001-00003e34”, “11,1”) in new stack
– Goto (bad-number,11,1)
– Executing [[email protected]:1] ResetCDR(“PJSIP/1001-00003e34”, “”) in new stack
– Executing [[email protected]:2] NoCDR(“PJSIP/1001-00003e34”, “”) in new stack
– Executing [[email protected]:3] Progress(“PJSIP/1001-00003e34”, “”) in new stack
– Executing [[email protected]:4] Wait(“PJSIP/1001-00003e34”, “1”) in new stack
– Executing [[email protected]:5] Playback(“PJSIP/1001-00003e34”, “silence/1&cannot-complete-as-dialed&check-number-dial-again,noanswer”) in new stack
– <PJSIP/1001-00003e34> Playing ‘silence/1.ulaw’ (language ‘en’)
– <PJSIP/1001-00003e34> Playing ‘cannot-complete-as-dialed.ulaw’ (language ‘en’)
– <PJSIP/1001-00003e34> Playing ‘check-number-dial-again.ulaw’ (language ‘en’)

Feature Code collision? Do you have Speed Dial changed from the default *10 to something else? Otherwise this is trying to speed dial 00 which doesn’t exist.

This is a new install, and I have not changed anything.

With that, I see Speed Dial is set to *0
I also see Contact Manager Speed Dials set to *10

OK, so it is a Feature Code collision. You’ll need to update your feature codes to match your needs.

1 Like

Yeah, I went ahead and disabled Contact Manager Speed Dials and it is workign again.

Thanks for pointing that out.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.