FreePBX | Register | Issues | Wiki | Portal | Support

VM Blasting


#1

Is there a way to eliminate the ‘If this is correct, press 1’ for the VM blast application?
We are using the VMBlast as a way for people to dial an ‘extension’ to leave many people a message. (example - People calling in sick for a shift)

Thanks,
Tom


#2

I created recording that was more suitable for my use, and changed the sound name the program was using in the module /var/www/html/admin/modules/vmblast/functions.inc.php

Tom


#3

I’m not saying that it doesn’t work - it’s just that we have an announcement telling the caller to explain why they won’t be in for their shift. After the announcement message completes, a system message prompts the caller by saying ‘if this is correct, press one’. The caller can’t leave a message until pressing 1.

I want it to be more like leaving a voicemail - only it needs to go to multiple people.
I understand the point where you want the caller to be sure that the message they will blast will go to the intended group, but in this case, I want to eliminate the system prompt.
I found this piece of code on the elastix site, but when I try it, I only get the tone to record:
http://www.store.elastix.org/en/component/kunena/3-help/44475-vmblast-remove-qpress-1-if-correctq.html
I’m running PiaF - but I don’t think that matters in this case. (FPX 2.8)

If I can find the sound file and replace it with another - even a blank sound, that may solve it for me, but I don’t know if the system sound file is used for other apps - I think that ‘if this is correct, press one’ may be used in multiple scenarios.

Thanks,
Tom


How Can You Prevent Making Changes in Greetings and Settings in Voicemail module in the UCP (User Control Panel)
#4

what happens if you just hang up after leaving the message?


#5

Searched all over the web and found some stuff on the elastix forums, however there were using the wrong variable for the voicemail blast announcement most were using ${MSG} in my install of freepbx 2.9 it should be ${VMBMSG}.

Use this code in extensions_override_freepbx.conf to remove the “press 1 to confirm” prompt after the VM Blast announcement!

[app-vmblast]
include => app-vmblast-custom
exten => vmblast,1(digits),ExecIf($["${DIGITS}" != “”],SayDigits,${DIGITS})
exten => vmblast,n(msg),ExecIf($["${VMBMSG}" != “”],Background,${VMBMSG})
exten => vmblast,n,VoiceMail(${GRPLIST:1},s)
exten => 1,n,Hangup

; end of [app-vmblast]

This is super simple but it took me a few hrs of debugging to figure this out LOL, I hope this helps others!


#6

This is an old post. I just want to confirm asantiago’s suggestion and the change made to /etc/asterisk/extensions_override_freepbx.conf. Worked like a charm! Thanks!


#7

The extensions_override_freepbx.conf worked for us. Thank you!


(Doug) #8

The way we handle this within the FreePBX interface is to first send the caller to announcement, then to the VM Blast group. On the VM Blast group itself, change the Audio Label “beep only - no confirmation”. Plays the recording and just beeps at the end for the caller to leave their message.

Doug


#9

Tried this on a current up to date PBX and it doesn’t work. Do I need to reload anything for this to work? Or is there an option in the GUI now?

EDIT: Nevermind, just had to reboot the server and now it works! Thanks @asantiago !


(Free Software Servers) #10

That’s all great except I have a “pre-anncouncement” IE: Nobody is available to answer your call, then another anoucement that changes periodically. So I need both setup. The extensions_override fixed it for me.

cat << 'EOL' >/etc/asterisk/extensions_override_freepbx.conf
[app-vmblast]
include => app-vmblast-custom
exten => vmblast,1(digits),ExecIf($["${DIGITS}" != “”],SayDigits,${DIGITS})
exten => vmblast,n(msg),ExecIf($["${VMBMSG}" != “”],Background,${VMBMSG})
exten => vmblast,n,VoiceMail(${GRPLIST:1},s)
exten => 1,n,Hangup

; end of [app-vmblast]
EOL