Vega bridge service for Vega configuration is not running

hi, I am using FreePBX 14.0.5.25 with all modules current. i tried to use the vega module today and was presented with this banner error.


also, the module would not connect to my vega. I did see this closed ticket
https://issues.freepbx.org/browse/FREEPBX-17012
that sounds like my issue, but I think i am using the most current module version

| vega | 14.0.3.16 | Enabled | Commercial+ |

does anyone have any suggestions, should I re-open the old bug report?

thanks

Update: from the pbx console, i am able to ssh to the vega and login with admin creds…so i don’t think this is a network issue, also, the vega and the PBX are on the same subnet, so no firewall between them.

bump, I would appreciate any help on this.

Hi @tonyg please follow point#3 debugging step from https://wiki.freepbx.org/display/FPG/Troubleshooting . May be that can help you to narrow down the problem.

1 Like

hi, thanks for replying.
i did review the page you list. systemctl errors when it tries to start vega_bridge. it appears from /run/systemd/generator.late/vega_bridge.service that it is using the script /etc/rc.d/init.d/vega_bridge…however, that script does not exist. so i did the following

fwconsole ma uninstall vega
fwconsole ma --edge download vega
fwconsole ma install vega

but still, /etc/rc.d/init.d does not contain that script, so the service does not start.

why do i not have that script?

I can tell you I have the same error on a system. I just installed the vega interface yesterday to manage the vega 3050 gateways.

tailing /var/log/messages I see this error:
Mar 28 15:23:52 pbx002 systemd: Starting SYSV: Vega Bridge Startup Script....
Mar 28 15:23:52 pbx002 systemd: Failed at step EXEC spawning /etc/rc.d/init.d/vega_bridge: No such file or directory
Mar 28 15:23:52 pbx002 systemd: vega_bridge.service: control process exited, code=exited status=203
Mar 28 15:23:52 pbx002 systemd: Failed to start SYSV: Vega Bridge Startup Script..
Mar 28 15:23:52 pbx002 systemd: Unit vega_bridge.service entered failed state.
Mar 28 15:23:52 pbx002 systemd: vega_bridge.service failed.
Mar 28 15:24:00 pbx002 systemd: Reloading.

The other vega_* logs in that directory have nothing useful other than it can’t start and that was from the time I installed the freepbx module.

I have vega module version 14.0.3.12 currently installed on FreePBX v14.0.5.25. I don’t know the systemctl process very well yet, but I don’t see a vega_bridge.service in /usr/lib/systemd/system. That may be why its not starting?

The services file is in /run/systemd/generator.late/vega_bridge.service
I think we have the right persons attention on this! (Kapil)…I am hopeful!

I’m not sure why it would be in /var/run/… that is for services that have become operational. I can say that I don’t have any vega_* file in that location. But I’ll wait and see what the experts have to say.

At this point all we can say for sure there are two isolated systems behaving the same way.

Hi @tonyg I think it would be better(and faster) if you could raise support ticket to our ticketing system so i can login to your server to see whats going on.

Hi, sorry, I don’t have any support credits left.

if you do this from CLI, do you see the module shown in the snippet below ?

[[email protected] ~]# yum list vega
Loaded plugins: fastestmirror, versionlock
Loading mirror speeds from cached hostfile
Installed Packages
python36u-vega.x86_64 1.2.3-1.sng7

[[email protected] ~]# yum list vega
Loaded plugins: fastestmirror, versionlock
Loading mirror speeds from cached hostfile
Error: No matching Packages to list

I get the same “No matching package”.

Running yum install python36u-vega* nets me:
Loaded plugins: fastestmirror, versionlock Loading mirror speeds from cached hostfile Package python36u-vega-1.2.3-1.sng7.x86_64 already installed and latest version Nothing to do

This is the product of this query repoquery -l python36u-vega-1.2.3-1.sng7.x86_64
/usr/bin/vegactl
/usr/lib/python3.6/site-packages/aiopytest/init.py
/usr/lib/python3.6/site-packages/aiopytest/pycache/init.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/aiopytest/pycache/init.cpython-36.pyc
/usr/lib/python3.6/site-packages/aiopytest/pycache/bdd.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/aiopytest/pycache/bdd.cpython-36.pyc
/usr/lib/python3.6/site-packages/aiopytest/pycache/plugin.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/aiopytest/pycache/plugin.cpython-36.pyc
/usr/lib/python3.6/site-packages/aiopytest/bdd.py
/usr/lib/python3.6/site-packages/aiopytest/plugin.py
/usr/lib/python3.6/site-packages/aiovega/init.py
/usr/lib/python3.6/site-packages/aiovega/pycache/init.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/aiovega/pycache/init.cpython-36.pyc
/usr/lib/python3.6/site-packages/aiovega/pycache/config.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/aiovega/pycache/config.cpython-36.pyc
/usr/lib/python3.6/site-packages/aiovega/pycache/exceptions.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/aiovega/pycache/exceptions.cpython-36.pyc
/usr/lib/python3.6/site-packages/aiovega/pycache/firmware.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/aiovega/pycache/firmware.cpython-36.pyc
/usr/lib/python3.6/site-packages/aiovega/pycache/parser.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/aiovega/pycache/parser.cpython-36.pyc
/usr/lib/python3.6/site-packages/aiovega/pycache/path.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/aiovega/pycache/path.cpython-36.pyc
/usr/lib/python3.6/site-packages/aiovega/pycache/serialize.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/aiovega/pycache/serialize.cpython-36.pyc
/usr/lib/python3.6/site-packages/aiovega/pycache/shell.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/aiovega/pycache/shell.cpython-36.pyc
/usr/lib/python3.6/site-packages/aiovega/cli/init.py
/usr/lib/python3.6/site-packages/aiovega/cli/pycache/init.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/aiovega/cli/pycache/init.cpython-36.pyc
/usr/lib/python3.6/site-packages/aiovega/cli/pycache/repl.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/aiovega/cli/pycache/repl.cpython-36.pyc
/usr/lib/python3.6/site-packages/aiovega/cli/repl.py
/usr/lib/python3.6/site-packages/aiovega/config.py
/usr/lib/python3.6/site-packages/aiovega/exceptions.py
/usr/lib/python3.6/site-packages/aiovega/filetransfer/init.py
/usr/lib/python3.6/site-packages/aiovega/filetransfer/pycache/init.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/aiovega/filetransfer/pycache/init.cpython-36.pyc
/usr/lib/python3.6/site-packages/aiovega/filetransfer/pycache/http.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/aiovega/filetransfer/pycache/http.cpython-36.pyc
/usr/lib/python3.6/site-packages/aiovega/filetransfer/pycache/tftp.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/aiovega/filetransfer/pycache/tftp.cpython-36.pyc
/usr/lib/python3.6/site-packages/aiovega/filetransfer/http.py
/usr/lib/python3.6/site-packages/aiovega/filetransfer/tftp.py
/usr/lib/python3.6/site-packages/aiovega/firmware.py
/usr/lib/python3.6/site-packages/aiovega/parser.py
/usr/lib/python3.6/site-packages/aiovega/path.py
/usr/lib/python3.6/site-packages/aiovega/serialize.py
/usr/lib/python3.6/site-packages/aiovega/shell.py
/usr/lib/python3.6/site-packages/aiovega/web/init.py
/usr/lib/python3.6/site-packages/aiovega/web/pycache/init.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/aiovega/web/pycache/init.cpython-36.pyc
/usr/lib/python3.6/site-packages/aiovega/web/pycache/config.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/aiovega/web/pycache/config.cpython-36.pyc
/usr/lib/python3.6/site-packages/aiovega/web/pycache/shell.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/aiovega/web/pycache/shell.cpython-36.pyc
/usr/lib/python3.6/site-packages/aiovega/web/pycache/system.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/aiovega/web/pycache/system.cpython-36.pyc
/usr/lib/python3.6/site-packages/aiovega/web/config.py
/usr/lib/python3.6/site-packages/aiovega/web/shell.py
/usr/lib/python3.6/site-packages/aiovega/web/system.py
/usr/lib/python3.6/site-packages/syslog_server/init.py
/usr/lib/python3.6/site-packages/syslog_server/pycache/init.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/syslog_server/pycache/init.cpython-36.pyc
/usr/lib/python3.6/site-packages/syslog_server/pycache/constants.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/syslog_server/pycache/constants.cpython-36.pyc
/usr/lib/python3.6/site-packages/syslog_server/pycache/message.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/syslog_server/pycache/message.cpython-36.pyc
/usr/lib/python3.6/site-packages/syslog_server/pycache/parser.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/syslog_server/pycache/parser.cpython-36.pyc
/usr/lib/python3.6/site-packages/syslog_server/constants.py
/usr/lib/python3.6/site-packages/syslog_server/message.py
/usr/lib/python3.6/site-packages/syslog_server/parser.py
/usr/lib/python3.6/site-packages/vega-1.2.3-py3.6.egg-info/PKG-INFO
/usr/lib/python3.6/site-packages/vega-1.2.3-py3.6.egg-info/SOURCES.txt
/usr/lib/python3.6/site-packages/vega-1.2.3-py3.6.egg-info/dependency_links.txt
/usr/lib/python3.6/site-packages/vega-1.2.3-py3.6.egg-info/entry_points.txt
/usr/lib/python3.6/site-packages/vega-1.2.3-py3.6.egg-info/requires.txt
/usr/lib/python3.6/site-packages/vega-1.2.3-py3.6.egg-info/top_level.txt
/usr/lib/python3.6/site-packages/vega/init.py
/usr/lib/python3.6/site-packages/vega/pycache/init.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/vega/pycache/init.cpython-36.pyc
/usr/lib/python3.6/site-packages/vega/pycache/analog.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/vega/pycache/analog.cpython-36.pyc
/usr/lib/python3.6/site-packages/vega/pycache/bri.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/vega/pycache/bri.cpython-36.pyc
/usr/lib/python3.6/site-packages/vega/pycache/pri.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/vega/pycache/pri.cpython-36.pyc
/usr/lib/python3.6/site-packages/vega/pycache/vega.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/vega/pycache/vega.cpython-36.pyc
/usr/lib/python3.6/site-packages/vega/analog.py
/usr/lib/python3.6/site-packages/vega/bri.py
/usr/lib/python3.6/site-packages/vega/pri.py
/usr/lib/python3.6/site-packages/vega/vega.py

looks like it removed my asterisks that should have contained vega but you figured it out anyway

you could always try yum reinstall on that package , beyond that you may need to open a support ticket - somethings going on in there

the module itself is supposed to handle setting all that up

perhaps delete the module and re-install … you will of course lose any settings that module contained doing so but it doesnt sound like that would be an issue considering its current condition

if you wanted to take it a step further you could yum erase that package and see if its reinstalled when you install the module again

I tried to remove the above rpm for command line and it gave me an error about sangoma-pbx was protected (good thing it failed). I went back into the web ui and removed the module using the module admin and then readded back in. This time I didn’t get the error message about the vega bridge service. So it appears to be running. I confirmed that the uninstall and reinstalled package versions numbers were the same (which appears to be behind the OP’s version by 4 sub released). I don’t have a clue why it worked on the second installer unless there was some dependency that wasn’t installed correctly the first time, where the second install succeeded.

If there is anything you want me to test, please let me know.

Hi, can you give me the commands you used, i would like to try this as well and see if it helps me.
thanks

Well I would recommend not going down the yum remove route since it appears uninstalling that package also attempted to uninstall the PBX core code.

What worked for me was to go into the Web UI -> Admin -> Module Admin. From there I selected the Vega package under Connectivity. I picked Uninstall from that item (under the twistie). I let it uninstall then clicked on Apply up at the top to refresh asterisk. Then I went and added it back in and selected apply. When I went to Connectivity->Vega Gateway Management the error message was gone.

Hmm, this did not work for me…i wonder if attempting to remove the rpm had some affect?

It never went beyond checking the dependencies. I stopped it because I saw the damage it would cause.

I just ran a find / -name *vega* command and I now see the startup scripts in /etc/rc.d/init.d/vega_bridge directory. (which there were none before) on my install. Do you have this script on your system?

What I find interesting is I issue this command yum provides /usr/bin/vegactl and I can see the rpm file that creates that file. But when I run yum provides /etc/rc.d/init.d/vega_bridge its not found in any rpm.

I wonder if you just need the startup script(s) to get your system working?

If so, I wonder what happens when you paste in this command into your linux console logged in as root
/usr/bin/python3.6 -m aiohttp.web aiovega.web:app_factory -H 127.0.0.1 -P 4000 &>> /var/log/vega_bridge.log That is the start command in the scripts.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.