Vega 60G Gateway (FXO Ports)

Hi, I have installed a Vega 60G Gateway and used the FreePBX Vega Gateway Management to configure it, configured to use the 60G FXO port for connection to my BT line. Incoming and outgoing calls work. However the call setup time for outgoing calls seems very long (approx 15 Seconds). Anyone know how to reduce this call setup time.

Many thanks

Peter

You asked about this in another thread:


Have you set up a proper dial plan on the SPA (or other device you are calling from)?

If so and you’re still having trouble, make a test call and note the time that you dial the last digit (your mobile phone’s clock is probably accurate within one second, good enough for this purpose).

Post the Asterisk log for the call, along with the time you noted, the device dial plan and the values of both interdigit timers.

Did you ever get a SIP trunk? That would also help reduce setup time, because Asterisk wouldn’t have to wait for dial tone and send DTMF.

As a reference, when I call +44 20 3355 6363 with Voxbeam, the call is answered ~2.5 seconds after dialing and the ‘Welcome to iNum’ announcement starts ~1.5 seconds after answer. (This includes some delays you won’t have; I’m in Bangkok and Asterisk is in Los Angeles.)

No, that was for the Cisco SPA I was using, I have discarded that device in favour of the Sangoma G60 Gateway (FXO Ports).

Peter

What device are you calling on (IP phone, softphone, SIP app, ATA with analogue phone, etc.)?

Analogue phone using the Cisco SPA3102 as the FXS interface. Interestingly when I use the softphone call set up time is as expected. So it must be a setting in the ATA.

Do you have a sample Dialplan that you could share, I guess it really should just send any dialed digits to the PBX and then the PBX can do the rest.

My SPA3102 dial plan is;
([0-9]xxx.|03xxx.|07xxx.|007xxx.|*xx)

Peter

Check the Dial Plan for Line 1 in the SPA. If you believe it’s appropriate for UK, then post the dial plan and other data requested in my earlier post.

Here is my dial plan;

([0-9]xxx.|03xxx.|07xxx.|007xxx.|*xx)

Peter

That will work, but not well. Whenever you use a ., you are telling the device that any number of digits may follow, so it waits the interdigit short timeout after each one, to see whether more digits are coming. At least for the formats you frequently dial, set up the dial plan so it looks for the right number of digits. As soon as there is a unique match, the number is sent out immediately. The plan I posted has only one dot (for international calling).

Also note that my plan assumes that you do not dial an extra 0 before external numbers.

Hi Stewart,

I have entered your dial plan;

(999S0|1[1-3]x|1[45]xx|08001111|0845464x|0[58]00xxxxxx|01[2-9][02-9]xxxxxx|0[1-9]xxxxxxxxx|[2-9]xxxxx|00xxxxxxxx.)

it seems to have made things faster. I will test for a few days and report back.

Thanks

Peter

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.