Using Grandstream FXO adapter to a Valcom paging system, asterisk doesnt complete the call, just rings

I have a Valcom paging system that works by providing a line. For example, I can hook up an analog phone directly to it, it will get dial tone, and I dial “#11” and it will page.

I hooked it up via a grandstream FXO adapter. The FXO adapter is configured properly as I can use it to make calls over a POTS line. But what happens when I call the the valcom, the valcom answers, but the PBX continues to ring. It is as if Asterisk/Grandstream are not getting the signal that the line was answered. Any suggestions?

Thank you

Call log please

In the Grandstream, set Enable Call Answer Supervision (or similar parameter, depending on model) to No.

If you already had this setting, or it doesn’t help, post a log including SIP trace, and the model of your FXO device.

Enable call supression is currently set to ch1-4:N;.
When I changed it to ch1-4:Y;
the call doesnt even connect.

The 88 is me telling it to use that outbound route
Call Logs when I have it as N is:
[2019-08-04 18:18:57] VERBOSE[10759][C-00002bbb] app_dial.c: Called SIP/604040/#11
[2019-08-04 18:18:57] VERBOSE[10758][C-00002bbb] app_dial.c: SIP/Voip Innovations-0000234a requested media update control 26, passing it to Local/[email protected];1
[2019-08-04 18:18:57] VERBOSE[10759][C-00002bbb] app_dial.c: Local/[email protected];2 requested media update control 26, passing it to SIP/604040-0000234b
[2019-08-04 18:19:00] VERBOSE[10759][C-00002bbb] app_dial.c: SIP/604040-0000234b is ringing
[2019-08-04 18:19:00] VERBOSE[10758][C-00002bbb] app_dial.c: Local/[email protected];1 is ringing

When I have it as Y they are
[2019-08-04 18:20:20] VERBOSE[10898][C-00002bbc] netsock2.c: Using SIP RTP TOS bits 184
[2019-08-04 18:20:20] VERBOSE[10898][C-00002bbc] netsock2.c: Using SIP RTP CoS mark 5
[2019-08-04 18:20:20] VERBOSE[10898][C-00002bbc] app_dial.c: Called SIP/604040/#11
[2019-08-04 18:20:20] VERBOSE[10898][C-00002bbc] app_dial.c: Local/[email protected];2 requested media update control 26, passing it to SIP/604040-0000234d

Thank you

That doesn’t seem to be a log of a call out of the FXO. You should provide more info, like screenshot of the trunk configuration, both on FreePBX and Grandstream and a log of an actual call from an extension to the pager. Also the outbound route used to call the pager.

Hi,

That was a call in via me using a DISA. When I have the GXW410X hooked up to a regular landline instead of the valcom the call complete without any issues. Attached are screenshots from my pbx, and grandstream

Thank you

GXW410X

Make a call to the pager and post the log

I am trying to send #11 do the Valcom. So I have an outbound route that when I dial 88XX it should strip the 88 and append a # before the 11.

Here is the log when I have the grandtream set to ch1-4:Y; by Enable call supervision.

Here is the log when I have the grandtream set to ch1-4:N; by Enable call supervision I hung up after letting it just ring and ring

Thank you

It appears that the GXW default dial plan does not allow numbers beginning with # .
Try setting it to
{ [x#]+ | [x*]+ }
as shown in

I believe that Call Answer Supervision should be No.

If you still have trouble, type
sip set debug peer 604040
at the Asterisk console, then make a test call. Post the log (which will now include a SIP trace).

I adjusted the dial plan but it still didnt work. Here is the log with debug enabled.

Thank you

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.