Upgrading FreePBX - Unable to start GPG

Hi,

I just ran a whole series of upgrades through the System Admin Pro, I started at 5.211.65-1 and am now at 6.12.65-32.

System Admin Updates says I am up to date but I would like to get to 13 or 14.

I don’t see the option on my dashboard to upgrade to 13.

All my modules are totally up to date and when I try to upgrade via the CLI I get the below error:

[[email protected] upgradescripts]# amportal a ma upgrade framework

Fetching FreePBX settings with gen_amp_conf.php..

Found module locally, verifying...Redownloading
Redownloading
Redownloading
Downloading 9676048 of 9676048 (100%)            
Downloading 9676048 of 9676048 (100%)            
The following error(s) occured:
 - Cant Verify downloaded module /var/www/html/admin/modules/_cache/framework-13.0.192.16.tgz.gpg. Unable to trust GPG Key - aborting (Cause: Unable to start GPG, the command was: [/usr/bin/gpg --homedir /home/asterisk/.gnupg --no-permission-warning --keyserver-options auto-key-retrieve=true,timeout=5 --status-fd 3 --list-keys 2016349F5BC6F49340FCCAF99F9169F4B33B4659])
[[email protected] upgradescripts]# sudo -u asterisk gpg --refresh-keys --keyserver pool.sks-keyservers.net

I tried

[[email protected] upgradescripts]# sudo -u asterisk gpg --keyserver pgp.mit.edu --recv-key 3DDB2122FE6D84F7
gpg: requesting key FE6D84F7 from hkp server pgp.mit.edu
gpg: key FE6D84F7: "FreePBX Mirror 1 (Module Signing - 2016/2017) <[email protected]>" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1

[[email protected] upgradescripts]# sudo -u asterisk gpg --refresh-keys --keyserver pool.sks-keyservers.net
gpg: refreshing 3 keys from hkp://pool.sks-keyservers.net
gpg: requesting key 69D2EAD9 from hkp server pool.sks-keyservers.net
gpg: requesting key B33B4659 from hkp server pool.sks-keyservers.net
gpg: requesting key FE6D84F7 from hkp server pool.sks-keyservers.net
gpg: key 69D2EAD9: "FreePBX Mirror 1 (Module Signing - 2014/2015) <[email protected]>" not changed
gpg: key B33B4659: "FreePBX Module Signing (This is the master key to sign FreePBX Modules) <[email protected]>" not changed
gpg: key FE6D84F7: "FreePBX Mirror 1 (Module Signing - 2016/2017) <[email protected]>" not changed
gpg: Total number processed: 3
gpg:              unchanged: 3


[[email protected] ~]# amportal a ma download framework

Fetching FreePBX settings with gen_amp_conf.php..

/var/lib/asterisk/bin/freepbx_engine: line 493: 31008 Killed                  $AMPBIN/module_admin $3 $4

Not sure what to try next. Thanks in advance for any tips.

You need to use the upgrade script as outlined here to get to 10.13.66

https://wiki.freepbx.org/display/PPS/FreePBX-Distro-6.12.65

Hi, Thanks for the speedy response, especially on a holiday weekend.

I tried running the update to 10.13.66 a few times and it won’t upgrade (although it runs the whole script)

STAGE 3 STARTING - Misc Items


Moving to Next Step

 Removing outdated modules
The following error(s) occured:
 - Specified module not found
The following error(s) occured:
 - Specified module not found
The following error(s) occured:
 - Specified module not found
The following error(s) occured:
 - Specified module not found
The following error(s) occured:
 - Specified module not found
The following error(s) occured:
 - Specified module not found
The following error(s) occured:
 - Specified module not found
 Update to FreePBX 13
trying to run as user asterisk:

[MODULEADMIN_SKIP_CACHE] already set to [1]

 update all FreePBX 13 modules now
trying to run as user asterisk:

[AMPSBIN] already set to [/usr/sbin]


Fetching FreePBX settings with gen_amp_conf.php..

Successfully reloaded
Error: fwconsole not correctly installed. Please run reload manually
Unlocked.
[[email protected] upgradescripts]# cat /etc/schmooze/pbx-version
6.12.65-32

I am very nervous that the bulk install with the system admin pro module I just purchased ran too many updates at once and broke things.

At this current time if I check online to get the updated modules on the GUI, the page breaks.

I am wondering if I should restore my backup and just run each upgrade one at a time myself, and forget this system admin upgrade thing.

I greatly appreciate your help.

I’m also getting this error in case it’s related:

chmod: cannot access/var/log/prosody’: No such file or directory`

and security issue error:

Module: “FreePBX Framework”, File: “/usr/sbin/amportal missing”

Anyone ever encountered anything similar?

Missing such an important component. i would make sure you are not on failing HDD or SSD, That your file-tables are OK for starts.