Upgrading FreePBX

Im running version and I have some PHP errors. I was thinking to upgrade to the newer version to fix it.

Can you please give the steps?

Browse to Admin, Module Admin. Updates will show up on both the System Updates tab and the Module Updates tab.

Is there a manual method? The system updates module says:

Last online check: 3 hours ago
No new updates

Can I do it manually?

Log into the console as ‘root’ and run “fwconsole -h”. That should get you the fwconsole help file, which will tell you exactly how to get the current status of your system updates.

Just go to fail2ban.org , download and install it from source, that way you get the latest version.

Please read and digest this first


and you will be good to go.

I want to download the most recent version and install it manually or via a script

Go to fail2ban and download freepbx? Im sorry. I dont get tht. I have seen the link, it discusses the security logs and threats. Nothing about freepbx upgrades

No, go to fail2ban.org and download fail2ban v9 . it comes with regexes for asterisk.there is no concept of FreePBX needed you just need to provide the asterisk log for it.

Is there a way that I download the new version and run a script and then it starts updating?

Can you explain to me what is good when we have fail2ban v9 logs? How would it help us upgrading?

No on line upgrading it doesn’t need it,

it needs to be (re)started after any iptables based firewall (re)starts, there are many jails available not just asterisk, ssh http mailservers and ftp servers to name a very few.

The best improvement among many is that the database is no longer ephemeral, bans last over reloads and boots.

I think you guys are misunderstanding what I need. I need to upgrade FreePBX complete. Not only fail2ban.

What errors have you got? Who says there’s upgrades available?..

There is no newer version than 12.7.4-1710-2.sng7? I read it somewhere

You probably read it in the System Updates tab 8)

I checked in there. When I ask the ststem to check online it goes in a loop. I think I have a broken setup. I need to install it manually

If you actually post the error (and this is the first time you’ve mentioned you HAVE an error on upgrades - you said ‘PHP error’ without any further information) people will be able to help. We are not mind readers. Please provide all the information.

PBX Firmware:12.7.3-1708-1.sng7

I went to the System updates tab and clicked Check Online.

It kept counting up to about 60 seconds and then came with the following error - Pink bar dancing up and down:

RPM command errored, Delete /dev/shm/yumwrapper/* and try again. Exit code 5 - see FreePBX log for more info.

I deleted the two log files and tried again - same result.

This is a halt in the php code - it now keeps displaying this message every time Module Admin is loaded until the log files are deleted.

Is this what the OP was talking about?

Hi Les:

Try running yum update from the bash prompt.

Done that and 796 updates later … problem fixed.

It now shows I’m up to date and

Current PBX Version:
Current System Version:**12.7.5-1807**-1.sng7  

compared to my first post

PBX Firmware:12.7.3-1708-1.sng7

and the current version is higher than was being quoted earlier in this thread.

Many thanks.

1 Like