Upgrades... sha1 mismatch

zulu
Tags: #<Tag:0x00007fb478932478>

(Jason) #1

The fact that Zulu was the only upgrade out of 80 that failed is a relief as I do not use Zulu.

The interesting thing about this is in years of working I have never seen this after a : fwconsole ma upgradeall

Considering I don’t use Zulu, I don’t really care about the fact it cant update.

It the why that confounds me. Why did this sha1 not match? Is this a common thing?

Thanks…


Zulu upgrade
(Matt Brooks) #2

@Scion This will happen if the download was incomplete or corrupted. From the looks of your screenshot, the sha1 check may have happened before the download was completed. My question is if this is repeatable? Does it happen every time you try to upgrade zulu?


(Jason) #3

Absolutely, every time.


(Matt Brooks) #4

There is probably a fwconsole command to do this, but I would try to remove the zulu module from the cache directory /var/www/html/admin/modules/_cache/ and retry.

Example:
rm /var/www/html/admin/modules/_cache/zulu-15.0.58.12.tgz.gpg


(Jason) #5

Thank you very much!

Here is the content of the directory. I notice the owner of the most recent is root instead of asterisk, interesting.

So, just blow all of those Zulu files away and try again?


(Matt Brooks) #6

@Scion interesting. I imagine the root owner may come from running fwconsole as root and the asterisk ownership probably comes from running it in the GUI.

But yes, it should be safe to blow those files away and retry.


(Jason) #7

So… Interesting.

I had to upgrade a COMPLETELY DIFFERENT PBX tonight because of fax issues (another story) and the same thing happened when it hit Zulu from fwconsole ma upgradeall from CLI.

Perhaps this is a colossal coincidence?


(Andrew) #8

Same network?


(Jason) #9

Nope. Separate VULTR cloud hosted instance. Not really surprising, isn’t Zulu dying on the vine?


(Jason) #10

I’m going to go out on a limb here. I host many, many, of these in the cloud. I bet this would occur on at least 90% if I ran that command from CLI at this point. BUT! The good news is, Zulu and I had a great battle in the past and I have moved on. I have not tried to delete the cached files yet because, I simply don’t care. I just hope this isn’t a issue for Zulu reliant folks.


(Phil) #11

I’m having exactly the same issue - SHA1 signature failure on latest offered zulu module, but like you, we don’t use it…so not too worried.


(Jared Busch) #12

You would be correct, but that is 100% not the problem with a SHA verification. Because I only ever upgrade from the command line with fwconsole and have never had this problem, ever.

The reason all of the rest of them are asterisk? because sudo fwconsole chown

This is how I upgrade systems (except when I am proving a point like now).

I chown always after upgrades, because history.

Here is what the script output earlier this month when I ran upgrades.
image
https://pastebin.freepbx.org/view/ed975aef


(Jared Busch) #13

The problem did not exist on June 29, 2021.
image
https://pastebin.freepbx.org/view/8032e4ec

image


(Jared Busch) #14

System that never had Zulu.


(TheJames) #15

When I experience an issue, rather than making assumptions I RTFM. If there is no friendly manual I RTFC…

A quick look at the friendly code we see the module xml from the mirror has an entry

<signed>
	<type>gpg</type>
	<sha1>443de78921edf2a06bb6d0885cbdb6cdab07f28e</sha1>
</signed>

So if we pull down the file:

<location>packages/zulu/5.6/zulu-14.0.58.10.tgz.gpg</location>

and run sha1sum zulu-14.0.58.10.tgz.gpg
we should get the same sha1 sum…

if not well the file is bad or the sum is…


(Jason) #16

Sum times things just go wrong…


(Simon Telephonics) #17

New install,

 - File Integrity failed for /var/www/html/admin/modules/_cache/zulu-15.0.58.12.tgz.gpg - aborting (sha1 did not match)

It looks like the most recent version that will pass validity check and install is 15.0.58.10:

fwconsole ma upgrade zulu --tag 15.0.58.10


(Lorne Gaetz) #18

Just did a test by running this on a 15 system:

fwconsole ma downloadinstall zulu --tag 15.0.58.12

module installed without issue. Is this resolved now, or are there people still seeing ths?


(John M) #19

Within the last 10 minutes I ran

fwconsole ma upgradeall

and got the sha1 error. I found this thread and tried

fwconsole ma downloadinstall zulu --tag 15.0.58.12

and it worked.


Zulu upgrade
(Ivana72) #20

correct, it is still happening on all systems. I’m also using the --tag to fix that.