Upgrade from 13 to 14 Error on phase 2

We use the update procedures located in the wiki (https://wiki.freepbx.org/display/PPS/Upgrading+from+Distro+6) and on phase two the system gets stuck in a loop when trying to install/upgrade through yum.

I see several errors simular to this one:

Error: Package: sangoma-pbx-1707-3.sng7.noarch (sng-pkgs)
Requires: asterisk-sounds-extra-en-ulaw
Removing: asterisk-sounds-extra-en-ulaw-1.5-2.sng7.noarch (installed)
asterisk-sounds-extra-en-ulaw = 1.5-2.sng7
Available: asterisk-sounds-extra-en-ulaw-1.5-1.2.noarch (sng-pkgs)
asterisk-sounds-extra-en-ulaw = 1.5-1.2
Available: asterisk-sounds-extra-en-ulaw-1.5-1.3.noarch (sng-pkgs)
asterisk-sounds-extra-en-ulaw = 1.5-1.3

As it continues the proccess it gets to “Running transaction test” then provides the error:

Transaction check error:
file /var/lib/asterisk/sounds/en/core-sounds-en.txt from install of asterisk-sounds-core-en-wideband-1.5-2.sng7.noarch conflicts with file from package asterisk-sounds-core-en-gsm-1.4.25-94_centos5.noarch

Any suggestions on where to start to trouble shoot this issue?

What version of the RPM did you install as the latest RPM done last week removes those old sound files.

I ran the cmd

yum -y install http://package1.sangoma.net/distro-upgrade-1707-12.sng7.noarch.rpm

So I am assuming it is the 1707-12 version.

I started the whole proccess last night at 8 PM est.

OK I just ran it now and it worked.

Can you PM me SSH access to your box so I can take a look

Did you find out the fix on this? Our machine is stuck at exactly the same looping error.

My system is stuck in this same loop. Did you find a solution?

We are working on it. Seems to be a issue with sound files and fail2ban that we had not seen before. Should have a new RPM published hopefully tonight still

So for the time being please do these command and re-run your script

yum install http://yum2.schmoozecom.net/schmooze-commercial/6/x86_64/RPMS/fail2ban/fail2ban-0.8.14-1.shmz65.1.131.noarch.rpm

rpm -e “asterisk-sounds-extra-en-gsm asterisk-sounds-core-en-gsm” --nodeps

Just checking–so run those commands and start over at
yum -y install …package1.sangoma.net/distro-upgrade-1707-12.sng7.noarch.rpm

Is that correct?

My system is up and running now but the GUI doesn’t work in the browser.

How did you get it to work? I keep hitting this new wall:

Another app is currently holding the yum lock; waiting for it to exit…
The other application is: yum
Memory : 107 M RSS (499 MB VSZ)
Started: Mon Aug 14 16:08:50 2017 - 00:13 ago
State : Running, pid: 2134

Thanks for any suggestions.

…oh, never mind that. I’m back in the error loop. I’ll hope for a miracle tonight so I don’t have to rebuild.

What do you mean a miracle. This is a beta upgrade script and says not to do it in production. Please tell me you did not do this in production.

If you just wait after running the yum command it should work after a minute or two. Make sure you are updating to the correct fail2ban. Version .131 not 1.30

Banners and links say 14 will help with several speed issues and other things we have fought with for the last year. I arrived at work this morning to a notice on the dashboard: new module available for installation. I go to modules, and sure enough, there is a new module to upgrade to 14. I install it. A new menu item is available to upgrade the system. It says it’s a FreePBX distro, so I must click here. I stepped my way through several notes of encouragement, none of which showed a skull and crossbones. Then on the last page it says it’s Beta. Good one.

Yes, it’s all my fault. I’m rebuilding overnight.

Hi!

You mean as in not accessible, not responding?

If so, if you issue

wget -qO- http://localhost | grep FreePBX

this from the command line of your system, what does this give you?

If you see something which has “FreePBX Administration” on the first line, the GUI actually works but is not accessible from the outside and I had that problem but thought it was related to my setup.

Are you using the FreePBX firewall? Is your system protected by another firewall?

In my case I am not using the FreePBX firewall and it is protected by another firewall… If you are in the same situation, please let me know and i will have something for you to try…

Good luck and have a nice day!

Nick

What do you mean. It says right on the wiki page at the top in Red

https://wiki.freepbx.org/display/PPS/Upgrading+from+Distro+6

Hi!

I didn’t know the upgrade script could be offered as a module but if this is indeed how you run this it should NOT have been made available as it is undergoing Beta testing.

@GameGamer43, @tm1000, @tonyclewis, @lgaetz any idea what is happening here?

Good luck and have a nice day!

Nick

Tony,

I ran “yum install http://yum.schmoozecom.net/schmooze-commercial/6/x86_64/RPMS/fail2ban/fail2ban-0.8.14-1.shmz65.1.131.noarch.rpm” (I changed it from .130 to 131 based on your last post) and that seemed to run fine, it showed it updated.

I ran the “rpm -e “asterisk-sounds-extra-en-gsm asterisk-sounds-core-en-gsm” --nodeps” cmd but that came back as “error: package asterisk-sounds-extra-en-gsm asterisk-sounds-core-en-gsm is not installed”

Rebooted the server and the same issue is occurring, same error as before.

I found the issue ticket tied to my post (15569) and I ran the follow cmds that seemed to get me past the loop.

“yum remove asterisk-sounds-core-en-gsm-1.4.25-94_centos5.noarch”

I’ll post if i have any other issues.

It is not a module. There is the normal FreePBX 13 to 14 upgrade module for users not on the distro but when you install it and try to use it says you have a FreePBX Distro and need to follow the wiki and link to wiki which at the very top says it’s beta.

The reason you need to use the upgrade scripts is FreePBX requires PHP 5.6 that is only available on SNG7 and not the old unsupported SHMZ OS 6 so we need to first upgrade the OS and all the packages.

2 Likes

Michael

You dont need to rebuild. What are your current logs showing is the problem. We just published a new RPM that resolves all open bugs.

If you run the following commands.

yum install http://yum2.schmoozecom.net/schmooze-commercial/6/x86_64/RPMS/fail2ban/fail2ban-0.8.14-1.shmz65.1.131.noarch.rpm

rpm -e “asterisk-sounds-extra-en-gsm asterisk-sounds-core-en-gsm” --nodeps

Now this command will restart the upgrade.

rm /var/run/post_sngupdate && /usr/sbin/post_upgrade

Now i am getting an httpd start error.

Aug 14 21:08:22 MyServer httpd[5983]: (98)Address already in use: AH00072: make_sock: could not bind to ad…:]:80
Aug 14 21:08:22 MyServer httpd[5983]: (98)Address already in use: AH00072: make_sock: could not bind to ad…0:96
Aug 14 21:08:22 MyServer httpd[5983]: no listening sockets available, shutting down
Aug 14 21:08:22 MyServer httpd[5983]: AH00015: Unable to open logs
Aug 14 21:08:22 MyServer systemd[1]: httpd.service: main process exited, code=exited, status=1/FAILURE
Aug 14 21:08:22 MyServer kill[5994]: kill: cannot find process ""
Aug 14 21:08:22 MyServer systemd[1]: httpd.service: control process exited, code=exited status=1
Aug 14 21:08:22 MyServer systemd[1]: Failed to start The Apache HTTP Server.
Aug 14 21:08:22 MyServer systemd[1]: Unit httpd.service entered failed state.
Aug 14 21:08:22 MyServer systemd[1]: httpd.service failed.
Hint: Some lines were ellipsized, use -l to show in full.

When I run a netstat --proto=inet,inet6 -pnl i do not see anything on those two ports.