Upgrade Asterisk Version from 1.8.25.0 to newest version

Asterisk 1.8.25.0 built by root @ jenkins-el6-64.schmoozecom.net on a x86_64 running Linux on 2013-12-18 22:04:30 UTC

When trying to upgrade, asterisk version by using yum it gave me tons of conflict errors. any thoughts?

Are you running the FreePBX distro? If so what version, 1.8 has been EOL for years.

I’m very new to all of this. How do I check?

If it’s the FreePBX distro, this will give you a version:

cat /etc/schmooze/pbx-version

It gave me 4.211.64-4

Quite a journey to start apparently

https://wiki.freepbx.org/display/PPS/FreePBX-Distro-4.211.64

(and that will get you to 5 :wink: On the way you will need to upgrade Asterisk from 1.8 to at least 13 )

I strongly recommend against upgrading in place. I would restore a backup from this to a new 15 install.

2 Likes

okay, I would prefer to do that as well. It should be a smooth transition?

A wise word choice, yes it should.

2 Likes

I am uploading my backup now. I will respond back if I have any issues.

Here are my logs:

I tried the restore and nothing happened:

Running with: /usr/sbin/fwconsole backup --restore=’/var/spool/asterisk/backup/uploads/20200212-082937-1581521377-895055246.tgz’ --transaction=‘93903291-1bc5-428b-afd6-79b7d49013e0’
Determining backup file type…type is legacy
Legacy CDR Restore Option: 0
Starting restore job with file: /var/spool/asterisk/backup/uploads/20200212-082937-1581521377-895055246.tgz
Extracting backup…
Backup extracted to /tmp/backup/93903291-1bc5-428b-afd6-79b7d49013e0. These files will remain until a new restore is run or until cleaned manually.
Loading manifest to memory
Loading astdb to memory
Parsing out SQL tables. This may take a moment depending on backup size.
Found 2 database files in the backup.
File named: /tmp/backup/93903291-1bc5-428b-afd6-79b7d49013e0/mysql-3.sql
Detected file /tmp/backup/93903291-1bc5-428b-afd6-79b7d49013e0/mysql-3.sql as the PBX (Asterisk) database. Attempting restore
Loading supplied database file mysql-3
SQLSTATE[HY000]: General error: 1 near “COMMENT”: syntax error

Upgrade all modules to current and then backup to edge with:

fwconsole ma upgrade backup --edge

on the new machine or the old machine?

On the new.

Okay, I ran that script. What does it do? Now do I try to restore?

Reload first

fwconsole reload

Then, yes.

Okay, it is running now. I will update once I have more info.

it finished and i got this:

Restore processing for modules are finished successfully
Apache will Restart now… And your GUI may die if the ports are changed !!!
Reloading… DONE
Running Post Restore Hooks… Please note that hook will restart httpd service so please refresh your page (using new ports)
Running Post Restore Hooks DONE
Finished
File named: /tmp/backup/f1933aa3-511b-4883-bfeb-d62933b22d31/mysql-4.sql
There were errors during the restore process
SQLSTATE[HY000]: General error: 1 no such table: callerid_entries on line 15 of file /var/www/html/admin/modules/callerid/Restore.php
SQLSTATE[HY000]: General error: 1 no such table: soundlang_packages on line 15 of file /var/www/html/admin/modules/soundlang/Restore.php
npm WARN deprecated [email protected]: Package no longer supported. Contact [email protected] for more info.

This may be dumb question. I am getting unable to connect to Asterisk. Do I need to have my Asterisk Card installed right now? Or should the service be getting installed and running?

So, once I run the backup - I am getting a message that Could not connect to asterisk.

I have tried fwconsole reload; fwconsole restart and I just get errors

[[email protected] ~]# fwconsole reload
Reload Started

In Reload.class.php line 835:

Unable to connect to Asterisk Manager

reload [–json] [–dry-run] [–skip-registry-checks] [–dont-reload-asterisk]