Unusual Network Setup and FreePBX

Hey there guys, I am using FreePBX in a VM on So You Start (OVH.) Dedicated Server.I have tried this in both ESXI, and Windows Hyper-V With the same issue. I realize I shouldn’t post all my network information here, but this is a test environment anyway, so hack away. (EDIT: Since its resolved I’m taking out my network information, I’m sure its archived somewhere, but just incase)

Okay, so this is where it gets confusing,
so My Host Machine (Currently Windows Hyper-V 2016, but ESXI had the same settings with the same behavior) has a network configuration of 158.xxx.xxx.xxx with a netmask of and a gateway of 167.xxx.xxx.xxx everything works fine, network connectivity, the next part is where it gets weird, (but is correct the settings work on all other VM’s)

IP of 167.xxx.xxx.xxx, Subnet Mask of /32 ( and a gateway of 158.xxx.xxx.xxx. With this configuration FreePBX Can not access the network., but no other VM’s have problems. I have tried the RC of Freepbx and the latest stable.

This network configuration works on all other OS’s, including Centos with cPanel installed, Ubuntu Server/Desktop, Windows Server 2016, the exception being pfsense, because it wont accept the network config at all.
I’ve tried googling and the only similar article I can find is Networking issue?
heres the link tot he OVH setup guide

Well… After 24 hours pretty much straight I couldn’t figure it out, I post this and the next thing you know I get it fixed. I don’t know what i did wrong the first time, but if you follow the OVH guide, exactly, it will work.

File: /etc/sysconfig/network-scripts/ifcfg-eth0


File : /etc/sysconfig/network-scripts/route-eth0

GATEWAY_VM dev eth0
default via >>>GATEWAY_VM<<<< dev eth0

(Replace >>>Gateway_VM<<<<<< with your gateway)

I’ve been searching for hours !!!
Your setup works perfectly, thanks a lot !

Glad it helped!