Networking issue

I’m attempting to setup FreePBX on a VPS for a client. The VPS uses bridged networking and is configured as it should be (with the IP’s MAC address, and the IP has worked flawlessly. on previous OSes that I install the same way, such as CentOS).

Upon setup I was introduced with a section that allowed me to enter my IPv4 details manually and disabled IPv6. I did this as necessary, but pinging doesn’t work and ‘some firstboot error occurred, and the system is not properly setup’ due to no internet.

So, I looked inside the ifcfg-eth0 file which is fine

And the 70-persistent-net.rules file which is fine (justified for better view but ensured it wasn’t saved)
(I can’t post more than one image, but I will give the extra screenshots if required)

I also looked inside etc/resolv.conf which is also fine
(I can’t post more than one image, but I will give the extra screenshots if required)

When restarting the network service it says everything is OK (including the IP I have entered)
(I can’t post more than one image, but I will give the extra screenshots if required)

But when using ‘route -n’ it seems to be depending on APIPA (169.254.0.0).
(I can’t post more than one image, but I will give the extra screenshots if required)

Pinging the default gateway does not work. It doesn’t seem to be making any attempt to use the manual information I have entered.

Any help would be greatly appreciated! Many thanks.

Your netmask is set to “255.255.255.255”. Are you sure that’s correct?

Is eth0 the only configuration file in /etc/sysconfig/network-scripts/? You have gateway defined in the ifcfg-eth0 file, which may or may not work depending on your set up. Interfaces are loaded sequentially (i.e. ifcfg-eth0, ifcfg-eth1, etc) and if you have a gateways defined in each of your ifcfg files, the last GATEWAY= statement will be used.

Check out dmesg and messages. Should give you more clues to what’s bonking on boot. You can also try manually assigning your IP/default gw with “ip route” and see if it throws an error.

Thanks a lot for your reply enderless.

255.255.255.255 is what OVH (the ISP) has written in their wiki for their external IPs when bridging them (I would provide a link but I’m unable to due to a forum limitation). I repeat the same configuration works with a blank CentOS installation and other OSes such as Debian and even Windows Server 2012. (same IP, netmask, etc).

As this is a separate post I think I can post another image now, here is a screenshot of what’s inside the network-scripts directory. From what I can see there is no other ethX file (only ifcfg-lo), so eth0 appears to be the only ‘adapter’ in use throughout this configuration:

It might also be important to mention that when typing ‘ifconfig etho0’ it shows this:

(IP REMOVED TO xx’s FOR SECURITY)
[[email protected] network-scripts]# ifconfig eth0
eth0 Link encap:Ethernet HWaddr 00:50:56:04:65:9F
inet addr:xx.xx.xx.xx Bcast:xx.xx.xx.xx Mask:255.255.255.255
inet6 addr: fe80::250:56ff:fe04:649f/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1150 errors:0 dropped:0 overruns:0 frame:0
TX packets:41 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:91040 (88.9 KiB) TX bytes:7322 (7.1 KiB)

Although this is the first time I’ve heard that you can manually assign network settings through ip route. Could you explain how to do this? (Unfortunately the keywords I’m using in Google seem to be of no help).

Many thanks!

At this point, you’re really going to need to speak to whoever’s providing this virtual machine. Something is strange about it, and I also find it extremely unlikely that your netmask is 255.255.255.255 - that’s for a point-to-point link, which this isn’t. Also, your broadcast looks wrong, but, you’ve censored it, so there’s not much we can do.

Sorry.

255.255.255.255 as a netmask says “This interface will talk to the address assigned and no other - routing is not possible on this interface.”

You cannot reach the gateway address without setting up an interface specific route.

This does seem like a very strange and largely unworkable configuration.

Hi xrobau and cynjut, thanks a lot for your responses!

Just to re-confirm, I am setting the service up for a client, and I therefore own the virtual machine myself and configure it necessarily. If the netmask is an issue, I will have to find the proper netmask for the IP - although as mentioned already the same network settings used works fine on a clean CentOS installation and many other OSes.

I’m not allowed to paste links, but hopefully it will allow me to write the link without www or http. The wiki page from OVH is as follows: help.ovh.co.uk/bridgeclient which states that I must use 255.255.255.255. If this is an ‘unworkable configuration’, I would appreciate help with this configuration as I am only going from what professional sources tell me.

I also apologise that I cannot provide the IP address. I am happy to provide uncensored screenshots privately through Skype or e-mail, but for the protection of my services and my customers I cannot publicly reveal the IPs. Rest assured the configuration is definitely correct.

Many thanks

(EDIT: For the record, I attempted with 255.0.0.0, 255.255.0.0 and 255.255.255.0, and restarted the network service each time, all of the netmasks have the same result.)

… and the webpage you pointed us to does, in fact, set up an interface specific route for the default route to your .254 gateway.

I’m going to guess that either the local firewall module is getting in the way, or that the rest of the gateway bridging interface hasn’t been set up correctly. Check to make sure the rest of your networking set (the stuff towards the bottom of the page) are set up correctly. Also, make sure that the things that are marked “Do not do these under any circumstances” are not set. Specifically, the default route which gets set in the FreePBX distro may be screwing up your access to the network.

From what I read, it looks like your problem is not in the Ethernet setup, but is in your routing setup.

Hi all And Terrum
I think i am the client and this problem is from my custom freepbx iso image
Terrum is now going to install the original centos server image on my VM
I can then install freepbx on my own hoping there are no problems with the virtual network adapters that can sometimes cause problems like the naming of the virtual network adapter i know the adapter need’s to be eth0

Terrum,

Like others have pointed out, a /32 netmask does not allow for a broadcast or gateway.

I checked out the documentation for OVH and it’s all over the place. For Ubuntu, it’s telling you to assign the same IP for the host and the broadcast. Windows 2003 example uses 255.255.0.0 while the other examples use 255.255.255.255. I’m not exactly sure what it’s referencing as far as a failover IP. The document seems to suggest a /24 network, claiming that the gateway is always @ .254. I found this (updated?) guide, but it still gives the same network recommendations.

Your MAC suggests an ESXi server, and your OS looks like CentOS. I’m not sure how things magically worked in the past, but perhaps the auto installer’s for your OS “fixed” the network settings. Manually trying to assign a gateway on a /32 in CentOS 6.7 throws the following error:

I would reach out to OVH and verify the settings needed for your VM. Also, the guide mentions setting /etc/sysconfig/network-scripts/route-eth0, but you didn’t list that in your setup.

Thanks a lot for your help enderless! I will be sorting this now either through the help of OVH or attempting to install FreePBX on top of a clean/working CentOS installation. Much appreciate the details and help regarding the issue!

@Terrum Thanks for trying after your install of the centos and then installing freepbx from the main wiki i have a perfect freepbx setup… only took about 30min to install and thats with custom sounds…

Thanks again for the time spent on the issue…

I guess you’re saying that you have a Dedicated machine with ovh.co.uk, and you’re trying to set up a VM on that dedicated machine.

Sadly, the instructions they’ve given you on that page ( http://help.ovh.co.uk/bridgeclient ) are pretty silly, and, are totally unneccesary. If you’re using standard KVM VMs then there’;s no need to mess around with the netmask.

What they’re saying to do is to treat the bridge (which is a broadcast interface) as a point-to-point interface, and then manually add a device route for the default gateway. You don’t need to do this, at all. Just configure the network as per normal, and everything will work.

In fact, by doing it the way they tell you to will explicitly stop you talking with other machines on the same network segment - maybe that’s what they’re trying to trick you into doing? Not much use if you want to have two machines that are MEANT to talk to each other.

Of course if they are doing something strange with the KVM host, then it’s possible they may have done something to require that setup, but I think it’s just lack of understanding of networking on their behalf.

1 Like