Unable to run YUM UPDATE

We have several servers where we can no longer run yum updates. The updates either hang out “running transactions” or we get these errors.

https://pastebin.com/jpmSrh2N

Do you have sangoma-devel installed. As it seems like you have an old version of it since your urls are directly pointing to 7.5 which is wrong.

yum remove sangoma-devel
yum clean all
yum upgrade

[[email protected] asterisk]# yum remove sangoma-devel
Loaded plugins: fastestmirror, versionlock
No Match for argument: sangoma-devel
No Packages marked for removal

Same result. Getting stuck at Running Transaction. I have let this go for an hour and nothing.

Total 15 MB/s | 455 MB 00:00:29
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction

“Running Transaction” happens locally. Has nothing to do with our mirror servers.

Searching the internet yields https://www.cyberciti.biz/faq/rhel-centos-fedora-redhat-yum-running-transaction-test-error/

You still have the issue that you are locked to 7.5 however.

FreePBX Distro 14.0.11

Getting the following error this afternoon on “yum check-update”. Tried three times.

http://sng7.com/os/7.5/os/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found

I’m curious how people are getting 7.5 in there as all distro systems should be http://sng7.com/os/7/os/x86_64/repodata/repomd.xml

cat /etc/yum/vars/releasever

yup same thing

http://sng7.com/os/7.5/os/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found

[[email protected] ~]# cat /etc/yum/vars/releasever
cat: /etc/yum/vars/releasever: No such file or directory
[[email protected] ~]#

You all just need to run: yum clean all

As your mirrors are cached.

1 Like

yeah that worked.

yum clean all
yum upgrade

503 packages updated
thanks!

I have no such file.

I’m attaching a file showing all the cached mirrorlist.txt file mod times and contents.

“yum clean all” did eliminate the yum errors, but now yum wants to update 243 packages. I just updated the system on 04/27!

typescript.tgz (445 Bytes)

Ok. This is normal though.

Did 7.6 transition to Stable some time between 04/27 and 04/29? I ask because now the cached mirrorlist.txt files are referencing 7.6 directories, whereas they were referencing 7.5 directories before “yum clean all”. I think that’s why I suddenly have 243 packages to be updated: it’s an update from 7.5 to 7.6.

See my latest post, 7.6 has just gone live, yay!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.