FreePBX | Register | Issues | Wiki | Portal | Support

Unable to register SPA303 to FreePBX v 12.0.86.2

configuration
Tags: #<Tag:0x00007fdfa5e1c918>

#21

My mistake. The server wouldn’t be listening on 5061


#22

Hi,

TO start with, I do not have a SPA303. But I have a couple of SPA301’s and I’ve seen dozens of SPA112’s, and if SPA303 is remotely similar to any of them, I don’t see why this should not work:

  • in the SPA303 SIP settings of the Ext[1 2 or 3], there should be a SIP port setting; (SPA112 has Line1 and Line2 SIP settings separate)

  • you MUST set a DIFFERENT SIP (listening) Port on every Ext ON THE SPA303. Period.

  • these are LISTENING ports. The ports your SPA303 listens ON. They have nothing to do with how the SPA303 contacts ports ON the servers.

  • there is no discrete setting for server SIP port on the SPA301 or SPA112 that I have.

So per your quote again,

means the SPA303 still sends the SIP dialog to lavoip to THEIR port 5060, but tells them that IT is on port 5060

There may be 2 things wrong here:

  • ensure your FreePBX is listening on a default port (5060) first - go to Asterisk SIP settings to check that
  • ensure your FreePBX Extension knows, that the SPA303 listens for it on port 5062 - go to the Extensions settings to check that. While at it, check you have same transport, same DTMF and same credentials on both FreePBX and SPA303 settings.

Same as for the Ext1, the lavoip server is really listening on port 5060 probably, but the SPA303 tells it, that IT is on port 5062 (some servers can show you this information while the extension is subscribed) (you can find out on SPA303’s voice status page, which port is the server talking do you FROM)

Hope this helps & is more or less accurate :wink:


#23

Thank you for the explanation but still no joy.

I have confirmed everything you said regarding Ext. 2 netstat -an | grep 5060 show FreePBX is listening on udp 0.0.0.0.

The FreePBX configuration specifies port 5062 for the extension and the SPA303 like specified 5062.

I double checked the credentials. If it was a credentials problem, I would get a different error message. The message I get on the SPA is FailedNot Reachable. If there were a firewall problem in the router, I would not be able to connect to losangeles.voip.ms either.


#24

Actually it might well be your router, my guess is you have a sip “alg/helper” application running that is not being helpful.


#25

The SPA, Zoiper on the desktop and Zoiper on the iPhone all go through the same router with no problems. My FreePBX registers to losangeles.voip.ms with no problem. The SPA gets the FailedNot reachable message. This is a TotoLink N300RT router.


#26

The clue is that it is not reachable, it is not a message, it is the result of a lack of message, that is always a network/router problem, use one of

sip set debug on
sip set debug ip . . .
sip set debug peer . .

and watch a call, pretty well guaranteed that you will see what is wrong.


#27

Sorry, I am a newb. Where do I set those debug options?


#28

at the asterisk CLI, but the wiki here and google can expand .


#29

I executed the following in the Asterirsk cli on the server

sip set debug on
sip set debug [ip of the phone]
sip set debug peer 10303

I checked the logs and don’t see any attempts at connecting from that IP address.

After I set debug off, I get “all circuits are busy now” on just about any call I make from any extension going through FreePBX. It is a bit intermittent but happens most of the time . I don’t know what caused that because I made no other changes other than setting debug on then off.

The two extensions on the phone registered at voip.ms directly are okay.

Anyway, I supposed I don’t see any evidence of the phone trying to connect so it “could” be a router problem I don’t know why the other two extensions on that phone can connect to losangeles.voip.ms

What might cause the circuits busy problem?


(William Lambert) #30

This discussion is really old, but hopefully this will help someone else. If you aren’t seeing any debug messages, take a look at your IPS/Fail-to-Ban list. I think there may have been a bug (?) in the Cisco firmware that didn’t allow all the characters for the default SIP Secret generated by FreePBX…which led to my device getting banned. Also, please pray that my hair grows back.