FreePBX | Register | Issues | Wiki | Portal | Support

Unable to register SPA303 to FreePBX v 12.0.86.2

configuration
Tags: #<Tag:0x00007fdf9947e9f8>

#1

I have installed FreePBX on Xenserver with some success. I can place outgoing and receive incoming calls, I can register with Zoiper on my iPhone and Windows 10 desktop but I cannot get my extension on my Cisco SPA 303 phone to register. I am a newbie about this and don’t find any info in the log that helps me identify the problem or even where it is.

I’ve put the relevant files in Dropbox so please take a look.

Log and configuration files


#2

I see a lot of views but no offers of assistance yet. Is there anything I am missing that would help someone in diagnosing this?


(Marbled) #3

Hi!

I am not sure if it’s the same problem but apparently the passwords generated by FreePBX are one character longer than what some Cisco products support…

see Help with registering Cisco 7940s in FreePBX

As to whether your phone as the same problem, I cannot say… When I see SPA I think of Sipura which is a company which was bought by Cisco to merge with its Linksys division so I do not know if the firmware of those phones are in any way related or not…

Try making your password shorter if it was auto-generated…

Good luck and have a nice day!

Nick


#4

Hi…thanks but I created the password myself and it is only 9 characters, The original one had a “!” in it so I removed that and now it is just a mixture of 9 alphanumeric characters.


#5

The error message on the SPA says “FailedNot reachable”


#6

Did you work thru the installation steps in the User Guide ?


Does your phone have an IP address ?


(Marbled) #7

Hi!

A couple of questions…

  • Is there a firewall between them?
  • Are they on the same subnet?
  • Did you specify the right subnet mask?
  • Did you specify an IP to connect to the PBX or an host name? If you specified an host name is it resolvable by DNS and did you provide the phone with the right DNS server?

You could try activating sip debugging (sip set debug on) but I would try checking for things like this with the message it’s giving you…

Good luck and have a nice day!

Nick


#8

Yes. I have been using this phone on voip.ms for several years. Two lines are registered to VoIP.ms but the third line is the one that won’t register to my SIP server


#9
  • The firewall on the SIP server is turned off. In fact, “service start iiptables” won’t even turn it on. It is stopped.
  • Yes. On the same subnet. The SIP server is 192.168.1.216 and the phone is 192.168.1.125.
  • The subnet mask on the SIP server is 255.255.255.0. There is no place to specify a subnet mask on the SPA303.
  • Connecting by IP address. There are two other extensions on the SPA303 that connect to voip.ms and they use DNS.

I’m new at this. Not sure how to set debugging on with the FreePBX gui.

From another computer on the same subnet, I tried to telnet to the SIP server on port 5060 and got a connection refused. Shouldn’t that be the default port?

ngrep -W byline -d eth0 port 5060 -O capture-file
on the SIP server produces reasonable output but I tried on a different computer on the same subnet and get no output so I suspect something is blocking port 5060 on the SIP server


#10

You can’t use telnet to connect to a UDP port, but your underlying problem is that you can’t have one host respond effectively to different servers on the same port, neither UDP nor TCP


#11

Yeah. I was checking around later with netstat and saw it was UDP.

I don’t quite understand your other statement. By “host” do you mean the phone? On this phone there are three extensions.


#12

So don’t use 5060 to LA tou already know it doesn’t work


#13

5060 to LA does work. Always has


#14

Not at the same time on the ame port to two servers, change one


#15

So I should change it so the Ext 1 and 3 are on 5060 and Ext 2 is on 5061?


#16

Change them all it to anything unique.


#17

I thought only port 5060 and 5061 are valid


#18

Okay. I have changed the ports on all extensions. They are 5060, 5061 and 5062 respectively.


#19

You can probably set your phone to talk to FreePBX server on port 5060, but your FreePBX server needs to talk to your phone on ITS port 5061. See the extension configuration on the FreePBX server.


#20

The extension is on 5061. When I run netstat, I don’t see 5061. I only see the server is listening on udp/5060