Unable to register Android Zoiper app to my server

I have just started getting a failure to register by my Android Zoiper app. The desktop version works fine as well as a Grandstream softphone I also have installed. I see nothing in the logs that show and attempt at registration.

The Grandstream Wave app is also on the same Android phone.

Zoiper shows this message:

Registration failed (Service unavailable (SBC failure)(503))

I have tried registering to different extensions with no success.

If I had to guess there is a problem with your SBC

What is SBC?

SBC stands for Session Border Controller
it’s a special device like a firewall for VOIP that sits between the PBX and the network
controlling connections to the PBX

https://www.zoiper.com/en/support/answer/for/windows/100/Informational_and_error_messages
SIP 503 / Transport Failure

This error message is shown when the server is unable to process the request for some reason, for example when the service you are trying to use is unavailable.
Please make sure all account details and the server hostname are entered correctly.

I only have the “Responsive Firewall” included with FreePBX. Other softphones can connect, both from the desktop and Android phone.

There are no other pieces of hardware or software involved.

Yes. All account details are correct. I have also used the IP address for the server just in case there was a DNS problem.

https://www.zoiper.com/en/support/home/category/2/Errors%20%26%20Problems

SIP 503

The issue that you are experiencing might be because the DNS server does not reply at times. (this could be a firewall issue, a problem with Windows o…

Last Modified: 2017-07-04 14:00:19

I’ve already seen that link. I have specified the IP address, not the host name

did you try using zoiper on the local network of the PBX

did you try using zoiper on the local network of the PBX

The PBX is on a VPS in the USA. I am in Cambodia. Not an option.

I have a VirtualBox installation on my laptop. I can try that.

that’s the process of elimination see if it works with your freepbx on LAN on VirtualBox
and then we’ll go from there

I have another softphone on the Android that is working fine. It’s definitely a Zoiper thing. I have uninstalled and re-installed but no joy.

It registers okay on the local VM

my zoiper setup

account name
[email protected]:5060

Host
200.999.777.236:5060

username
201

password
extension password

network settings
transport
TCP or UDP whatever your PBX uses

and i use a chan sip extension

on the setup screen use this format

username @ PBX/Voip provider
extension [email protected] public IP address:your SIP Port

password
Secret (extension password)

and when you’re trying deactivate the other softphone if you’re reusing the same extension

I turned on tcpdump. With the Zoiper, I can see no packets arriving at the server at all yet the local VM is receiving packets. When I enable the Grandstream softphone, I can see the packets on my server.

I’ve tried using just my 4G data and not over the wifi. Same thing.

I’ve got another phone I’ll try later.

With the tcpdump, a could see traffic to port 5060 when I would telnet to the server:

telnet freepbx.vietfeir.com 5060

This is a strange one

Well, wouldn’t you know it? I went out for lunch and while connected to another wifi, it registered. Now I am home and it is still registered. I unregistered and re-registered and it connects.