Unable to Receive Calls-

Hello Folks,
I’m running FreePbx 15.0.16 on Asterisk 16.6.
I’m unable to receive calls on my Voyant SIP Trunk UNLESS I have “Allow Annonymous Inbound SIP Calls” set to yes… If set to no, Caller gets “Number you have dialed is not in service”.
Single Voyant SIP Trunk for both Inbound and Outbound. Outbound calls work fine.
Asterisk Verbose shows the following on these inbound calls-
Executing [[email protected]:7] Log(“SIP/corpglobal.net-000000bb”, "WARNING,“Rejecting unknown SIP connection from 137.192.80.49"”) in new stack
Voyant SIP Trunk-
Server is corpglobal.net
Outbond Proxy is reg-gw.sip.global Resolves to 137.192.80.49
Trunk SIP Settings (Outgoing PEER Details)
username=3157400109
type=friend
trustrpid=yes
sendrpd=no
secret=xxxxxxxxxx
qualify=yes
port=5060
outboundproxy=reg-gw.sip.global
nat=yes
keepalive=45
insecure=port,invite
host=corpglobal.net
fromuser=3157400109
fromdomain=corpglobal.net
dtmfmode=rfc2833
disallow=all
directmedia=no
context=from-pstn-toheader
allow=ulaw
Incoming USER details-
type=friend
insecure=invite
context=from-trunk
outboundproxy=reg-gw.sip.global
Register String-
[email protected]:[email protected]:5060/3157400109
Please Help, any advice would be greatly appreciated. I don’t want to leave Allow anonymous calls.
Thank you,
Greg

Random Guess: PJSIP

By default PJSIP is on port 5060, so your inbound 5060 is getting sent to the PJSIP channel driver and it is not configured to do anything with Voyant. So it only lets the call come in while you have Anonymous enabled.

Use a PJSIP trunk and your problem will go away.

The log shows it as a chan_sip channel.

If I recall in chan_sip the outbound proxy is not used for matching. Just the “host” line is, you’d have to add another peer in chan_sip to match based on the outbound proxy instead.

Yes and he likely has PJSIP listening on 5060 as I said.

I don’t understand what you mean then? The log shows that chan_pjsip is not receiving the call, but chan_sip is as expected.

very useful!

You are correct. I misread that last night.

So, @gregstahl I have no idea what your problem may be without more details.

Sorry for the delay,
I have changed this to PJ SIP and set anonymous calls to no.

Trying to get the trunk registered to my carrier (Voyant).
Getting this-
[2020-01-12 12:49:28] WARNING[24595]: res_pjsip_outbound_registration.c:796 sche dule_retry: No response received from ‘sip:corpglobal.net:5060’ on registration attempt to ‘sip:[email protected]:5060’, retrying in ‘60’

My carrier advised to remove the route header that is being sent in the registration attempt and to set the qualify to 0.

I set the Qualify Frequency (under PJSIP Settings- Advanced) to 0. How do I remove the route header being sent in the registration attempt??

Thank you

You don’t. It’s required, removing it would break things even more.

You need to look if you are getting a response and if you’re not seeing one come back from them you need to contact them and find out if they are getting your request and are replying to it.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.