Unable to play voicemails on digium phone after update

Hello Everyone

i got recent update on my Freepbx server , everything was fine before the update but right now
when users receive voicemail on there desk phones and they try to play it will not play anything and it says Fetching voicemail messages and then it doesn’t play

before the update everything was fine
my freePBX version is
we use Digium phones , i have restart the server and check the setting nothing seems to be changed except the new update

How are you provisioning your phones, with Endpoint manager?

no there is no endpoint manager , it was totally fine all the sudden it stopped working after the update

How did you configure these phones? Manually?

Sounds like you are running into the exact same issue I had. Here is a link to my post below. Seems to me like a bad bug in DPMA 3.6.0, I’m assuming that’s what you upgraded to. Downgrading to DPMA 3.5.5 was the only way I could figure out to get it working again…

1 Like

Thanks for sharing

can you please help me out on rolling back DPMA version to 3.5.5
honestly i am kind of new in Freepbx

Not sure which version of asterisk you are on. For me these were the 2 key commands run from the command line. I’ll remove the version lock later once I know this issue is resolved in newer versions of DPMA.

yum downgrade asterisk16-res_digium_phone
yum versionlock asterisk16-res_digium_phone

when i run the command asterisk -r

it shows Asterisk 13.36.0

Ok, then I would guess the package name for you would be asterisk13-res_digium_phone

i have downgraded and it shows successfully

do i need to restart the server in order to apply

because on GUI still shows 3.6.0


Definitely reboot when you can.

many thanks for all your help i will do it later today hopefully this will fix it

Hello again

yes that worked now i am able to access voicemails , but i did use versionlock and then try to update , update got failed and now GUI is unaccessable , how can i undo versionlock command ?

There is a new version of DPMA published to the sangoma-devel repo that resolves this issue, DPMA version 3.6.3-rc1. Anyone who is in a position to test and provide feedback, is welcome to do so. Otherwise, it will be promoted to the packages repo in a few weeks.

Hi Igaetz,
I’m having this issue with 3.6.2, Where can get DPMA 3.6.3-rc1

I followed these steps to upgrades to 3.6.3

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.