Unable to play voicemails on digium phone after update


(United States) #1

Hello Everyone

i got recent update on my Freepbx server , everything was fine before the update but right now
when users receive voicemail on there desk phones and they try to play it will not play anything and it says Fetching voicemail messages and then it doesn’t play

before the update everything was fine
my freePBX version is 14.0.16.2
we use Digium phones , i have restart the server and check the setting nothing seems to be changed except the new update

20201220_143535


(Lorne Gaetz) #2

How are you provisioning your phones, with Endpoint manager?


(United States) #3

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)


(United States) #4

no there is no endpoint manager , it was totally fine all the sudden it stopped working after the update


(Itzik) #5

How did you configure these phones? Manually?


(Jdennis) #6

Sounds like you are running into the exact same issue I had. Here is a link to my post below. Seems to me like a bad bug in DPMA 3.6.0, I’m assuming that’s what you upgraded to. Downgrading to DPMA 3.5.5 was the only way I could figure out to get it working again…

https://community.freepbx.org/t/asterisk-16-15-dpma-3-6-0-and-visual-voice-mail-not-working/72077


(United States) #7

Thanks for sharing

can you please help me out on rolling back DPMA version to 3.5.5
honestly i am kind of new in Freepbx


(Jdennis) #8

Not sure which version of asterisk you are on. For me these were the 2 key commands run from the command line. I’ll remove the version lock later once I know this issue is resolved in newer versions of DPMA.

yum downgrade asterisk16-res_digium_phone
yum versionlock asterisk16-res_digium_phone


(United States) #9

when i run the command asterisk -r

it shows Asterisk 13.36.0


(Jdennis) #10

Ok, then I would guess the package name for you would be asterisk13-res_digium_phone


(United States) #11

i have downgraded and it shows successfully

downgrade

do i need to restart the server in order to apply

because on GUI still shows 3.6.0

GUI


(Jdennis) #12

Definitely reboot when you can.


(United States) #13

many thanks for all your help i will do it later today hopefully this will fix it


(United States) #14

Hello again

yes that worked now i am able to access voicemails , but i did use versionlock and then try to update , update got failed and now GUI is unaccessable , how can i undo versionlock command ?


(Lorne Gaetz) #15

There is a new version of DPMA published to the sangoma-devel repo that resolves this issue, DPMA version 3.6.3-rc1. Anyone who is in a position to test and provide feedback, is welcome to do so. Otherwise, it will be promoted to the packages repo in a few weeks.


(Kps Tech) #16

Hi Igaetz,
I’m having this issue with 3.6.2, Where can get DPMA 3.6.3-rc1

edit:
I followed these steps to upgrades to 3.6.3
https://wiki.asterisk.org/wiki/display/DIGIUM/DPMA+Installation